]> git.pld-linux.org Git - packages/perl-Net-SSLeay.git/blob - perl-Net-SSLeay.spec
ebe061b09eac6012cba4067ded6879c1b9dabc7d
[packages/perl-Net-SSLeay.git] / perl-Net-SSLeay.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Net::SSLeay - Perl extension for using OpenSSL or SSLeay
7 Summary(pl.UTF-8):      Net::SSLeay - rozszerzenie Perla do używania OpenSSL lub SSLeay
8 Name:           perl-Net-SSLeay
9 Version:        1.48
10 Release:        1
11 # same as openssl
12 License:        Apache-like
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Net/Net-SSLeay-%{version}.tar.gz
15 # Source0-md5:  4e10d9da28f26732e37807820bf72af5
16 Patch0:         %{name}-no_zlib.patch
17 URL:            http://search.cpan.org/dist/Net-SSLeay/
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  openssl-tools >= 0.9.7d
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-MIME-Base64
24 BuildRequires:  perl-Test-Simple >= 0.60_01
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module offers some high level convinience functions for accessing
30 web pages on SSL servers, a sslcat() function for writing your own
31 clients, and finally access to the SSL api of SSLeay/OpenSSL package
32 so you can write servers or clients for more complicated applications.
33
34 %description -l pl.UTF-8
35 Ten moduł oferuje kilka wygodnych funkcji wysokiego poziomu służących
36 do dostępu do stron WWW na serwerach SSL, funkcję sslcat() do pisania
37 własnych klientów, oraz dostęp do API SSL pakietu SSLeay/OpenSSL, co
38 pozwala na pisanie serwerów lub klientów dla bardziej skomplikowanych
39 aplikacji.
40
41 %prep
42 %setup -q -n Net-SSLeay-%{version}
43 %patch0 -p1
44
45 %build
46 echo "n" | %{__perl} Makefile.PL %{_prefix} \
47         INSTALLDIRS=vendor
48 %{__make} \
49         CC="%{__cc}" \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:echo "n" | %{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 install examples/*.{pl,conf} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Net/SSLeay.pod
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes Credits README
71 %{perl_vendorarch}/Net/SSLeay.pm
72 %{perl_vendorarch}/Net/SSLeay
73 %dir %{perl_vendorarch}/auto/Net/SSLeay
74 %{perl_vendorarch}/auto/Net/SSLeay/autosplit.ix
75 %{perl_vendorarch}/auto/Net/SSLeay/*.al
76 %{perl_vendorarch}/auto/Net/SSLeay/SSLeay.bs
77 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSLeay/SSLeay.so
78 %{_mandir}/man3/Net::SSLeay*.3pm*
79 %{_examplesdir}/%{name}-%{version}
This page took 0.074014 seconds and 2 git commands to generate.