]> git.pld-linux.org Git - packages/perl-Net-SSLeay.git/blob - perl-Net-SSLeay.spec
up to 1.84
[packages/perl-Net-SSLeay.git] / perl-Net-SSLeay.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Net::SSLeay - Perl extension for using OpenSSL or SSLeay
7 Summary(pl.UTF-8):      Net::SSLeay - rozszerzenie Perla do używania OpenSSL lub SSLeay
8 Name:           perl-Net-SSLeay
9 Version:        1.84
10 Release:        1
11 License:        Artistic v2.0
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Net/Net-SSLeay-%{version}.tar.gz
14 # Source0-md5:  cfbe968487149626978f427cc9fb8c77
15 Patch0:         %{name}-no_zlib.patch
16 URL:            http://search.cpan.org/dist/Net-SSLeay/
17 BuildRequires:  openssl-devel >= 0.9.7d
18 BuildRequires:  openssl-tools >= 0.9.7d
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-MIME-Base64
23 BuildRequires:  perl-Test-Simple >= 0.60_01
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module offers some high level convinience functions for accessing
29 web pages on SSL servers, a sslcat() function for writing your own
30 clients, and finally access to the SSL api of SSLeay/OpenSSL package
31 so you can write servers or clients for more complicated applications.
32
33 %description -l pl.UTF-8
34 Ten moduł oferuje kilka wygodnych funkcji wysokiego poziomu służących
35 do dostępu do stron WWW na serwerach SSL, funkcję sslcat() do pisania
36 własnych klientów, oraz dostęp do API SSL pakietu SSLeay/OpenSSL, co
37 pozwala na pisanie serwerów lub klientów dla bardziej skomplikowanych
38 aplikacji.
39
40 %prep
41 %setup -q -n Net-SSLeay-%{version}
42 %patch0 -p1
43
44 %build
45 echo "n" | %{__perl} Makefile.PL %{_prefix} \
46         INSTALLDIRS=vendor
47 %{__make} \
48         CC="%{__cc}" \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:echo "n" | %{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %{__make} pure_install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 cp -p examples/*.{pl,conf} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Net/SSLeay.pod
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes Credits LICENSE QuickRef README
70 %{perl_vendorarch}/Net/SSLeay.pm
71 %{perl_vendorarch}/Net/SSLeay
72 %dir %{perl_vendorarch}/auto/Net/SSLeay
73 %{perl_vendorarch}/auto/Net/SSLeay/autosplit.ix
74 %{perl_vendorarch}/auto/Net/SSLeay/*.al
75 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSLeay/SSLeay.so
76 %{_mandir}/man3/Net::SSLeay*.3pm*
77 %{_examplesdir}/%{name}-%{version}
This page took 0.038599 seconds and 3 git commands to generate.