]> git.pld-linux.org Git - packages/perl-Monitoring-Plugin.git/commitdiff
rename to Monitoring::Plugin, update to 0.37
authorElan Ruusamäe <glen@delfi.ee>
Thu, 4 Dec 2014 13:08:51 +0000 (15:08 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 4 Dec 2014 13:09:07 +0000 (15:09 +0200)
see: https://www.monitoring-plugins.org/news/new-project-name.html

perl-Monitoring-Plugin.spec [new file with mode: 0644]
perl-Nagios-Plugin.spec [deleted file]

diff --git a/perl-Monitoring-Plugin.spec b/perl-Monitoring-Plugin.spec
new file mode 100644 (file)
index 0000000..9f40105
--- /dev/null
@@ -0,0 +1,81 @@
+#
+# Conditional build:
+%bcond_without tests           # do not perform "make test"
+
+%define        pdir    Monitoring
+%define        pnam    Plugin
+%include       /usr/lib/rpm/macros.perl
+Summary:       Monitoring::Plugin - A family of Perl modules to streamline writing Monitoring plugins
+Summary(pl.UTF-8):     Monitoring::Plugin - rodzina modułów Perla ułatwiająca pisanie wtyczek Monitoringa
+Name:          perl-Monitoring-Plugin
+Version:       0.37
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://search.cpan.org/CPAN/authors/id/N/NI/NIERLEIN/Monitoring-Plugin-%{version}.tar.gz
+# Source0-md5: 4112350a23a20e9159ae002b8ce6bbf3
+URL:           http://search.cpan.org/dist/Monitoring-Plugin/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{with tests}
+BuildRequires: perl(Test::More) >= 0.62
+BuildRequires: perl-Class-Accessor
+BuildRequires: perl-Config-Tiny
+BuildRequires: perl-Math-Calc-Units
+BuildRequires: perl-Params-Validate
+%endif
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Monitoring::Plugin and its associated Monitoring::Plugin::* modules
+are a family of Perl modules to streamline writing Monitoring plugins.
+The main end user modules are Monitoring::Plugin, providing an
+object-oriented interface to the entire Monitoring::Plugin::*
+collection, and Monitoring::Plugin::Functions, providing a simpler
+functional interface to a useful subset of the available
+functionality.
+
+The purpose of the collection is to make it as simple as possible for
+developers to create plugins that conform the Monitoring Plugin
+guidelines <https://www.monitoring-plugins.org/doc/guidelines.html>.
+
+%description -l pl.UTF-8
+Monitoring::Plugin i związane z nim moduły Monitoring::Plugin::* to
+rodzina modułów Perla ułatwiająca pisanie wtyczek Monitoringa. Główne
+moduły dla użytkownika końcowego to Monitoring::Plugin, udostępniający
+zorientowany obiektowo interfejs do całej kolekcji
+Monitoring::Plugin::*, oraz Monitoring::Plugin::Functions,
+udostępniający prostszy, funkcyjny interfejs do przydatnego podzbioru
+dostępnej funkcjonalności.
+
+Celem tej kolekcji jest jak największe ułatwienie programistom
+tworzenia wtyczek zgodnych z zaleceniami dla wtyczek Monitoringa:
+<https://www.monitoring-plugins.org/doc/guidelines.html>.
+
+%prep
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%build
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc Changes README
+%dir %{perl_vendorlib}/Monitoring
+%{perl_vendorlib}/Monitoring/*.pm
+%{perl_vendorlib}/Monitoring/Plugin
+%{_mandir}/man3/Monitoring::Plugin*.3pm*
diff --git a/perl-Nagios-Plugin.spec b/perl-Nagios-Plugin.spec
deleted file mode 100644 (file)
index b3352a4..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-#
-# Conditional build:
-%bcond_without tests           # do not perform "make test"
-#
-%include       /usr/lib/rpm/macros.perl
-%define        pdir    Nagios
-%define        pnam    Plugin
-Summary:       Nagios::Plugin - A family of Perl modules to streamline writing Nagios plugins
-Summary(pl.UTF-8):     Nagios::Plugin - rodzina modułów Perla ułatwiająca pisanie wtyczek Nagiosa
-Name:          perl-Nagios-Plugin
-Version:       0.36
-Release:       1
-# same as perl
-License:       GPL v1+ or Artistic
-Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-authors/id/T/TO/TONVOON/Nagios-Plugin-%{version}.tar.gz
-# Source0-md5: b897f6d5d66a655dde7caec579efcf2e
-URL:           http://search.cpan.org/dist/Nagios-Plugin/
-BuildRequires: perl-devel >= 1:5.8.0
-BuildRequires: rpm-perlprov >= 4.1-13
-%if %{with tests}
-BuildRequires: perl-Class-Accessor
-BuildRequires: perl-Config-Tiny
-BuildRequires: perl-Math-Calc-Units
-BuildRequires: perl-Params-Validate
-BuildRequires: perl(Test::More) >= 0.62
-%endif
-# Not catched by `use base qw(Class::Accessor::Fast)'; construct
-Requires:      perl-Class-Accessor
-Requires:      perl-Config-Tiny
-BuildArch:     noarch
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-
-%description
-Nagios::Plugin and its associated Nagios::Plugin::* modules are a
-family of Perl modules to streamline writing Nagios plugins. The main
-end user modules are Nagios::Plugin, providing an object-oriented
-interface to the entire Nagios::Plugin::* collection, and
-Nagios::Plugin::Functions, providing a simpler functional interface to
-a useful subset of the available functionality.
-
-The purpose of the collection is to make it as simple as possible for
-developers to create plugins that conform the Nagios Plugin guidelines
-<http://nagiosplug.sourceforge.net/developer-guidelines.html>.
-
-%description -l pl.UTF-8
-Nagios::Plugin i związane z nim moduły Nagios::Plugin::* to rodzina
-modułów Perla ułatwiająca pisanie wtyczek Nagiosa. Główne moduły dla
-użytkownika końcowego to Nagios::Plugin, udostępniający zorientowany
-obiektowo interfejs do całej kolekcji Nagios::Plugin::*, oraz
-Nagios::Plugin::Functions, udostępniający prostszy, funkcyjny
-interfejs do przydatnego podzbioru dostępnej funkcjonalności.
-
-Celem tej kolekcji jest jak największe ułatwienie programistom
-tworzenia wtyczek zgodnych z zaleceniami dla wtyczek Nagiosa:
-<http://nagiosplug.sourceforge.net/developer-guidelines.html>.
-
-%prep
-%setup -q -n %{pdir}-%{pnam}-%{version}
-
-%build
-%{__perl} Makefile.PL \
-       INSTALLDIRS=vendor
-%{__make}
-
-%{?with_tests:%{__make} test}
-
-%install
-rm -rf $RPM_BUILD_ROOT
-
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%files
-%defattr(644,root,root,755)
-%doc Changes README
-%dir %{perl_vendorlib}/Nagios
-%{perl_vendorlib}/Nagios/*.pm
-%{perl_vendorlib}/Nagios/Plugin
-%{_mandir}/man3/*
This page took 0.072845 seconds and 4 git commands to generate.