]> git.pld-linux.org Git - packages/perl-List-MoreUtils.git/blob - perl-List-MoreUtils.spec
- updated to 0.09
[packages/perl-List-MoreUtils.git] / perl-List-MoreUtils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    List
7 %define         pnam    MoreUtils
8 Summary:        List::MoreUtils - provide the stuff missing in List::Util
9 Summary(pl):    List::MoreUtils - dostarczenie elementów brakuj±cych w List::Util
10 Name:           perl-List-MoreUtils
11 Version:        0.09
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  9d9399faadcd4cc5e98f4bb3e4089c81
18 URL:            http://search.cpan.org/dist/List-MoreUtils/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 List::MoreUtils provides some trivial but commonly needed
25 functionality on lists which is not going to go into List::Util.
26
27 All of the below functions are implementable in one line of Perl code.
28 Using the functions from this module however should give slightly
29 better performance as everything is implemented in C. The pure-Perl
30 implementation of these functions only serves as a fallback in case
31 the C portions of this module couldn't be compiled on this machine.
32
33 %description -l pl
34 List::MoreUtils dostarcza prostych, ale czêsto potrzebnych funkcji do
35 operacji na listach - elementy, które nie zostan± do³±czone do
36 List::Util.
37
38 Wszystkie z funkcji s± mo¿liwe do implementowania w jednej linijce
39 kodu Perla. U¿ywanie funkcji z tego modu³u mo¿e jednak daæ odrobinê
40 wiêksz± wydajno¶æ jako, ¿e ca³o¶æ zosta³a napisana w C. Implementacja
41 napisana w Perlu s³u¿y w sytuacjach wyj±tkowych w przypadkach, gdy
42 elementy modu³u napisane w C nie mog± zostaæ skompilowane na maszynie.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50
51 %{__make} \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorarch}/List/*.pm
69 %{_mandir}/man3/*
This page took 0.285982 seconds and 4 git commands to generate.