]> git.pld-linux.org Git - packages/perl-List-MoreUtils.git/blob - perl-List-MoreUtils.spec
- x32 rebuild
[packages/perl-List-MoreUtils.git] / perl-List-MoreUtils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    List
7 %define         pnam    MoreUtils
8 Summary:        List::MoreUtils - provide the stuff missing in List::Util
9 Summary(pl.UTF-8):      List::MoreUtils - dostarczenie elementów brakujących w List::Util
10 Name:           perl-List-MoreUtils
11 Version:        0.403
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/List/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ea3a04e59fdc599389370d1d6ddde7bc
18 URL:            http://search.cpan.org/dist/List-MoreUtils/
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.86
20 BuildRequires:  perl-ExtUtils-CBuilder >= 0.27
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Exporter-Tiny >= 0.038
25 BuildRequires:  perl-Test-Simple >= 0.90
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 List::MoreUtils provides some trivial but commonly needed
31 functionality on lists which is not going to go into List::Util.
32
33 All of the below functions are implementable in one line of Perl code.
34 Using the functions from this module however should give slightly
35 better performance as everything is implemented in C. The pure-Perl
36 implementation of these functions only serves as a fallback in case
37 the C portions of this module couldn't be compiled on this machine.
38
39 %description -l pl.UTF-8
40 List::MoreUtils dostarcza prostych, ale często potrzebnych funkcji do
41 operacji na listach - elementy, które nie zostaną dołączone do
42 List::Util.
43
44 Wszystkie z funkcji są możliwe do implementowania w jednej linijce
45 kodu Perla. Używanie funkcji z tego modułu może jednak dać odrobinę
46 większą wydajność jako, że całość została napisana w C. Implementacja
47 napisana w Perlu służy w sytuacjach wyjątkowych w przypadkach, gdy
48 elementy modułu napisane w C nie mogą zostać skompilowane na maszynie.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56
57 %{__make} \
58         CC="%{__cc}" \
59         OPTIMIZE="%{rpmcflags}"
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %dir %{perl_vendorarch}/List
76 %{perl_vendorarch}/List/MoreUtils.pm
77 %{perl_vendorarch}/List/MoreUtils
78 %dir %{perl_vendorarch}/auto/List/MoreUtils
79 %attr(755,root,root) %{perl_vendorarch}/auto/List/MoreUtils/MoreUtils.so
80 %{_mandir}/man3/List::MoreUtils*.3pm*
This page took 1.353106 seconds and 3 git commands to generate.