]> git.pld-linux.org Git - packages/perl-JSON-WebToken.git/blob - perl-JSON-WebToken.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-JSON-WebToken.git] / perl-JSON-WebToken.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    JSON
6 %define         pnam    WebToken
7 Summary:        JSON::WebToken - JSON Web Token (JWT) implementation
8 Name:           perl-JSON-WebToken
9 Version:        0.10
10 Release:        1
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/JSON/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  a68a0e415493495c5d3c516d854de047
15 URL:            https://metacpan.org/release/JSON-WebToken/
16 BuildRequires:  perl-Module-Build
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-JSON
21 BuildRequires:  perl-Module-Runtime
22 BuildRequires:  perl(Test::Mock::Guard) >= 0.07
23 BuildRequires:  perl-Test-Requires >= 0.06
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 JSON::WebToken is JSON Web Token (JWT) implementation for Perl
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Build.PL \
36         destdir=$RPM_BUILD_ROOT \
37         installdirs=vendor
38 ./Build
39
40 %{?with_tests:./Build test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 ./Build install
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes
53 %{perl_vendorlib}/JSON/*.pm
54 %{perl_vendorlib}/JSON/WebToken
55 %{_mandir}/man3/*
This page took 0.523595 seconds and 3 git commands to generate.