]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
- up to 1.54
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" - needs network connection
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    Socket-SSL
8 Summary:        IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
9 Summary(pl.UTF-8):      IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
10 Name:           perl-IO-Socket-SSL
11 Version:        1.54
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  3d091d3de33a8ca2fe5f75172b1a329b
19 URL:            http://search.cpan.org/dist/IO-Socket-SSL/
20 %if %{with tests}
21 BuildRequires:  perl-Net-SSLeay >= 1.33
22 BuildRequires:  perl-Scalar-List-Utils
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 Suggests:       perl-Net-IDN-Encode
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module is a true drop-in replacement for IO::Socket::INET that
32 uses SSL to encrypt data before it is transferred to a remote server
33 or client. IO::Socket::SSL supports all the extra features that one
34 needs to write a full-featured SSL client or server application:
35 multiple SSL contexts, cipher selection, certificate verification, and
36 SSL version selection. As an extra bonus, it works perfectly with
37 mod_perl.
38
39 %description -l pl.UTF-8
40 Ten moduł jest prawdziwym zamiennikiem dla IO::Socket::INET,
41 używającym SSL do kodowania danych przed przesyłaniem do zdalnego
42 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
43 rzeczy potrzebne do napisania w pełni funkcjonalnego klienta lub
44 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
45 certyfikatu, wybór wersji SSL. Ponadto wspaniale działa z mod_perlem.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 install example/* util/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Change* README docs/*
72 %{perl_vendorlib}/IO/Socket/SSL.pm
73 %{_mandir}/man3/IO::Socket::SSL.3pm*
74 %{_examplesdir}/%{name}-%{version}
This page took 0.125971 seconds and 4 git commands to generate.