]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
up to 2.076
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" - needs network connection
4 #
5 %define         pdir    IO
6 %define         pnam    Socket-SSL
7 Summary:        IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
8 Summary(pl.UTF-8):      IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
9 Name:           perl-IO-Socket-SSL
10 Version:        2.076
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  257995236a3ee5deaa9fe046b7d568f9
18 Patch0:         IO-Socket-SSL-2.068-use-system-default-SSL-version.patch
19 URL:            https://metacpan.org/release/IO-Socket-SSL
20 %if %{with tests}
21 BuildRequires:  perl-Net-SSLeay >= 1.46
22 BuildRequires:  perl-Scalar-List-Utils
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  rpmbuild(macros) >= 1.745
27 # actually Net::SSLeay using openssl >= 0.9.8
28 Requires:       openssl >= 0.9.8
29 Suggests:       perl-Mozilla-CA
30 Suggests:       perl-Net-IDN-Encode
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This module is a true drop-in replacement for IO::Socket::INET that
36 uses SSL to encrypt data before it is transferred to a remote server
37 or client. IO::Socket::SSL supports all the extra features that one
38 needs to write a full-featured SSL client or server application:
39 multiple SSL contexts, cipher selection, certificate verification, and
40 SSL version selection. As an extra bonus, it works perfectly with
41 mod_perl.
42
43 %description -l pl.UTF-8
44 Ten moduł jest prawdziwym zamiennikiem dla IO::Socket::INET,
45 używającym SSL do kodowania danych przed przesyłaniem do zdalnego
46 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
47 rzeczy potrzebne do napisania w pełni funkcjonalnego klienta lub
48 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
49 certyfikatu, wybór wersji SSL. Ponadto wspaniale działa z mod_perlem.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53 %patch0 -p0
54
55 %build
56 echo "n" | \
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/IO/Socket/SSL.pod
70
71 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72 cp -pr example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README docs/*
80 %{perl_vendorlib}/IO/Socket/SSL.pm
81 %{perl_vendorlib}/IO/Socket/SSL
82 %{_mandir}/man3/IO::Socket::SSL*.3pm*
83 %{_examplesdir}/%{name}-%{version}
This page took 0.107125 seconds and 3 git commands to generate.