]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
- version 0.97
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" - needs network connection
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    Socket-SSL
8 Summary:        IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
9 Summary(pl):    IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
10 Name:           perl-IO-Socket-SSL
11 Version:        0.97
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  34562e9475de132faa0f14ca2be053a5
19 BuildRequires:  perl-Net-SSLeay
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module is a true drop-in replacement for IO::Socket::INET that
27 uses SSL to encrypt data before it is transferred to a remote server
28 or client. IO::Socket::SSL supports all the extra features that one
29 needs to write a full-featured SSL client or server application:
30 multiple SSL contexts, cipher selection, certificate verification, and
31 SSL version selection. As an extra bonus, it works perfectly with
32 mod_perl.
33
34 %description -l pl
35 Ten modu³ jest prawdziwym zamiennikiem dla IO::Socket::INET,
36 u¿ywaj±cym SSL do kodowania danych przed przesy³aniem do zdalnego
37 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
38 rzeczy potrzebne do napisania w pe³ni funkcjonalnego klienta lub
39 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
40 certyfikatu, wybór wersji SSL. Ponadto wspaniale dzia³a z mod_perlem.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59 install example/* util/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Change* README docs/*
67 %{perl_vendorlib}/IO/Socket/SSL.pm
68 %{_mandir}/man3/*
69 %{_examplesdir}/%{name}-%{version}
This page took 0.850149 seconds and 3 git commands to generate.