]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
- S: perl-Net-IDN-Encode
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" - needs network connection
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    Socket-SSL
8 Summary:        IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
9 Summary(pl.UTF-8):      IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
10 Name:           perl-IO-Socket-SSL
11 Version:        1.34
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/IO/SULLR/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  c42dfa4172e6ee3673b5ead6709f7c04
19 URL:            http://search.cpan.org/dist/IO-Socket-SSL/
20 %if %{with tests}
21 BuildRequires:  perl-Net-SSLeay >= 1.21
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 Suggests:       perl-Net-IDN-Encode
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module is a true drop-in replacement for IO::Socket::INET that
31 uses SSL to encrypt data before it is transferred to a remote server
32 or client. IO::Socket::SSL supports all the extra features that one
33 needs to write a full-featured SSL client or server application:
34 multiple SSL contexts, cipher selection, certificate verification, and
35 SSL version selection. As an extra bonus, it works perfectly with
36 mod_perl.
37
38 %description -l pl.UTF-8
39 Ten moduł jest prawdziwym zamiennikiem dla IO::Socket::INET,
40 używającym SSL do kodowania danych przed przesyłaniem do zdalnego
41 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
42 rzeczy potrzebne do napisania w pełni funkcjonalnego klienta lub
43 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
44 certyfikatu, wybór wersji SSL. Ponadto wspaniale działa z mod_perlem.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63 install example/* util/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Change* README docs/*
71 %{perl_vendorlib}/IO/Socket/SSL.pm
72 %{_mandir}/man3/*
73 %{_examplesdir}/%{name}-%{version}
This page took 0.057129 seconds and 3 git commands to generate.