]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
up to 2.064
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" - needs network connection
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    Socket-SSL
8 Summary:        IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
9 Summary(pl.UTF-8):      IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
10 Name:           perl-IO-Socket-SSL
11 Version:        2.064
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  4f0d83a35fd8b3eb59f17d344724a6f1
19 URL:            http://search.cpan.org/dist/IO-Socket-SSL/
20 %if %{with tests}
21 BuildRequires:  perl-Net-SSLeay >= 1.46
22 BuildRequires:  perl-Scalar-List-Utils
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 # actually Net::SSLeay using openssl >= 0.9.8
27 Requires:       openssl >= 0.9.8
28 Suggests:       perl-Net-IDN-Encode
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module is a true drop-in replacement for IO::Socket::INET that
34 uses SSL to encrypt data before it is transferred to a remote server
35 or client. IO::Socket::SSL supports all the extra features that one
36 needs to write a full-featured SSL client or server application:
37 multiple SSL contexts, cipher selection, certificate verification, and
38 SSL version selection. As an extra bonus, it works perfectly with
39 mod_perl.
40
41 %description -l pl.UTF-8
42 Ten moduł jest prawdziwym zamiennikiem dla IO::Socket::INET,
43 używającym SSL do kodowania danych przed przesyłaniem do zdalnego
44 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
45 rzeczy potrzebne do napisania w pełni funkcjonalnego klienta lub
46 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
47 certyfikatu, wybór wersji SSL. Ponadto wspaniale działa z mod_perlem.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 echo "n" | \
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/IO/Socket/SSL.pod
67
68 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69 install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes README docs/*
77 %{perl_vendorlib}/IO/Socket/SSL.pm
78 %{perl_vendorlib}/IO/Socket/SSL
79 %{_mandir}/man3/IO::Socket::SSL*.3pm*
80 %{_examplesdir}/%{name}-%{version}
This page took 0.118193 seconds and 3 git commands to generate.