]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blob - perl-IO-Socket-SSL.spec
5bdbac6fa6ab2831276c38c122c19213d9bddce9
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" - needs network connection
4 #
5 %define         pdir    IO
6 %define         pnam    Socket-SSL
7 Summary:        IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
8 Summary(pl.UTF-8):      IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
9 Name:           perl-IO-Socket-SSL
10 Version:        2.073
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  43232d97e3898b0b0e79545568b7d751
18 Patch0:         IO-Socket-SSL-2.068-use-system-default-cipher-list.patch
19 Patch1:         IO-Socket-SSL-2.068-use-system-default-SSL-version.patch
20 URL:            https://metacpan.org/release/IO-Socket-SSL
21 %if %{with tests}
22 BuildRequires:  perl-Net-SSLeay >= 1.46
23 BuildRequires:  perl-Scalar-List-Utils
24 %endif
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildRequires:  rpmbuild(macros) >= 1.745
28 # actually Net::SSLeay using openssl >= 0.9.8
29 Requires:       openssl >= 0.9.8
30 Suggests:       perl-Mozilla-CA
31 Suggests:       perl-Net-IDN-Encode
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This module is a true drop-in replacement for IO::Socket::INET that
37 uses SSL to encrypt data before it is transferred to a remote server
38 or client. IO::Socket::SSL supports all the extra features that one
39 needs to write a full-featured SSL client or server application:
40 multiple SSL contexts, cipher selection, certificate verification, and
41 SSL version selection. As an extra bonus, it works perfectly with
42 mod_perl.
43
44 %description -l pl.UTF-8
45 Ten moduł jest prawdziwym zamiennikiem dla IO::Socket::INET,
46 używającym SSL do kodowania danych przed przesyłaniem do zdalnego
47 serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
48 rzeczy potrzebne do napisania w pełni funkcjonalnego klienta lub
49 serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
50 certyfikatu, wybór wersji SSL. Ponadto wspaniale działa z mod_perlem.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54 %patch0 -p0
55 %patch1 -p0
56
57 %build
58 echo "n" | \
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/IO/Socket/SSL.pod
72
73 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74 cp -pr example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc Changes README docs/*
82 %{perl_vendorlib}/IO/Socket/SSL.pm
83 %{perl_vendorlib}/IO/Socket/SSL
84 %{_mandir}/man3/IO::Socket::SSL*.3pm*
85 %{_examplesdir}/%{name}-%{version}
This page took 0.059721 seconds and 2 git commands to generate.