]> git.pld-linux.org Git - packages/perl-Glib.git/commitdiff
- updated to 1.329 auto/th/perl-Glib-1.329-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 2 Jul 2019 20:06:03 +0000 (22:06 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 2 Jul 2019 20:06:03 +0000 (22:06 +0200)
- added tests patch

perl-Glib-tests.patch [new file with mode: 0644]
perl-Glib.spec

diff --git a/perl-Glib-tests.patch b/perl-Glib-tests.patch
new file mode 100644 (file)
index 0000000..07fee76
--- /dev/null
@@ -0,0 +1,26 @@
+Something started to strip ending newlines from comments...
+--- Glib-1.329/t/g.t.orig      2012-01-06 07:26:40.000000000 +0100
++++ Glib-1.329/t/g.t   2019-07-02 22:02:39.461858950 +0200
+@@ -84,7 +84,7 @@
+       eq_array (\@bools, [FALSE, TRUE, FALSE]);
+       ok ($key_file->has_group('locales'));
+-      is ($key_file->get_comment('locales', 'mystring'), "some string\n");
++      is ($key_file->get_comment('locales', 'mystring'), "some string");
+       is ($key_file->get_string('locales', 'mystring'), 'Good morning');
+       is ($key_file->get_locale_string('locales', 'mystring', 'it'), 'Buongiorno');
+@@ -94,11 +94,11 @@
+       $key_file->set_string_list('listsection', 'stringlist', 'one', 'two', 'three');
+       $key_file->set_locale_string('locales', 'mystring', 'en', 'one');
+       $key_file->set_comment('locales', 'mystring', 'comment');
+-      is ($key_file->get_comment('locales', 'mystring'), "comment\n");
++      is ($key_file->get_comment('locales', 'mystring'), "comment");
+       $key_file->set_comment('locales', undef, "another comment\n");
+       is ($key_file->get_comment('locales', undef), "#another comment\n#");
+       $key_file->set_comment(undef, undef, 'one comment more');
+-      is ($key_file->get_comment(undef, undef), "one comment more\n");
++      is ($key_file->get_comment(undef, undef), "one comment more");
+       $key_file->set_boolean($start_group, 'boolkey', FALSE);
+       $key_file->set_value($start_group, 'boolkey', '0');
index 942d70caef3bff5eff15bd45541e970c3f85f868..99ff7461c18fbac671a48027f361db9ac8d7231f 100644 (file)
@@ -8,12 +8,13 @@ Summary:      Perl Glib bindings
 Summary(pl.UTF-8):     Wiązania Glib dla Perla
 Name:          perl-Glib
 # note: versions 1.x[13579]y are unstable, if you want them, please use DEVEL branch
-Version:       1.327
+Version:       1.329
 Release:       1
 License:       LGPL v2.1+
 Group:         Development/Languages/Perl
 Source0:       http://downloads.sourceforge.net/gtk2-perl/%{pnam}-%{version}.tar.gz
-# Source0-md5: e71fdca3c491e6395371c7bb0d92851a
+# Source0-md5: be860965e07065f1188e679fbac83dc0
+Patch0:                %{name}-tests.patch
 URL:           http://gtk2-perl.sourceforge.net/
 BuildRequires: glib2-devel >= 1:2.24.0
 BuildRequires: perl-ExtUtils-Depends >= 0.300
@@ -44,6 +45,7 @@ Pliki programistyczne wiązań Glib dla Perla.
 
 %prep
 %setup -q -n %{pnam}-%{version}
+%patch0 -p1
 
 %build
 %{__perl} Makefile.PL \
@@ -96,6 +98,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/Glib::Type.3pm*
 %{_mandir}/man3/Glib::Utils.3pm*
 %{_mandir}/man3/Glib::Variant.3pm*
+%{_mandir}/man3/Glib::VariantDict.3pm*
 %{_mandir}/man3/Glib::VariantType.3pm*
 %{_mandir}/man3/Glib::index.3pm*
 %{_mandir}/man3/Glib::version.3pm*
This page took 0.087733 seconds and 4 git commands to generate.