]> git.pld-linux.org Git - packages/perl-Glib.git/blob - perl-Glib.spec
- patch to remove compilator warnings added (doesn't help for make test not pass...
[packages/perl-Glib.git] / perl-Glib.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pnam    Glib
7 Summary:        Perl Glib bindings
8 Summary(pl):    Wi±zania Glib dla Perla
9 Name:           perl-Glib
10 Version:        1.020
11 Release:        1
12 License:        GPL
13 Group:          Development/Languages/Perl
14 Source0:        http://dl.sourceforge.net/gtk2-perl/%{pnam}-%{version}.tar.gz
15 # Source0-md5:  e80339fa6f4eddecf64056cec1731a03
16 Patch0:         %{name}-kill_warnings.patch
17 URL:            http://gtk2-perl.sf.net/
18 BuildRequires:  glib2-devel >= 2.0.0
19 BuildRequires:  perl-ExtUtils-Depends >= 0.1
20 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.00
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module provides perl access to Glib and GLib's GObject libraries.
27
28 %description -l pl
29 Ten modu³ daje dostêp z poziomu Perla do bibliotek GLib i GObject.
30
31 %prep
32 %setup -q -n %{pnam}-%{version}
33 %patch0 -p1
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38
39 %{__make} \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Glib/*.pod
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc AUTHORS ChangeLog README*
58 %{perl_vendorarch}/*.pm
59 %dir %{perl_vendorarch}/Glib
60 %{perl_vendorarch}/Glib
61 %dir %{perl_vendorarch}/auto/Glib
62 %attr(755,root,root) %{perl_vendorarch}/auto/Glib/Glib.so
63 %{perl_vendorarch}/auto/Glib/Glib.bs
64 %{_mandir}/man3/*
This page took 0.075469 seconds and 4 git commands to generate.