]> git.pld-linux.org Git - packages/perl-Glib.git/blob - perl-Glib.spec
- rebuild with perl 5.24.0
[packages/perl-Glib.git] / perl-Glib.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pnam    Glib
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Perl Glib bindings
8 Summary(pl.UTF-8):      Wiązania Glib dla Perla
9 Name:           perl-Glib
10 # note: versions 1.x[13579]y are unstable, if you want them, please use DEVEL branch
11 Version:        1.320
12 Release:        2
13 License:        LGPL v2.1+
14 Group:          Development/Languages/Perl
15 Source0:        http://downloads.sourceforge.net/gtk2-perl/%{pnam}-%{version}.tar.gz
16 # Source0-md5:  9cb020634d0b4d97152e629b1cadf54d
17 URL:            http://gtk2-perl.sourceforge.net/
18 BuildRequires:  glib2-devel >= 1:2.24.0
19 BuildRequires:  perl-ExtUtils-Depends >= 0.300
20 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.06
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       glib2 >= 1:2.24.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides Perl access to Glib and GLib's GObject libraries.
28
29 %description -l pl.UTF-8
30 Ten moduł daje dostęp z poziomu Perla do bibliotek GLib i GObject.
31
32 %package devel
33 Summary:        Development files for Perl Glib bindings
34 Summary(pl.UTF-8):      Pliki programistyczne wiązań Glib dla Perla
35 Group:          Development/Languages/Perl
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       glib2-devel >= 1:2.24.0
38
39 %description devel
40 Development files for Perl Glib bindings.
41
42 %description devel -l pl.UTF-8
43 Pliki programistyczne wiązań Glib dla Perla.
44
45 %prep
46 %setup -q -n %{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{perl_vendorarch}/{Gnome2,auto/Gnome2}
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Glib/*.pod
66 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Glib/Param/*.pod
67 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Glib/.packlist
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc AUTHORS NEWS README TODO
75 %{perl_vendorarch}/Glib.pm
76 %dir %{perl_vendorarch}/Glib
77 %{perl_vendorarch}/Glib/Object
78 %dir %{perl_vendorarch}/auto/Glib
79 %attr(755,root,root) %{perl_vendorarch}/auto/Glib/Glib.so
80 %{_mandir}/man3/Glib.3pm*
81 %{_mandir}/man3/Glib::BookmarkFile.3pm*
82 %{_mandir}/man3/Glib::Boxed.3pm*
83 %{_mandir}/man3/Glib::Bytes.3pm*
84 %{_mandir}/man3/Glib::Error.3pm*
85 %{_mandir}/man3/Glib::Flags.3pm*
86 %{_mandir}/man3/Glib::KeyFile.3pm*
87 %{_mandir}/man3/Glib::Log.3pm*
88 %{_mandir}/man3/Glib::MainLoop.3pm*
89 %{_mandir}/man3/Glib::Markup.3pm*
90 %{_mandir}/man3/Glib::Object*.3pm*
91 %{_mandir}/man3/Glib::OptionContext.3pm*
92 %{_mandir}/man3/Glib::OptionGroup.3pm*
93 %{_mandir}/man3/Glib::Param::*.3pm*
94 %{_mandir}/man3/Glib::ParamSpec.3pm*
95 %{_mandir}/man3/Glib::Signal.3pm*
96 %{_mandir}/man3/Glib::Type.3pm*
97 %{_mandir}/man3/Glib::Utils.3pm*
98 %{_mandir}/man3/Glib::Variant.3pm*
99 %{_mandir}/man3/Glib::VariantType.3pm*
100 %{_mandir}/man3/Glib::index.3pm*
101 %{_mandir}/man3/Glib::version.3pm*
102 # for Gnome2-related packages
103 %dir %{perl_vendorarch}/Gnome2
104 %dir %{perl_vendorarch}/auto/Gnome2
105
106 %files devel
107 %defattr(644,root,root,755)
108 %{perl_vendorarch}/Glib/CodeGen.pm
109 %{perl_vendorarch}/Glib/GenPod.pm
110 %{perl_vendorarch}/Glib/Install
111 %{perl_vendorarch}/Glib/MakeHelper.pm
112 %{perl_vendorarch}/Glib/ParseXSDoc.pm
113 %{_mandir}/man3/Glib::CodeGen.3pm*
114 %{_mandir}/man3/Glib::GenPod.3pm*
115 %{_mandir}/man3/Glib::MakeHelper.3pm*
116 %{_mandir}/man3/Glib::ParseXSDoc.3pm*
117 %{_mandir}/man3/Glib::devel.3pm*
118 %{_mandir}/man3/Glib::xsapi.3pm*
This page took 0.157187 seconds and 3 git commands to generate.