]> git.pld-linux.org Git - packages/perl-Email-Address.git/blob - perl-Email-Address.spec
- release 2
[packages/perl-Email-Address.git] / perl-Email-Address.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Email
7 %define pnam    Address
8 Summary:        Email::Address - RFC 2822 Address Parsing and Creation
9 Summary(pl):    Email::Address - Parsowanie i tworzenie adresów zgodnych z RFC 2822
10 Name:           perl-Email-Address
11 Version:        1.2
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b356b65411d4f52e02b8b0c9c0942e58
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This class implements a complete RFC 2822 parser that locates email
25 addresses in strings and returns a list of Email::Address objects
26 found. Alternatley you may construct objects manually. The goal of
27 this software is to be correct, very very fast, and API compatible
28 with the MailTools version. Did I mention fast?
29
30 %description -l pl
31 Ta klasa implementuje zgodny z RFC 2822 parser który lokalizuje adresy
32 email w ci±gach znaków i zwraca listê obiektów Email::Address. Mo¿liwe
33 jest tak¿e tworzenie takich obiektów rêczenie. Oprogramowanie to ma
34 byæ poprawne, bardzo bardzo szybkie, i z API zgodnym z MailTools. 
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/Email/*.pm
60 %{_mandir}/man3/*
This page took 0.076369 seconds and 4 git commands to generate.