]> git.pld-linux.org Git - packages/perl-DateTime.git/blob - perl-DateTime.spec
e34e50a1044070db00c92cdfc30d6d84d8847d03
[packages/perl-DateTime.git] / perl-DateTime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # perform "make test"
4
5 %define         pdir    DateTime
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        DateTime - representation of date/time combinations
8 Summary(pl.UTF-8):      DateTime - reprezentacja kombinacji daty i czasu
9 Name:           perl-DateTime
10 Version:        1.43
11 Release:        1
12 Epoch:          2
13 License:        Artistic v2.0
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  94d9fe0de84c2a473462ec9090f58ca6
17 URL:            http://datetime.perl.org/
18 BuildRequires:  perl(Pod::Man) >= 1.14
19 BuildRequires:  perl-Dist-CheckConflicts >= 0.02
20 BuildRequires:  perl-ExtUtils-CBuilder
21 BuildRequires:  perl-devel >= 1:5.8.4
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-CPAN-Meta-Check >= 0.011
25 BuildRequires:  perl-CPAN-Meta-Requirements
26 BuildRequires:  perl-DateTime-Format-Mail
27 BuildRequires:  perl-DateTime-Format-Strptime >= 1.2000
28 BuildRequires:  perl-DateTime-Locale >= 1.06
29 BuildRequires:  perl-DateTime-TimeZone >= 3:2.02
30 BuildRequires:  perl-Math-Round
31 BuildRequires:  perl-Params-ValidationCompiler >= 0.13
32 BuildRequires:  perl-Scalar-List-Utils
33 BuildRequires:  perl-Specio >= 0.18
34 BuildRequires:  perl-Storable
35 BuildRequires:  perl-Test-Fatal
36 BuildRequires:  perl-Test-Simple >= 0.96
37 BuildRequires:  perl-Test-Warnings >= 0.005
38 BuildRequires:  perl-Try-Tiny
39 BuildRequires:  perl-namespace-autoclean >= 0.19
40 %endif
41 Requires:       perl-base >= 1:5.8.7-3
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 DateTime is a class for the representation of date/time combinations,
46 and is part of the Perl DateTime project. For details on this project
47 please see <http://datetime.perl.org/>. The DateTime site has a FAQ
48 which may help answer many "how do I do X?" questions. The FAQ is at
49 <http://datetime.perl.org/faq.html>.
50
51 %description -l pl.UTF-8
52 DateTime to klasa do reprezentowania kombinacji daty i czasu, będąca
53 częścią perlowego projektu DateTime. Szczegóły dotyczące tego projektu
54 można znaleźć pod adresem <http://datetime.perl.org/>. Serwis ten ma
55 swoje FAQ, gdzie można znaleźć odpowiedzi na wiele pytań - dostępne
56 pod <http://datetime.perl.org/faq.html>.
57
58 %prep
59 %setup -q -n %{pdir}-%{version}
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 # for noarch DateTime::* modules
75 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/{Event,Format}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc CREDITS Changes TODO leaptab.txt
83 %dir %{perl_vendorlib}/DateTime/Event
84 %dir %{perl_vendorlib}/DateTime/Format
85 %{perl_vendorarch}/DateTime.pm
86 %{perl_vendorarch}/DateTime/*.pm
87 %dir %{perl_vendorarch}/auto/DateTime
88 %attr(755,root,root) %{perl_vendorarch}/auto/DateTime/DateTime.so
89 %{_mandir}/man3/DateTime*.3pm*
This page took 0.056369 seconds and 2 git commands to generate.