]> git.pld-linux.org Git - packages/perl-DBD-mysql.git/commitdiff
- 4.020 auto/th/perl-DBD-mysql-4_020-1 auto/ti/perl-DBD-mysql-4_020-1
authorlisu <lisu@pld-linux.org>
Fri, 7 Oct 2011 13:38:59 +0000 (13:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    headers.patch -> 1.2
    perl-DBD-mysql.spec -> 1.80

headers.patch
perl-DBD-mysql.spec

index 57ef9d57adadc5e91b50061f4ec7618b2f9eef67..738cedd036d9c547e02ccfefc82094d180abe60a 100644 (file)
@@ -1,14 +1,5 @@
---- DBD-mysql-4.018/dbdimp.h~  2010-07-10 17:53:52.000000000 +0300
-+++ DBD-mysql-4.018/dbdimp.h   2011-04-04 14:18:05.002129843 +0300
-@@ -333,3 +333,6 @@
- extern int mysql_db_reconnect(SV*);
- int mysql_st_free_result_sets (SV * sth, imp_sth_t * imp_sth);
-+#if MYSQL_VERSION_ID >= MULTIPLE_RESULT_SET_VERSION
-+int dbd_st_more_results(SV* sth, imp_sth_t* imp_sth);
-+#endif
---- DBD-mysql-4.018/dbdimp.h~  2011-04-04 14:19:08.000000000 +0300
-+++ DBD-mysql-4.018/dbdimp.h   2011-04-04 14:20:32.302207311 +0300
+--- DBD-mysql-4.020/dbdimp.h~  2011-08-20 20:35:59.000000000 +0200
++++ DBD-mysql-4.020/dbdimp.h   2011-10-07 15:37:51.615157851 +0200
 @@ -23,6 +23,8 @@
  #include <mysqld_error.h>  /* Comes MySQL */
  
@@ -16,5 +7,15 @@
 +#define is_prefix mysql_is_prefix      /* namespace sanity */
 +extern int is_prefix(const char *, const char *);
  
- /*
-  * This is the version of MySQL wherer
+ /* For now, we hardcode this, but in the future,
+  * we can detect capabilities of the MySQL libraries
+@@ -353,6 +355,9 @@
+ extern int mysql_db_reconnect(SV*);
+ int mysql_st_free_result_sets (SV * sth, imp_sth_t * imp_sth);
++#if MYSQL_VERSION_ID >= MULTIPLE_RESULT_SET_VERSION
++int dbd_st_more_results(SV* sth, imp_sth_t* imp_sth);
++#endif
+ #if MYSQL_ASYNC
+ int mysql_db_async_result(SV* h, MYSQL_RES** resp);
+ int mysql_db_async_ready(SV* h);
index c502cbe3a19fecc2942738fe9ee94e6bd6ffe4e8..4c0a9ed599c4a0330b79968e7080ae8db4ff055a 100644 (file)
@@ -24,13 +24,13 @@ Summary(sv.UTF-8):  Ett gränssnitt till MySQL för Perl
 Summary(uk.UTF-8):     Perl-інтерфейс до MySQL
 Summary(zh_CN.UTF-8):  Perl 的 MySQL 界面。
 Name:          perl-DBD-mysql
-Version:       4.018
-Release:       5
+Version:       4.020
+Release:       1
 # NOTE: libmysqlclient infects everything that links against it with GPL
 License:       GPL (Perl code also Artistic)
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/DBD/CAPTTOFU/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: d1d4ee2f20910d6491d1b6216471b2f1
+# Source0-md5: a2bf8808bbd45298e84dde06afbd58e9
 Patch0:                headers.patch
 URL:           http://search.cpan.org/dist/DBD-mysql/
 BuildRequires: mysql-devel >= 5.0.27
This page took 0.03297 seconds and 4 git commands to generate.