]> git.pld-linux.org Git - packages/performous.git/commitdiff
Fixed lib64 and some other cmake problems auto/th/performous-0.6.1-19
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 11 Jul 2012 22:23:18 +0000 (00:23 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 11 Jul 2012 22:23:18 +0000 (00:23 +0200)
Build with glib 2.32 and boost 1.50
Release 19

boost-1.50.patch [new file with mode: 0644]
cmake.patch [new file with mode: 0644]
glib2.32.patch [new file with mode: 0644]
performous.spec

diff --git a/boost-1.50.patch b/boost-1.50.patch
new file mode 100644 (file)
index 0000000..b9fb4ea
--- /dev/null
@@ -0,0 +1,92 @@
+--- Performous-0.6.1-Source/game/xtime.hh~     2010-10-31 17:05:43.000000000 +0100
++++ Performous-0.6.1-Source/game/xtime.hh      2012-07-11 23:32:18.102217244 +0200
+@@ -20,7 +20,7 @@
+       }
+       boost::xtime now() {
+               boost::xtime time;
+-              boost::xtime_get(&time, boost::TIME_UTC);
++              boost::xtime_get(&time, boost::TIME_UTC_);
+               return time;
+       }
+       double seconds(boost::xtime const& time) {
+--- Performous-0.6.1-Source/game/backgrounds.cc.orig   2012-07-11 23:39:56.532201074 +0200
++++ Performous-0.6.1-Source/game/backgrounds.cc        2012-07-11 23:41:57.872196793 +0200
+@@ -55,8 +55,8 @@
+               for (fs::directory_iterator dirIt(parent), dirEnd; m_loading && dirIt != dirEnd; ++dirIt) {
+                       fs::path p = dirIt->path();
+                       if (fs::is_directory(p)) { reload_internal(p); continue; }
+-                      std::string name = p.leaf(); // File basename
+-                      std::string path = p.directory_string(); // Path without filename
++                      std::string name = p.filename().string(); // File basename
++                      std::string path = p.string(); // Path without filename
+                       path.erase(path.size() - name.size());
+                       if (!regex_match(name.c_str(), match, expression)) continue;
+                       {
+--- Performous-0.6.1-Source/game/filemagic.hh.orig     2010-10-31 17:05:43.000000000 +0100
++++ Performous-0.6.1-Source/game/filemagic.hh  2012-07-12 00:03:24.689391875 +0200
+@@ -71,7 +71,7 @@
+               // For now, just check the extension an assume it's not lying.
+               // Get file extension in lower case
+-              std::string ext = filename.extension();
++              std::string ext = filename.extension().string();
+               // somehow this does not convert the extension to lower case:
+               //std::for_each(ext.begin(), ext.end(), static_cast<int(*)(int)>(std::tolower));
+               std::transform(ext.begin(), ext.end(), ext.begin(), ::tolower );
+--- Performous-0.6.1-Source/game/songs.cc.orig 2012-07-12 00:11:59.302707053 +0200
++++ Performous-0.6.1-Source/game/songs.cc      2012-07-12 00:12:34.382705813 +0200
+@@ -67,8 +67,8 @@
+               for (fs::directory_iterator dirIt(parent), dirEnd; m_loading && dirIt != dirEnd; ++dirIt) {
+                       fs::path p = dirIt->path();
+                       if (fs::is_directory(p)) { reload_internal(p); continue; }
+-                      std::string name = p.leaf(); // File basename (notes.txt)
+-                      std::string path = p.directory_string(); // Path without filename
++                      std::string name = p.filename().string(); // File basename (notes.txt)
++                      std::string path = p.string(); // Path without filename
+                       path.erase(path.size() - name.size());
+                       if (!regex_match(name.c_str(), match, expression)) continue;
+                       try {
+--- Performous-0.6.1-Source/game/cache.cc~     2010-10-31 17:05:43.000000000 +0100
++++ Performous-0.6.1-Source/game/cache.cc      2012-07-12 00:14:28.226035127 +0200
+@@ -9,7 +9,7 @@
+       fs::path constructSVGCacheFileName(fs::path const& svgfilename, double factor){
+               fs::path cache_filename;
+               std::string const lod = (boost::format("%.2f") % factor).str();
+-              std::string const cache_basename = svgfilename.filename() + ".cache_" + lod + ".png";
++              std::string const cache_basename = svgfilename.filename().string() + ".cache_" + lod + ".png";
+               if (isThemeResource(svgfilename)) {
+                       std::string const theme_name = (config["game/theme"].s().empty() ? "default" : config["game/theme"].s());
+--- Performous-0.6.1-Source/game/songparser-ini.cc~    2010-10-31 17:05:43.000000000 +0100
++++ Performous-0.6.1-Source/game/songparser-ini.cc     2012-07-12 00:15:52.466032156 +0200
+@@ -94,7 +94,7 @@
+       // Search the dir for the music files
+       for (boost::filesystem::directory_iterator dirIt(s.path), dirEnd; dirIt != dirEnd; ++dirIt) {
+               boost::filesystem::path p = dirIt->path();
+-              std::string name = p.leaf(); // File basename (notes.txt)
++              std::string name = p.filename().string(); // File basename (notes.txt)
+               if (regex_match(name.c_str(), match, midifile)) {
+                        s.midifilename = name;
+               } else if (regex_match(name.c_str(), match, audiofile_background)) {
+--- Performous-0.6.1-Source/game/fs.cc~        2010-10-31 17:05:43.000000000 +0100
++++ Performous-0.6.1-Source/game/fs.cc 2012-07-12 00:16:42.242697067 +0200
+@@ -127,7 +127,7 @@
+ bool isThemeResource(fs::path filename){
+       try {
+-              std::string themefile = getThemePath(filename.filename());
++              std::string themefile = getThemePath(filename.filename().string());
+               return themefile == filename;
+       } catch (...) { return false; }
+ }
+--- Performous-0.6.1-Source/game/songparser.cc~        2010-10-31 17:05:43.000000000 +0100
++++ Performous-0.6.1-Source/game/songparser.cc 2012-07-12 00:17:20.302695724 +0200
+@@ -101,7 +101,7 @@
+               for (boost::filesystem::directory_iterator dirIt(s.path), dirEnd; dirIt != dirEnd; ++dirIt) {
+                       boost::filesystem::path p = dirIt->path();
+-                      std::string name = p.leaf(); // File basename
++                      std::string name = p.filename().string(); // File basename
+                       if (m_song.cover.empty() && regex_match(name.c_str(), match, coverfile)) {
+                               m_song.cover = name;
+                       } else if (m_song.background.empty() && regex_match(name.c_str(), match, backgroundfile)) {
diff --git a/cmake.patch b/cmake.patch
new file mode 100644 (file)
index 0000000..c562e80
--- /dev/null
@@ -0,0 +1,66 @@
+--- Performous-0.6.1-Source/cmake/Modules/FindGlib.cmake~      2010-10-31 17:05:44.000000000 +0100
++++ Performous-0.6.1-Source/cmake/Modules/FindGlib.cmake       2012-07-11 23:22:12.095571956 +0200
+@@ -17,7 +17,7 @@
+ find_path(GlibConfig_INCLUDE_DIR
+   NAMES glibconfig.h
+   PATHS ${Glib_PKGCONF_INCLUDE_DIRS} /usr
+-  PATH_SUFFIXES lib/glib-2.0/include ../lib/glib-2.0/include
++  PATH_SUFFIXES lib${LIB_SUFFIX}/glib-2.0/include ../lib${LIB_SUFFIX}/glib-2.0/include
+ )
+ # Finally the library itself
+--- Performous-0.6.1-Source/cmake/Modules/FindGDK-PixBuf.cmake~        2010-10-31 17:05:44.000000000 +0100
++++ Performous-0.6.1-Source/cmake/Modules/FindGDK-PixBuf.cmake 2012-07-11 23:25:09.845565687 +0200
+@@ -14,7 +14,7 @@
+ find_path(GDK-PixBuf_INCLUDE_DIR
+   NAMES gdk-pixbuf/gdk-pixbuf.h
+   PATHS ${GDK-PixBuf_PKGCONF_INCLUDE_DIRS}
+-  PATH_SUFFIXES gtk-2.0
++  PATH_SUFFIXES gdk-pixbuf-2.0
+ )
+ # Finally the library itself
+--- Performous-0.6.1-Source/cmake/Modules/FindLibRSVG.cmake~   2010-10-31 17:05:44.000000000 +0100
++++ Performous-0.6.1-Source/cmake/Modules/FindLibRSVG.cmake    2012-07-11 23:26:57.155561898 +0200
+@@ -18,7 +18,7 @@
+ find_path(LibRSVG_INCLUDE_DIR
+   NAMES librsvg/rsvg.h
+   PATHS ${LibRSVG_PKGCONF_INCLUDE_DIRS}
+-  PATH_SUFFIXES librsvg-2
++  PATH_SUFFIXES librsvg-2.0
+ )
+ # Finally the library itself
+--- Performous-0.6.1-Source/cmake/Modules/FindSigC++.cmake~    2010-10-31 17:05:44.000000000 +0100
++++ Performous-0.6.1-Source/cmake/Modules/FindSigC++.cmake     2012-07-11 23:29:10.248890540 +0200
+@@ -17,7 +17,7 @@
+ find_path(SigC++Config_INCLUDE_DIR
+   NAMES sigc++config.h
+   PATHS ${SigC++_PKGCONF_INCLUDE_DIRS} /usr
+-  PATH_SUFFIXES lib/sigc++-2.0/include ../lib/sigc++-2.0/include
++  PATH_SUFFIXES lib${LIB_SUFFIX}/sigc++-2.0/include ../lib${LIB_SUFFIX}/sigc++-2.0/include
+ )
+ # Finally the library itself
+--- Performous-0.6.1-Source/cmake/Modules/FindGlibmm.cmake~    2010-10-31 17:05:44.000000000 +0100
++++ Performous-0.6.1-Source/cmake/Modules/FindGlibmm.cmake     2012-07-11 23:29:52.625555711 +0200
+@@ -21,7 +21,7 @@
+ find_path(GlibmmConfig_INCLUDE_DIR
+   NAMES glibmmconfig.h
+   PATHS ${Glibmm_PKGCONF_INCLUDE_DIRS} /usr
+-  PATH_SUFFIXES lib/glibmm-2.4/include ../lib/glibmm-2.4/include
++  PATH_SUFFIXES lib${LIB_SUFFIX}/glibmm-2.4/include ../lib${LIB_SUFFIX}/glibmm-2.4/include
+ )
+ # Finally the library itself
+--- Performous-0.6.1-Source/cmake/Modules/FindLibXML++.cmake~  2010-10-31 17:05:44.000000000 +0100
++++ Performous-0.6.1-Source/cmake/Modules/FindLibXML++.cmake   2012-07-11 23:30:33.782220925 +0200
+@@ -21,7 +21,7 @@
+ find_path(LibXML++Config_INCLUDE_DIR
+   NAMES libxml++config.h
+   PATHS ${LibXML++_PKGCONF_INCLUDE_DIRS} /usr
+-  PATH_SUFFIXES lib/libxml++-2.6/include ../lib/libxml++-2.6/include
++  PATH_SUFFIXES lib${LIB_SUFFIX}/libxml++-2.6/include ../lib${LIB_SUFFIX}/libxml++-2.6/include
+ )
+ # Finally the library itself
diff --git a/glib2.32.patch b/glib2.32.patch
new file mode 100644 (file)
index 0000000..1650924
--- /dev/null
@@ -0,0 +1,11 @@
+--- Performous-0.6.1-Source/game/unicode.cc~   2010-10-31 17:05:43.000000000 +0100
++++ Performous-0.6.1-Source/game/unicode.cc    2012-07-12 00:18:01.832694262 +0200
+@@ -2,7 +2,7 @@
+ #include <boost/scoped_ptr.hpp>
+ #include <glibmm/ustring.h>
+-#include <glib/gconvert.h>
++#include <glib.h>
+ #include <sstream>
+ #include <stdexcept>
index af7c03d7e4e3318c717e28ec76b4d41272e36ce3..abcee57541f875b7ad989d889ede662064a878b6 100644 (file)
@@ -6,13 +6,16 @@ Summary:      Performous - The All-in-One Music Game
 Summary(pl.UTF-8):     Performous - wiele gier muzycznych w jednej
 Name:          performous
 Version:       0.6.1
-Release:       18
+Release:       19
 License:       GPL v2+
 Group:         Applications
 Source0:       http://downloads.sourceforge.net/performous/Performous-%{version}-Source.tar.bz2
 # Source0-md5: 451a759de77984b5a699e91107fe52e2
 Patch0:                %{name}-ffmpeg.patch
 Patch1:                %{name}-libpng15.patch
+Patch2:                cmake.patch
+Patch3:                boost-1.50.patch
+Patch4:                glib2.32.patch
 URL:           http://performous.org/
 BuildRequires: ImageMagick-c++-devel
 BuildRequires: SDL-devel
@@ -72,14 +75,17 @@ Zestaw narzędzi do konwersji danych dla programu Performous.
 %setup -qn Performous-%{version}-Source
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
 mkdir build
 
 %build
 cd build
 %cmake .. \
        -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
-       -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags} -DBOOST_FILESYSTEM_VERSION=2" \
-       -DCMAKE_DEBUG_FLAGS_RELEASE="%{debugcflags} -DBOOST_FILESYSTEM_VERSION=2" \
+       -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags}" \
+       -DCMAKE_DEBUG_FLAGS_RELEASE="%{debugcflags}" \
        -DCMAKE_INSTALL_PREFIX=%{_prefix} \
 %if "%{_lib}" == "lib64"
        -DLIB_SUFFIX=64
This page took 0.079407 seconds and 4 git commands to generate.