]> git.pld-linux.org Git - packages/performous.git/commitdiff
- updated to 0.7.0 auto/th/performous-0.7.0-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 13 Nov 2012 11:54:52 +0000 (12:54 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 13 Nov 2012 11:54:52 +0000 (12:54 +0100)
- removed obsolete patches

boost-1.50.patch [deleted file]
glib2.32.patch [deleted file]
performous-ffmpeg.patch [deleted file]
performous.spec

diff --git a/boost-1.50.patch b/boost-1.50.patch
deleted file mode 100644 (file)
index b9fb4ea..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
---- Performous-0.6.1-Source/game/xtime.hh~     2010-10-31 17:05:43.000000000 +0100
-+++ Performous-0.6.1-Source/game/xtime.hh      2012-07-11 23:32:18.102217244 +0200
-@@ -20,7 +20,7 @@
-       }
-       boost::xtime now() {
-               boost::xtime time;
--              boost::xtime_get(&time, boost::TIME_UTC);
-+              boost::xtime_get(&time, boost::TIME_UTC_);
-               return time;
-       }
-       double seconds(boost::xtime const& time) {
---- Performous-0.6.1-Source/game/backgrounds.cc.orig   2012-07-11 23:39:56.532201074 +0200
-+++ Performous-0.6.1-Source/game/backgrounds.cc        2012-07-11 23:41:57.872196793 +0200
-@@ -55,8 +55,8 @@
-               for (fs::directory_iterator dirIt(parent), dirEnd; m_loading && dirIt != dirEnd; ++dirIt) {
-                       fs::path p = dirIt->path();
-                       if (fs::is_directory(p)) { reload_internal(p); continue; }
--                      std::string name = p.leaf(); // File basename
--                      std::string path = p.directory_string(); // Path without filename
-+                      std::string name = p.filename().string(); // File basename
-+                      std::string path = p.string(); // Path without filename
-                       path.erase(path.size() - name.size());
-                       if (!regex_match(name.c_str(), match, expression)) continue;
-                       {
---- Performous-0.6.1-Source/game/filemagic.hh.orig     2010-10-31 17:05:43.000000000 +0100
-+++ Performous-0.6.1-Source/game/filemagic.hh  2012-07-12 00:03:24.689391875 +0200
-@@ -71,7 +71,7 @@
-               // For now, just check the extension an assume it's not lying.
-               // Get file extension in lower case
--              std::string ext = filename.extension();
-+              std::string ext = filename.extension().string();
-               // somehow this does not convert the extension to lower case:
-               //std::for_each(ext.begin(), ext.end(), static_cast<int(*)(int)>(std::tolower));
-               std::transform(ext.begin(), ext.end(), ext.begin(), ::tolower );
---- Performous-0.6.1-Source/game/songs.cc.orig 2012-07-12 00:11:59.302707053 +0200
-+++ Performous-0.6.1-Source/game/songs.cc      2012-07-12 00:12:34.382705813 +0200
-@@ -67,8 +67,8 @@
-               for (fs::directory_iterator dirIt(parent), dirEnd; m_loading && dirIt != dirEnd; ++dirIt) {
-                       fs::path p = dirIt->path();
-                       if (fs::is_directory(p)) { reload_internal(p); continue; }
--                      std::string name = p.leaf(); // File basename (notes.txt)
--                      std::string path = p.directory_string(); // Path without filename
-+                      std::string name = p.filename().string(); // File basename (notes.txt)
-+                      std::string path = p.string(); // Path without filename
-                       path.erase(path.size() - name.size());
-                       if (!regex_match(name.c_str(), match, expression)) continue;
-                       try {
---- Performous-0.6.1-Source/game/cache.cc~     2010-10-31 17:05:43.000000000 +0100
-+++ Performous-0.6.1-Source/game/cache.cc      2012-07-12 00:14:28.226035127 +0200
-@@ -9,7 +9,7 @@
-       fs::path constructSVGCacheFileName(fs::path const& svgfilename, double factor){
-               fs::path cache_filename;
-               std::string const lod = (boost::format("%.2f") % factor).str();
--              std::string const cache_basename = svgfilename.filename() + ".cache_" + lod + ".png";
-+              std::string const cache_basename = svgfilename.filename().string() + ".cache_" + lod + ".png";
-               if (isThemeResource(svgfilename)) {
-                       std::string const theme_name = (config["game/theme"].s().empty() ? "default" : config["game/theme"].s());
---- Performous-0.6.1-Source/game/songparser-ini.cc~    2010-10-31 17:05:43.000000000 +0100
-+++ Performous-0.6.1-Source/game/songparser-ini.cc     2012-07-12 00:15:52.466032156 +0200
-@@ -94,7 +94,7 @@
-       // Search the dir for the music files
-       for (boost::filesystem::directory_iterator dirIt(s.path), dirEnd; dirIt != dirEnd; ++dirIt) {
-               boost::filesystem::path p = dirIt->path();
--              std::string name = p.leaf(); // File basename (notes.txt)
-+              std::string name = p.filename().string(); // File basename (notes.txt)
-               if (regex_match(name.c_str(), match, midifile)) {
-                        s.midifilename = name;
-               } else if (regex_match(name.c_str(), match, audiofile_background)) {
---- Performous-0.6.1-Source/game/fs.cc~        2010-10-31 17:05:43.000000000 +0100
-+++ Performous-0.6.1-Source/game/fs.cc 2012-07-12 00:16:42.242697067 +0200
-@@ -127,7 +127,7 @@
- bool isThemeResource(fs::path filename){
-       try {
--              std::string themefile = getThemePath(filename.filename());
-+              std::string themefile = getThemePath(filename.filename().string());
-               return themefile == filename;
-       } catch (...) { return false; }
- }
---- Performous-0.6.1-Source/game/songparser.cc~        2010-10-31 17:05:43.000000000 +0100
-+++ Performous-0.6.1-Source/game/songparser.cc 2012-07-12 00:17:20.302695724 +0200
-@@ -101,7 +101,7 @@
-               for (boost::filesystem::directory_iterator dirIt(s.path), dirEnd; dirIt != dirEnd; ++dirIt) {
-                       boost::filesystem::path p = dirIt->path();
--                      std::string name = p.leaf(); // File basename
-+                      std::string name = p.filename().string(); // File basename
-                       if (m_song.cover.empty() && regex_match(name.c_str(), match, coverfile)) {
-                               m_song.cover = name;
-                       } else if (m_song.background.empty() && regex_match(name.c_str(), match, backgroundfile)) {
diff --git a/glib2.32.patch b/glib2.32.patch
deleted file mode 100644 (file)
index 1650924..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- Performous-0.6.1-Source/game/unicode.cc~   2010-10-31 17:05:43.000000000 +0100
-+++ Performous-0.6.1-Source/game/unicode.cc    2012-07-12 00:18:01.832694262 +0200
-@@ -2,7 +2,7 @@
- #include <boost/scoped_ptr.hpp>
- #include <glibmm/ustring.h>
--#include <glib/gconvert.h>
-+#include <glib.h>
- #include <sstream>
- #include <stdexcept>
diff --git a/performous-ffmpeg.patch b/performous-ffmpeg.patch
deleted file mode 100644 (file)
index 5058fca..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur Performous-0.6.1-Source.org/game/ffmpeg.cc Performous-0.6.1-Source/game/ffmpeg.cc
---- Performous-0.6.1-Source.org/game/ffmpeg.cc 2010-10-31 17:05:43.000000000 +0100
-+++ Performous-0.6.1-Source/game/ffmpeg.cc     2011-09-11 21:20:47.661140779 +0200
-@@ -60,8 +60,8 @@
-       for (unsigned int i=0; i<pFormatCtx->nb_streams; i++) {
-               AVCodecContext* cc = pFormatCtx->streams[i]->codec;
-               cc->workaround_bugs = FF_BUG_AUTODETECT;
--              if (videoStream == -1 && cc->codec_type==CODEC_TYPE_VIDEO) videoStream = i;
--              if (audioStream == -1 && cc->codec_type==CODEC_TYPE_AUDIO) audioStream = i;
-+              if (videoStream == -1 && cc->codec_type==AVMEDIA_TYPE_VIDEO) videoStream = i;
-+              if (audioStream == -1 && cc->codec_type==AVMEDIA_TYPE_AUDIO) audioStream = i;
-       }
-       if (videoStream == -1 && decodeVideo) throw std::runtime_error("No video stream found");
-       if (audioStream == -1 && decodeAudio) throw std::runtime_error("No audio stream found");
index 47a3e5b7138f4b3f44f1ad2a010c2561b337a4fd..158473c4ef5ac11a39306f9f4fc95d6f2bd27c9f 100644 (file)
@@ -5,17 +5,14 @@
 Summary:       Performous - The All-in-One Music Game
 Summary(pl.UTF-8):     Performous - wiele gier muzycznych w jednej
 Name:          performous
-Version:       0.6.1
-Release:       20
+Version:       0.7.0
+Release:       1
 License:       GPL v2+
 Group:         Applications
-Source0:       http://downloads.sourceforge.net/performous/Performous-%{version}-Source.tar.bz2
-# Source0-md5: 451a759de77984b5a699e91107fe52e2
-Patch0:                %{name}-ffmpeg.patch
+Source0:       http://downloads.sourceforge.net/performous/performous-%{version}.tar.bz2
+# Source0-md5: 60f3f72b51a630a4aa996484aedb9526
 Patch1:                %{name}-libpng15.patch
 Patch2:                cmake.patch
-Patch3:                boost-1.50.patch
-Patch4:                glib2.32.patch
 URL:           http://performous.org/
 BuildRequires: ImageMagick-c++-devel
 BuildRequires: SDL-devel
@@ -72,12 +69,9 @@ Several utilities for converting data files for Performous.
 Zestaw narzędzi do konwersji danych dla programu Performous.
 
 %prep
-%setup -qn Performous-%{version}-Source
-%patch0 -p1
+%setup -q
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
 mkdir build
 
 %build
This page took 0.132243 seconds and 4 git commands to generate.