]> git.pld-linux.org Git - packages/percona-server.git/commitdiff
- use /var/lib/mysql for db always
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 11 Oct 2017 11:57:08 +0000 (13:57 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 11 Oct 2017 11:57:08 +0000 (13:57 +0200)
percona-server.init
percona-server.spec

index 073a5975934176d3757f9dc5aeb01957520b7409..31724f9ccf1f0104beec7cfbc4ecb179c08d0f61 100755 (executable)
@@ -35,8 +35,8 @@ else
        nls "Warning: Missing clusters config file %s" /etc/percona-server/clusters.conf
        if [ -z "$MYSQL_DB_CLUSTERS" ]; then
                nls "Warning: there are no configured clusters."
-               nls "Using default cluster /var/lib/percona-server (compatibility mode)"
-               MYSQL_DB_CLUSTERS=/var/lib/percona-server
+               nls "Using default cluster /var/lib/mysql (compatibility mode)"
+               MYSQL_DB_CLUSTERS=/var/lib/mysql
        fi
 fi
 
@@ -160,7 +160,7 @@ mysqlgetconfig() {
        local mode="$2"
 
        # emulate old behaviour if only one cluster specified
-       if [ "$clusterdir" = "$MYSQL_DB_CLUSTERS" -a "$clusterdir" = "/var/lib/percona-server" -a -f /etc/mysqld.conf ]; then
+       if [ "$clusterdir" = "$MYSQL_DB_CLUSTERS" -a "$clusterdir" = "/var/lib/mysql" -a -f /etc/mysqld.conf ]; then
                MYSQL_RA_COMPAT=yes
                config_file=/etc/mysqld.conf
        else
index de45e31f7d96ea681e86ada129bea39314a55efb..42369ef55ad1d8b787e4806d73d25eb2f38247ce 100644 (file)
@@ -842,7 +842,7 @@ fi
 
 %attr(700,mysql,mysql) %{_perconahome}
 # root:root is proper here for mysql.rpm while mysql:mysql is potential security hole
-%attr(751,root,root) /var/lib/%{name}
+%attr(751,root,root) /var/lib/mysql
 %attr(750,mysql,mysql) %dir /var/log/%{name}
 %attr(750,mysql,mysql) %dir /var/log/archive/%{name}
 %attr(640,mysql,mysql) %ghost /var/log/%{name}/*
This page took 0.03962 seconds and 4 git commands to generate.