]> git.pld-linux.org Git - packages/percona-server.git/commitdiff
Up to 5.7.41-44.1 auto/th/percona-server-5.7.41-44.1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 19 Apr 2023 14:59:33 +0000 (16:59 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 19 Apr 2023 14:59:33 +0000 (16:59 +0200)
build.patch
openssl-3.patch [deleted file]
percona-server.spec

index b5a14499c0fd29c1881c5e9cf6e213d1a9103207..7e116e51307fb7962fb895824aa89e9d30bb63af 100644 (file)
@@ -9,22 +9,10 @@
      OUTPUT_VARIABLE SCRIPT_OUTPUT
      WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
    )
-From 9dddf90bf54cfa29d14d199d19ad07d4590fbb1e Mon Sep 17 00:00:00 2001
-From: Thomas Deutschmann <whissi@gentoo.org>
-Date: Thu, 30 Apr 2020 22:55:34 +0200
-Subject: [PATCH 2/8] cmake: Remove -Werror
-
-Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
----
- cmake/maintainer.cmake | 6 ------
- 1 file changed, 6 deletions(-)
-
-diff --git a/cmake/maintainer.cmake b/cmake/maintainer.cmake
-index 19db0d34f..3ed806be4 100644
---- a/cmake/maintainer.cmake
-+++ b/cmake/maintainer.cmake
-@@ -37,12 +37,6 @@ IF(CMAKE_CXX_COMPILER_ID MATCHES "Clang"
-       "${MY_CXX_WARNING_FLAGS} -Wno-null-conversion -Wno-unused-private-field")
+--- a/cmake/maintainer.cmake~  2023-02-28 18:21:35.000000000 +0100
++++ b/cmake/maintainer.cmake   2023-04-19 16:21:27.342942580 +0200
+@@ -45,12 +45,6 @@ IF(CMAKE_CXX_COMPILER_ID MATCHES "Clang"
+   STRING_APPEND(MY_CXX_WARNING_FLAGS " -Wno-unused-parameter -Wno-unused-but-set-variable")
  ENDIF()
  
 -# Turn on Werror (warning => error) when using maintainer mode.
diff --git a/openssl-3.patch b/openssl-3.patch
deleted file mode 100644 (file)
index 79f2f4d..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
---- mysql-5.7.31/cmake/ssl.cmake.orig  2020-06-02 13:05:42.000000000 +0200
-+++ mysql-5.7.31/cmake/ssl.cmake       2021-09-26 10:27:27.431001078 +0200
-@@ -172,20 +172,28 @@
-       #   #define OPENSSL_VERSION_NUMBER 0x1000103fL
-       # Encoded as MNNFFPPS: major minor fix patch status
-       FILE(STRINGS "${OPENSSL_INCLUDE_DIR}/openssl/opensslv.h"
--        OPENSSL_VERSION_NUMBER
--        REGEX "^#[ ]*define[\t ]+OPENSSL_VERSION_NUMBER[\t ]+0x[0-9].*"
-+        OPENSSL_VERSION_MAJOR
-+        REGEX "^#[ ]*define[\t ]+OPENSSL_VERSION_MAJOR[\t ]+([0-9]+).*"
-         )
-       STRING(REGEX REPLACE
--        "^.*OPENSSL_VERSION_NUMBER[\t ]+0x([0-9]).*$" "\\1"
--        OPENSSL_MAJOR_VERSION "${OPENSSL_VERSION_NUMBER}"
-+        "^#[ ]*define[\t ]+OPENSSL_VERSION_MAJOR[\t ]+([0-9]+).*" "\\1"
-+        OPENSSL_MAJOR_VERSION ${OPENSSL_VERSION_MAJOR}
-+        )
-+      FILE(STRINGS "${OPENSSL_INCLUDE_DIR}/openssl/opensslv.h"
-+        OPENSSL_VERSION_MINOR
-+        REGEX "^#[ ]*define[\t ]+OPENSSL_VERSION_MINOR[\t ]+([0-9]+).*"
-         )
-       STRING(REGEX REPLACE
--        "^.*OPENSSL_VERSION_NUMBER[\t ]+0x[0-9]([0-9][0-9]).*$" "\\1"
--        OPENSSL_MINOR_VERSION "${OPENSSL_VERSION_NUMBER}"
-+        "^#[ ]*define[\t ]+OPENSSL_VERSION_MINOR[\t ]+([0-9]+).*" "\\1"
-+        OPENSSL_MINOR_VERSION ${OPENSSL_VERSION_MINOR}
-+        )
-+      FILE(STRINGS "${OPENSSL_INCLUDE_DIR}/openssl/opensslv.h"
-+        OPENSSL_VERSION_PATCH
-+        REGEX "^#[ ]*define[\t ]+OPENSSL_VERSION_PATCH[\t ]+([0-9]+).*"
-         )
-       STRING(REGEX REPLACE
--        "^.*OPENSSL_VERSION_NUMBER[\t ]+0x[0-9][0-9][0-9]([0-9][0-9]).*$" "\\1"
--        OPENSSL_FIX_VERSION "${OPENSSL_VERSION_NUMBER}"
-+        "^#[ ]*define[\t ]+OPENSSL_VERSION_PATCH[\t ]+([0-9]+).*" "\\1"
-+        OPENSSL_FIX_VERSION ${OPENSSL_VERSION_PATCH}
-         )
-     ENDIF()
-     SET(OPENSSL_VERSION
-@@ -203,7 +211,7 @@
-     IF(OPENSSL_INCLUDE_DIR AND
-        OPENSSL_LIBRARY   AND
-        CRYPTO_LIBRARY      AND
--       OPENSSL_MAJOR_VERSION STREQUAL "1"
-+       (OPENSSL_MAJOR_VERSION STREQUAL "1" OR OPENSSL_MAJOR_VERSION STREQUAL "3")
-       )
-       SET(OPENSSL_FOUND TRUE)
-     ELSE()
---- percona-server-5.7.31-34/sql/mysqld.cc~    2020-08-15 11:23:18.000000000 +0200
-+++ percona-server-5.7.31-34/sql/mysqld.cc     2021-09-26 16:17:42.275241856 +0200
-@@ -161,6 +161,7 @@
- #if defined(HAVE_OPENSSL)
- #include <openssl/crypto.h>
-+#include <openssl/evp.h>
- #endif
- #ifndef EMBEDDED_LIBRARY
-@@ -3689,15 +3689,15 @@
- static int init_ssl()
- {
- #ifdef HAVE_OPENSSL
--  int fips_mode= FIPS_mode();
-+  int fips_mode = EVP_default_properties_is_fips_enabled(NULL);
-   if (fips_mode != 0)
-   {
-     /* FIPS is enabled, Log warning and Disable it now */
-     sql_print_warning(
-         "Percona Server cannot operate under OpenSSL FIPS mode."
-         " Disabling FIPS.");
--    FIPS_mode_set(0);
-+    EVP_set_default_properties(NULL, "fips=no");
-   }
- #if OPENSSL_VERSION_NUMBER < 0x10100000L
-   CRYPTO_malloc_init();
- #else /* OPENSSL_VERSION_NUMBER < 0x10100000L */
index 99cbb38f2ccdcb389af15999e144c6c4231414f8..e67a9604183f8d05410698ef096bfdc57d53a717 100644 (file)
@@ -50,8 +50,8 @@
 %undefine      with_coredumper
 %endif
 
-%define                rel     2
-%define                percona_rel     41
+%define                rel     1
+%define                percona_rel     44
 Summary:       Percona Server: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     Percona Server: ist eine SQL-Datenbank
 Summary(fr.UTF-8):     Percona Server: un serveur SQL rapide et fiable
@@ -61,12 +61,12 @@ Summary(ru.UTF-8):  Percona Server - быстрый SQL-сервер
 Summary(uk.UTF-8):     Percona Server - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  Percona Server数据库服务器
 Name:          percona-server
-Version:       5.7.38
+Version:       5.7.41
 Release:       %{percona_rel}.%{rel}
 License:       GPL + Percona Server FLOSS Exception
 Group:         Applications/Databases
 Source0:       https://downloads.percona.com/downloads/Percona-Server-5.7/LATEST/source/tarball/%{name}-%{version}-%{percona_rel}.tar.gz
-# Source0-md5: 4d499d3881a2496db2d537d6c9ff30ce
+# Source0-md5: fa49686b60b4148bc6d351b8ba6b9ef8
 Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.11-release.tar.gz
 # Source100-md5:       5cac34f3d78a9d612ca4301abfcbd666
 %if %{without system_boost}
@@ -97,7 +97,6 @@ Patch6:               mysql-chain-certs.patch
 # from fedora
 Patch7:                mysql-dubious-exports.patch
 Patch8:                mysql-cmake.patch
-Patch9:                openssl-3.patch
 URL:           https://www.percona.com/software/mysql-database/percona-server
 BuildRequires: bison >= 1.875
 BuildRequires: cmake >= 2.8.2
@@ -500,9 +499,6 @@ cd ../..
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
-%if "%(pkg-config --modversion libssl)" >= "3.0"
-%patch9 -p1
-%endif
 
 # to get these files rebuild
 [ -f sql/sql_yacc.cc ] && %{__rm} sql/sql_yacc.cc
This page took 0.183413 seconds and 4 git commands to generate.