]> git.pld-linux.org Git - packages/pdnsd.git/commitdiff
- updated for 1.2.6 auto/th/pdnsd-1_2_6-1
authorkosmo <kosmo@pld-linux.org>
Fri, 9 May 2008 11:21:13 +0000 (11:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    pdnsd-ac_am.patch -> 1.6
    pdnsd-ipv6_pktinfo.patch -> 1.1
    pdnsd-query_roots_in_default_conf.patch -> 1.2

pdnsd-ac_am.patch
pdnsd-ipv6_pktinfo.patch [new file with mode: 0644]
pdnsd-query_roots_in_default_conf.patch

index 5b3f78bcf92139a01c4f60b06c0cf5374b7c395a..61946fb9c3d513740642ba525c928a5c252392ab 100644 (file)
@@ -1,21 +1,3 @@
-diff -urN pdnsd-1.2.4.org/configure.in pdnsd-1.2.4/configure.in
---- pdnsd-1.2.4.org/configure.in       2005-12-27 13:14:55.000000000 +0100
-+++ pdnsd-1.2.4/configure.in   2006-02-20 21:15:01.000000000 +0100
-@@ -495,14 +495,5 @@
- doc/pdnsd.conf
- src/Makefile
- src/pdnsd-ctl/Makefile
--src/rc/Makefile
--src/rc/RedHat/Makefile
--src/rc/RedHat/pdnsd
--src/rc/SuSE/Makefile
--src/rc/SuSE/pdnsd
--src/rc/Debian/Makefile
--src/rc/Debian/pdnsd
--src/rc/Slackware/Makefile
--src/rc/Slackware/rc.pdnsd
- src/test/Makefile
- ])
 diff -urN pdnsd-1.2.4.org/src/Makefile.am pdnsd-1.2.4/src/Makefile.am
 --- pdnsd-1.2.4.org/src/Makefile.am    2005-03-17 22:08:21.000000000 +0100
 +++ pdnsd-1.2.4/src/Makefile.am        2006-02-20 21:15:21.000000000 +0100
@@ -40,6 +22,26 @@ diff -urN pdnsd-1.2.4.org/src/pdnsd-ctl/Makefile.am pdnsd-1.2.4/src/pdnsd-ctl/Ma
  
  # These are Symlinks we want to have in the package
  #EXTRA_DIST = rr_types.h
+diff -urN pdnsd-1.2.4.org/configure.in pdnsd-1.2.4/configure.in
+--- pdnsd-1.2.4.org/configure.in       2005-12-27 13:14:55.000000000 +0100
++++ pdnsd-1.2.4/configure.in   2006-02-20 21:15:01.000000000 +0100
+@@ -495,16 +495,5 @@
+ doc/pdnsd.conf
+ src/Makefile
+ src/pdnsd-ctl/Makefile
+-src/rc/Makefile
+-src/rc/RedHat/Makefile
+-src/rc/RedHat/pdnsd
+-src/rc/SuSE/Makefile
+-src/rc/SuSE/pdnsd
+-src/rc/Debian/Makefile
+-src/rc/Debian/pdnsd
+-src/rc/Slackware/Makefile
+-src/rc/Slackware/rc.pdnsd
+-src/rc/ArchLinux/Makefile
+-src/rc/ArchLinux/pdnsd
+ src/test/Makefile
+ ])
 diff -urN pdnsd-1.2.4.org/src/test/Makefile.am pdnsd-1.2.4/src/test/Makefile.am
 --- pdnsd-1.2.4.org/src/test/Makefile.am       2000-11-15 18:27:12.000000000 +0100
 +++ pdnsd-1.2.4/src/test/Makefile.am   2006-02-20 21:20:11.000000000 +0100
@@ -55,19 +57,19 @@ diff -urN pdnsd-1.2.4.org/src/test/Makefile.am pdnsd-1.2.4/src/test/Makefile.am
 +TESTADDSRC = $(top_srcdir)/src/netdev.c $(top_srcdir)/src/error.c $(top_srcdir)/src/thread.c $(top_srcdir)/src/helpers.c $(top_srcdir)/src/icmp.c
  
  if_up_SOURCES = if_up.c $(TESTADDSRC)
--if_up_LDADD =  $(TESTOBJS)
+-if_up_LDADD =  $(TESTOBJS) @thread_CFLAGS@
 -if_up_DEPENDENCIES = $(TESTDEPS)
  
  is_local_addr_SOURCES = is_local_addr.c $(TESTADDSRC)
--is_local_addr_LDADD = $(TESTOBJS)
+-is_local_addr_LDADD = $(TESTOBJS) @thread_CFLAGS@
 -is_local_addr_DEPENDENCIES = $(TESTDEPS)
  
  tping_SOURCES = tping.c $(TESTADDSRC)
--tping_LDADD = $(TESTOBJS)
+-tping_LDADD = $(TESTOBJS) @thread_CFLAGS@
 -tping_DEPENDENCIES = $(TESTDEPS)
  
  random_SOURCES = random.c $(TESTADDSRC)
--random_LDADD = $(TESTOBJS)
+-random_LDADD = $(TESTOBJS) @thread_CFLAGS@
 -random_DEPENDENCIES = $(TESTDEPS)
  
  # These are Symlinks we want to have in the package
diff --git a/pdnsd-ipv6_pktinfo.patch b/pdnsd-ipv6_pktinfo.patch
new file mode 100644 (file)
index 0000000..cbdb303
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN pdnsd-1.2.6.orig/src/dns_answer.c pdnsd-1.2.6/src/dns_answer.c
+--- pdnsd-1.2.6.orig/src/dns_answer.c  2007-08-19 16:46:12.000000000 +0200
++++ pdnsd-1.2.6/src/dns_answer.c       2008-05-09 13:16:26.000000000 +0200
+@@ -1325,7 +1325,7 @@
+ # ifdef ENABLE_IPV6
+       if (!run_ipv4) {
+-              if (setsockopt(sock,SOL_IPV6,IPV6_RECVPKTINFO,&so,sizeof(so))!=0) {
++              if (setsockopt(sock,SOL_IPV6,IPV6_PKTINFO,&so,sizeof(so))!=0) {
+                       log_error("Could not set options on udp socket: %s",strerror(errno));
+                       close(sock);
+                       return -1;
index fccd546da230a4eceb2b6474111875d0042549d7..713a9f0faed58050db9fbc742944b3f00d73202e 100644 (file)
@@ -1,19 +1,14 @@
 --- pdnsd-1.2.5/doc/pdnsd.conf.in.query_roots_in_default_conf.patch    2007-05-01 12:13:57.000000000 +0200
 +++ pdnsd-1.2.5/doc/pdnsd.conf.in      2007-05-01 12:14:36.000000000 +0200
-@@ -10,13 +10,14 @@
-                               # machines on your network to query pdnsd.
-       status_ctl = on;
- #     paranoid=on;
--#     query_method=tcp_udp;   # pdnsd must be compiled with tcp
-+      query_method=tcp_udp;   # pdnsd must be compiled with tcp
-                               # query support for this to work.
+@@ -14,9 +14,10 @@
        min_ttl=15m;       # Retain cached entries at least 15 minutes.
        max_ttl=1w;        # One week.
        timeout=10;        # Global timeout option (10 seconds).
  }
  
 +/*
- # The following section is most appropriate for fixed connections to the Internet.
+ # The following section is most appropriate if you have a fixed connection to
+ # the Internet and an ISP which provides good DNS servers.
  server {
        label= "myisp";
 @@ -30,6 +31,7 @@
This page took 0.079484 seconds and 4 git commands to generate.