]> git.pld-linux.org Git - packages/pdns.git/commitdiff
- updated to 3.0 auto/th/pdns-3_0-1
authorŁukasz Kieś <kiesiu@pld-linux.org>
Mon, 28 Nov 2011 12:26:28 +0000 (12:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gcc4.patch -> 1.2
    pdns-int16.patch -> 1.5
    pdns-openldap-2.3.patch -> 1.2
    pdns.spec -> 1.79

gcc4.patch
pdns-int16.patch
pdns-openldap-2.3.patch
pdns.spec

index 8970b27181b5489e026f7943e13545451e581f34..ffd47403a206333211dd298b1f7db19ba6cb0a07 100644 (file)
@@ -1,20 +1,22 @@
---- pdns-2.9.22/pdns/rcpgenerator.cc.orig      2010-04-14 23:40:51.208359588 +0200
-+++ pdns-2.9.22/pdns/rcpgenerator.cc   2010-04-14 23:42:06.531685676 +0200
-@@ -21,6 +21,7 @@
- #include "misc.hh"
- #include <boost/lexical_cast.hpp>
- #include <iostream>
-+#include <cstdio>
- #include "base64.hh"
- using namespace boost;
---- pdns-2.9.22/pdns/dnsparser.cc.orig 2010-04-14 23:44:22.735837950 +0200
-+++ pdns-2.9.22/pdns/dnsparser.cc      2010-04-14 23:44:37.368336270 +0200
+diff -uNr pdns-3.0/pdns/dnsparser.cc pdns-3.0.new/pdns/dnsparser.cc
+--- pdns-3.0/pdns/dnsparser.cc 2011-07-22 13:23:22.000000000 +0200
++++ pdns-3.0.new/pdns/dnsparser.cc     2011-11-28 11:59:02.047547670 +0100
 @@ -20,6 +20,7 @@
  #include "dnswriter.hh"
  #include <boost/lexical_cast.hpp>
  #include <boost/algorithm/string.hpp>
 +#include <cstdio>
  
- using namespace boost;
+ #include "namespaces.hh"
  
+diff -uNr pdns-3.0/pdns/rcpgenerator.cc pdns-3.0.new/pdns/rcpgenerator.cc
+--- pdns-3.0/pdns/rcpgenerator.cc      2011-07-22 13:23:22.000000000 +0200
++++ pdns-3.0.new/pdns/rcpgenerator.cc  2011-11-28 11:59:22.501841684 +0100
+@@ -22,6 +22,7 @@
+ #include <boost/lexical_cast.hpp>
+ #include <boost/algorithm/string.hpp>
+ #include <iostream>
++#include <cstdio>
+ #include "base32.hh"
+ #include "base64.hh"
+ #include "namespaces.hh"
index 0e17fce54872ae26bbfa5491bcc3c332334ce4fe..4319f0c40b1c278cf285449a236990d8b62bd918 100644 (file)
@@ -1,5 +1,30 @@
---- pdns-2.9.22/modules/ldapbackend/powerldap.hh~      2009-02-07 19:46:56.713653002 +0100
-+++ pdns-2.9.22/modules/ldapbackend/powerldap.hh       2009-02-07 19:47:40.993231763 +0100
+diff -uNr pdns-3.0/modules/ldapbackend/ldapbackend.cc pdns-3.0.new/modules/ldapbackend/ldapbackend.cc
+--- pdns-3.0/modules/ldapbackend/ldapbackend.cc        2011-07-22 13:23:22.000000000 +0200
++++ pdns-3.0.new/modules/ldapbackend/ldapbackend.cc    2011-11-28 11:55:30.704283338 +0100
+@@ -434,7 +434,7 @@
+                                                               continue;
+                                                       }
+-                                                      rr.priority = (uint16_t) strtoul( (content.substr( 0, first )).c_str(), &endptr, 10 );
++                                                      rr.priority = (u_int16_t) strtoul( (content.substr( 0, first )).c_str(), &endptr, 10 );
+                                                       if( *endptr != '\0' )
+                                                       {
+                                                               L << Logger::Warning << m_myname << " Invalid " << attrname << " without priority for " << m_qname << ": " << content << endl;
+diff -uNr pdns-3.0/modules/ldapbackend/powerldap.cc pdns-3.0.new/modules/ldapbackend/powerldap.cc
+--- pdns-3.0/modules/ldapbackend/powerldap.cc  2011-07-22 13:23:22.000000000 +0200
++++ pdns-3.0.new/modules/ldapbackend/powerldap.cc      2011-11-28 11:55:46.355019073 +0100
+@@ -4,7 +4,7 @@
+-PowerLDAP::PowerLDAP( const string& hosts, uint16_t port, bool tls )
++PowerLDAP::PowerLDAP( const string& hosts, u_int16_t port, bool tls )
+ {
+         d_ld = 0;
+         d_hosts = hosts;
+diff -uNr pdns-3.0/modules/ldapbackend/powerldap.hh pdns-3.0.new/modules/ldapbackend/powerldap.hh
+--- pdns-3.0/modules/ldapbackend/powerldap.hh  2011-07-22 13:23:22.000000000 +0200
++++ pdns-3.0.new/modules/ldapbackend/powerldap.hh      2011-11-28 11:54:08.347077606 +0100
 @@ -18,7 +18,7 @@
   */
  
  #include <map>
  #include <string>
  #include <vector>
-diff -Nur pdns-2.9.21.1.orig/modules/ldapbackend/ldapbackend.cc pdns-2.9.21.1.int16/modules/ldapbackend/ldapbackend.cc
---- pdns-2.9.21.1.orig/modules/ldapbackend/ldapbackend.cc      2007-04-21 07:56:36.000000000 -0600
-+++ pdns-2.9.21.1.int16/modules/ldapbackend/ldapbackend.cc     2008-10-06 10:08:55.000000000 -0600
-@@ -433,7 +433,7 @@
-                                                               continue;
-                                                       }
--                                                      rr.priority = (uint16_t) strtoul( (content.substr( 0, first )).c_str(), &endptr, 10 );
-+                                                      rr.priority = (u_int16_t) strtoul( (content.substr( 0, first )).c_str(), &endptr, 10 );
-                                                       if( *endptr != '\0' )
-                                                       {
-                                                               L << Logger::Warning << m_myname << " Invalid " << attrname << " without priority for " << m_qname << ": " << content << endl;
-diff -Nur pdns-2.9.21.1.orig/modules/ldapbackend/powerldap.cc pdns-2.9.21.1.int16/modules/ldapbackend/powerldap.cc
---- pdns-2.9.21.1.orig/modules/ldapbackend/powerldap.cc        2007-04-21 07:56:36.000000000 -0600
-+++ pdns-2.9.21.1.int16/modules/ldapbackend/powerldap.cc       2008-10-06 10:08:55.000000000 -0600
-@@ -2,7 +2,7 @@
--PowerLDAP::PowerLDAP( const string& hosts, uint16_t port, bool tls )
-+PowerLDAP::PowerLDAP( const string& hosts, u_int16_t port, bool tls )
- {
-       int protocol = LDAP_VERSION3;
-diff -Nur pdns-2.9.21.1.orig/modules/ldapbackend/powerldap.hh pdns-2.9.21.1.int16/modules/ldapbackend/powerldap.hh
---- pdns-2.9.21.1.orig/modules/ldapbackend/powerldap.hh        2007-04-21 07:56:36.000000000 -0600
-+++ pdns-2.9.21.1.int16/modules/ldapbackend/powerldap.hh       2008-10-06 10:11:53.000000000 -0600
-@@ -78,7 +74,7 @@
-       typedef map<string, vector<string> > sentry_t;
-       typedef vector<sentry_t> sresult_t;
+@@ -69,7 +69,7 @@
+         typedef map<string, vector<string> > sentry_t;
+         typedef vector<sentry_t> sresult_t;
  
--      PowerLDAP( const string& hosts = "ldap://127.0.0.1/", uint16_t port = LDAP_PORT, bool tls = false );
-+      PowerLDAP( const string& hosts = "ldap://127.0.0.1/", u_int16_t port = LDAP_PORT, bool tls = false );
-       ~PowerLDAP();
+-        PowerLDAP( const string& hosts = "ldap://127.0.0.1/", uint16_t port = LDAP_PORT, bool tls = false );
++        PowerLDAP( const string& hosts = "ldap://127.0.0.1/", u_int16_t port = LDAP_PORT, bool tls = false );
+         ~PowerLDAP();
  
-       void getOption( int option, int* value );
+         void getOption( int option, int* value );
index 201c28798a4ecf8b16d073aa27f94a247ac1000c..3327763c237a9588d425ab95dadaa1a693c44ffe 100644 (file)
@@ -1,11 +1,12 @@
---- pdns-2.9.19/modules/ldapbackend/powerldap.hh~      2006-01-18 00:55:23.000000000 +0100
-+++ pdns-2.9.19/modules/ldapbackend/powerldap.hh       2006-01-18 01:03:42.000000000 +0100
+diff -uNr pdns-3.0/modules/ldapbackend/powerldap.hh pdns-3.0.new/modules/ldapbackend/powerldap.hh
+--- pdns-3.0/modules/ldapbackend/powerldap.hh  2011-07-22 13:23:22.000000000 +0200
++++ pdns-3.0.new/modules/ldapbackend/powerldap.hh      2011-11-28 11:50:02.192161656 +0100
 @@ -27,6 +27,8 @@
- #include <stdexcept>
+ #include <inttypes.h>
  #include <errno.h>
  #include <lber.h>
 +
 +#define LDAP_DEPRECATED 1
  #include <ldap.h>
  
+ #ifdef HAVE_CONFIG_H
index a99c330691bfa5f68eeeb3a24550afda0423dfc3..82a08fa079bee05daf1815c241cc21a25c5f3da4 100644 (file)
--- a/pdns.spec
+++ b/pdns.spec
@@ -1,28 +1,32 @@
 Summary:       PowerDNS is a Versatile Database Driven Nameserver
 Summary(pl.UTF-8):     PowerDNS to wielofunkcyjny serwer nazw korzystający z relacyjnych baz danych
 Name:          pdns
-Version:       2.9.22
-Release:       4
+Version:       3.0
+Release:       1
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://downloads.powerdns.com/releases/%{name}-%{version}.tar.gz
-# Source0-md5: 8a6ff842733aca885577eb54e983a1ff
+# Source0-md5: dce3855707a1a02c1d1893242f33960a
 Source1:       http://downloads.powerdns.com/documentation/%{name}.pdf
 # Source1-md5: cb69cd9655e4cb319c66adb2c733314d
 Source2:       http://downloads.powerdns.com/documentation/%{name}.txt
 Source3:       %{name}.init
 Source4:       %{name}.conf
 Source5:       %{name}.sysconfig
-Patch0:                %{name}-configure.patch
+Patch0:                configure.ac.patch
 Patch1:                %{name}-int16.patch
 Patch2:                %{name}-openldap-2.3.patch
 Patch3:                gcc4.patch
 URL:           http://www.powerdns.com/
+BuildRequires: autoconf >= 2.52
+BuildRequires: automake
 BuildRequires: bison
 BuildRequires: boost-devel >= 1.35.0
 BuildRequires: flex
 BuildRequires: libpq++-devel
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
+BuildRequires: lua51-devel
 BuildRequires: mysql-devel
 BuildRequires: openldap-devel >= 2.4.6
 BuildRequires: rpmbuild(macros) >= 1.268
@@ -139,20 +143,19 @@ cp %{SOURCE4} .
 
 %build
 CPPFLAGS="-DHAVE_NAMESPACE_STD -DHAVE_CXX_STRING_HEADER -DDLLIMPORT=\"\""
+%{__libtoolize}
+%{__aclocal} -I .
+%{__autoconf}
+%{__automake}
 %configure \
        --libdir=%{_libdir}/%{name} \
        --sysconfdir=%{_sysconfdir}/%{name} \
        --disable-static \
-       --enable-ldap \
-       --enable-mysql \
-       --enable-pgsql \
-       --enable-sqlite3 \
+       --with-lua \
        --with-pgsql-includes=%{_includedir} \
        --with-pgsql-lib=%{_libdir} \
        --with-mysql-includes=%{_includedir} \
        --with-mysql-lib=%{_libdir} \
-       --with-sqlite3-includes=%{_includedir} \
-       --with-sqlite3-lib=%{_libdir} \
        --with-dynmodules="gsqlite3 gmysql gpgsql pipe ldap" \
        --with-modules="" \
        --with-socketdir=/var/run
This page took 0.037213 seconds and 4 git commands to generate.