]> git.pld-linux.org Git - packages/pcl.git/commitdiff
- added openni patch (remove non-existing openni-dev dependency from pcl_*.pc)
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 28 Dec 2012 19:44:33 +0000 (20:44 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 28 Dec 2012 19:44:33 +0000 (20:44 +0100)
- override LIB_INSTALL_DIR to get proper libdirs in pcl*_.pc

pcl-openni.patch [new file with mode: 0644]
pcl.spec

diff --git a/pcl-openni.patch b/pcl-openni.patch
new file mode 100644 (file)
index 0000000..ced07db
--- /dev/null
@@ -0,0 +1,24 @@
+--- PCL-1.6.0-Source/io/CMakeLists.txt.orig    2012-07-18 01:11:32.000000000 +0200
++++ PCL-1.6.0-Source/io/CMakeLists.txt 2012-12-28 15:34:55.362591817 +0100
+@@ -139,9 +139,6 @@
+     endif(OPENNI_FOUND)
+     set(EXT_DEPS eigen3)
+-    if(OPENNI_FOUND)
+-      list(APPEND EXT_DEPS openni-dev)
+-    endif(OPENNI_FOUND)
+     PCL_MAKE_PKGCONFIG(${LIB_NAME} ${SUBSYS_NAME} "${SUBSYS_DESC}"
+       "${SUBSYS_DEPS}" "${EXT_DEPS}" "" "" "")
+--- PCL-1.6.0-Source/visualization/CMakeLists.txt.orig 2012-07-18 01:11:32.000000000 +0200
++++ PCL-1.6.0-Source/visualization/CMakeLists.txt      2012-12-28 15:37:49.779254847 +0100
+@@ -99,9 +99,6 @@
+     endif()
+     set(EXT_DEPS "")
+-    if(OPENNI_FOUND)
+-      list(APPEND EXT_DEPS openni-dev)
+-    endif(OPENNI_FOUND)
+     PCL_MAKE_PKGCONFIG(${LIB_NAME} ${SUBSYS_NAME} "${SUBSYS_DESC}"
+       "${SUBSYS_DEPS}" "${EXT_DEPS}" "" "" "")
index 02f76a79a1966dd34f5043ae399d82f8fb830346..4f5de3ad0d925e8cc5294b9bb7ba0b99bc01e40c 100644 (file)
--- a/pcl.spec
+++ b/pcl.spec
@@ -15,6 +15,7 @@ Group:                Libraries
 Source0:       http://www.pointclouds.org/assets/files/1.6.0/PCL-%{version}-Source.tar.bz2
 # Source0-md5: f83ca5d0ff290412b0807864b95eba26
 Patch0:                %{name}-link.patch
+Patch1:                %{name}-openni.patch
 URL:           http://pointclouds.org/
 BuildRequires: OpenNI-devel
 BuildRequires: boost-devel >= 1.40
@@ -89,6 +90,7 @@ Dokumentacja API oraz wprowadzenie do biblioteki PCL.
 %prep
 %setup -q -n PCL-%{version}-Source
 %patch0 -p1
+%patch1 -p1
 
 # don't use SSE/SSE2/SSE3 just because compiler and builder host supports it
 %{__sed} -i -e '/^PCL_CHECK_FOR_SSE/d' CMakeLists.txt
@@ -96,7 +98,9 @@ Dokumentacja API oraz wprowadzenie do biblioteki PCL.
 %build
 mkdir build
 cd build
-%cmake ..
+# LIB_INSTALL_DIR specified by PLD cmake macro is incompatible with what PCL expects
+%cmake .. \
+       -DLIB_INSTALL_DIR=%{_lib}
 %{__make}
 
 # why it's not called on build?
This page took 0.178573 seconds and 4 git commands to generate.