]> git.pld-linux.org Git - packages/patch.git/commitdiff
- rel 2; fix CVE-2018-1000156 auto/th/patch-2.7.6-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 9 Aug 2018 17:47:59 +0000 (19:47 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 9 Aug 2018 17:47:59 +0000 (19:47 +0200)
patch-CVE-2018-1000156.patch [new file with mode: 0644]
patch.spec

diff --git a/patch-CVE-2018-1000156.patch b/patch-CVE-2018-1000156.patch
new file mode 100644 (file)
index 0000000..fc3b0c2
--- /dev/null
@@ -0,0 +1,209 @@
+diff -up patch-2.7.6/src/pch.c.CVE-2018-1000156 patch-2.7.6/src/pch.c
+--- patch-2.7.6/src/pch.c.CVE-2018-1000156     2018-02-03 12:41:49.000000000 +0000
++++ patch-2.7.6/src/pch.c      2018-05-03 12:50:43.374036905 +0100
+@@ -33,6 +33,7 @@
+ # include <io.h>
+ #endif
+ #include <safe.h>
++#include <sys/wait.h>
+ #define INITHUNKMAX 125                       /* initial dynamic allocation size */
+@@ -2388,22 +2389,28 @@ do_ed_script (char const *inname, char c
+     static char const editor_program[] = EDITOR_PROGRAM;
+     file_offset beginning_of_this_line;
+-    FILE *pipefp = 0;
+     size_t chars_read;
++    FILE *tmpfp = 0;
++    char const *tmpname;
++    int tmpfd = -1;
++    pid_t pid;
++
++    if (! dry_run && ! skip_rest_of_patch)
++      {
++       /* Write ed script to a temporary file.  This causes ed to abort on
++          invalid commands such as when line numbers or ranges exceed the
++          number of available lines.  When ed reads from a pipe, it rejects
++          invalid commands and treats the next line as a new command, which
++          can lead to arbitrary command execution.  */
++
++       tmpfd = make_tempfile (&tmpname, 'e', NULL, O_RDWR | O_BINARY, 0);
++       if (tmpfd == -1)
++         pfatal ("Can't create temporary file %s", quotearg (tmpname));
++       tmpfp = fdopen (tmpfd, "w+b");
++       if (! tmpfp)
++         pfatal ("Can't open stream for file %s", quotearg (tmpname));
++      }
+-    if (! dry_run && ! skip_rest_of_patch) {
+-      int exclusive = *outname_needs_removal ? 0 : O_EXCL;
+-      assert (! inerrno);
+-      *outname_needs_removal = true;
+-      copy_file (inname, outname, 0, exclusive, instat.st_mode, true);
+-      sprintf (buf, "%s %s%s", editor_program,
+-               verbosity == VERBOSE ? "" : "- ",
+-               outname);
+-      fflush (stdout);
+-      pipefp = popen(buf, binary_transput ? "wb" : "w");
+-      if (!pipefp)
+-        pfatal ("Can't open pipe to %s", quotearg (buf));
+-    }
+     for (;;) {
+       char ed_command_letter;
+       beginning_of_this_line = file_tell (pfp);
+@@ -2414,14 +2421,14 @@ do_ed_script (char const *inname, char c
+       }
+       ed_command_letter = get_ed_command_letter (buf);
+       if (ed_command_letter) {
+-          if (pipefp)
+-              if (! fwrite (buf, sizeof *buf, chars_read, pipefp))
++          if (tmpfp)
++              if (! fwrite (buf, sizeof *buf, chars_read, tmpfp))
+                   write_fatal ();
+           if (ed_command_letter != 'd' && ed_command_letter != 's') {
+               p_pass_comments_through = true;
+               while ((chars_read = get_line ()) != 0) {
+-                  if (pipefp)
+-                      if (! fwrite (buf, sizeof *buf, chars_read, pipefp))
++                  if (tmpfp)
++                      if (! fwrite (buf, sizeof *buf, chars_read, tmpfp))
+                           write_fatal ();
+                   if (chars_read == 2  &&  strEQ (buf, ".\n"))
+                       break;
+@@ -2434,13 +2441,50 @@ do_ed_script (char const *inname, char c
+           break;
+       }
+     }
+-    if (!pipefp)
++    if (!tmpfp)
+       return;
+-    if (fwrite ("w\nq\n", sizeof (char), (size_t) 4, pipefp) == 0
+-      || fflush (pipefp) != 0)
++    if (fwrite ("w\nq\n", sizeof (char), (size_t) 4, tmpfp) == 0
++      || fflush (tmpfp) != 0)
+       write_fatal ();
+-    if (pclose (pipefp) != 0)
+-      fatal ("%s FAILED", editor_program);
++
++    if (lseek (tmpfd, 0, SEEK_SET) == -1)
++      pfatal ("Can't rewind to the beginning of file %s", quotearg (tmpname));
++
++    if (! dry_run && ! skip_rest_of_patch) {
++       int exclusive = *outname_needs_removal ? 0 : O_EXCL;
++       *outname_needs_removal = true;
++       if (inerrno != ENOENT)
++         {
++           *outname_needs_removal = true;
++           copy_file (inname, outname, 0, exclusive, instat.st_mode, true);
++         }
++       sprintf (buf, "%s %s%s", editor_program,
++                verbosity == VERBOSE ? "" : "- ",
++                outname);
++       fflush (stdout);
++
++       pid = fork();
++       if (pid == -1)
++         pfatal ("Can't fork");
++       else if (pid == 0)
++         {
++           dup2 (tmpfd, 0);
++           execl ("/bin/sh", "sh", "-c", buf, (char *) 0);
++           _exit (2);
++         }
++       else
++         {
++           int wstatus;
++           if (waitpid (pid, &wstatus, 0) == -1
++               || ! WIFEXITED (wstatus)
++               || WEXITSTATUS (wstatus) != 0)
++             fatal ("%s FAILED", editor_program);
++         }
++    }
++
++    fclose (tmpfp);
++    unlink (tmpname);
++    free((char*) tmpname);
+     if (ofp)
+       {
+diff -up patch-2.7.6/tests/ed-style.CVE-2018-1000156 patch-2.7.6/tests/ed-style
+--- patch-2.7.6/tests/ed-style.CVE-2018-1000156        2018-05-03 12:50:28.988937938 +0100
++++ patch-2.7.6/tests/ed-style 2018-05-03 12:51:35.841397873 +0100
+@@ -0,0 +1,40 @@
++# Copyright (C) 2018 Free Software Foundation, Inc.
++#
++# Copying and distribution of this file, with or without modification,
++# in any medium, are permitted without royalty provided the copyright
++# notice and this notice are preserved.
++
++. $srcdir/test-lib.sh
++
++require_cat
++use_local_patch
++use_tmpdir
++
++# ==============================================================
++
++cat > ed1.diff <<EOF
++0a
++foo
++.
++EOF
++
++check 'patch -e foo -i ed1.diff' <<EOF
++EOF
++
++check 'cat foo' <<EOF
++foo
++EOF
++
++cat > ed2.diff <<EOF
++1337a
++r !echo bar
++,p
++EOF
++
++check 'patch -e foo -i ed2.diff > /dev/null 2> /dev/null || echo "Status: $?"' <<EOF
++Status: 2
++EOF
++
++check 'cat foo' <<EOF
++foo
++EOF
+diff -up patch-2.7.6/tests/Makefile.am.CVE-2018-1000156 patch-2.7.6/tests/Makefile.am
+--- patch-2.7.6/tests/Makefile.am.CVE-2018-1000156     2018-05-03 12:50:28.988937938 +0100
++++ patch-2.7.6/tests/Makefile.am      2018-05-03 12:50:57.340132989 +0100
+@@ -32,6 +32,7 @@ TESTS = \
+       crlf-handling \
+       dash-o-append \
+       deep-directories \
++      ed-style \
+       empty-files \
+       false-match \
+       fifo \
+diff -up patch-2.7.6/tests/Makefile.in.CVE-2018-1000156 patch-2.7.6/tests/Makefile.in
+--- patch-2.7.6/tests/Makefile.in.CVE-2018-1000156     2018-05-03 12:50:28.989937944 +0100
++++ patch-2.7.6/tests/Makefile.in      2018-05-03 12:51:25.974329992 +0100
+@@ -1308,6 +1308,7 @@ TESTS = \
+       crlf-handling \
+       dash-o-append \
+       deep-directories \
++      ed-style \
+       empty-files \
+       false-match \
+       fifo \
+@@ -1645,6 +1646,13 @@ empty-files.log: empty-files
+       $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
+       --log-file $$b.log --trs-file $$b.trs \
+       $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
++      "$$tst" $(AM_TESTS_FD_REDIRECT)
++ed-style.log: empty-files
++      @p='ed-style'; \
++      b='ed-style'; \
++      $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
++      --log-file $$b.log --trs-file $$b.trs \
++      $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
+       "$$tst" $(AM_TESTS_FD_REDIRECT)
+ false-match.log: false-match
+       @p='false-match'; \
index 03638f558c51dec242e0fe22176468a092945b58..dad52cba7a04151ca382dbb6e70dd8667d73fe86 100644 (file)
@@ -11,12 +11,13 @@ Summary(tr.UTF-8):  GNU yama yardımcı programları
 Summary(uk.UTF-8):     Утиліта GNU patch, для модифікації/апгрейду файлів
 Name:          patch
 Version:       2.7.6
-Release:       1
+Release:       2
 License:       GPL v3+
 Group:         Applications/Text
 Source0:       http://ftp.gnu.org/gnu/patch/%{name}-%{version}.tar.xz
 # Source0-md5: 78ad9937e4caadcba1526ef1853730d5
 Source1:       %{name}.1.pl
+Patch0:                patch-CVE-2018-1000156.patch
 URL:           http://www.gnu.org/software/patch/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11.2
@@ -76,6 +77,7 @@ Patch - це програма, яка допомогає в модифікаці
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__aclocal} -I m4
This page took 0.088042 seconds and 4 git commands to generate.