]> git.pld-linux.org Git - packages/partysip.git/commitdiff
- fixes to missing DESTDIR call and config location
authorPaweł Gołaszewski <blues@pld-linux.org>
Thu, 2 Jan 2003 10:29:58 +0000 (10:29 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    partysip-DESTDIR_fix.patch -> 1.1
    partysip-config_location.patch -> 1.1

partysip-DESTDIR_fix.patch [new file with mode: 0644]
partysip-config_location.patch [new file with mode: 0644]

diff --git a/partysip-DESTDIR_fix.patch b/partysip-DESTDIR_fix.patch
new file mode 100644 (file)
index 0000000..42c73f9
--- /dev/null
@@ -0,0 +1,35 @@
+--- ./conf/Makefile.am.org     Sat Dec 28 01:50:58 2002
++++ ./conf/Makefile.am Thu Jan  2 09:59:46 2003
+@@ -1,27 +1,25 @@
+ EXTRA_DIST = partysip.conf
+-sysconfdir = $(prefix)/etc/partysip/
+-
+ pkgdatadir = $(prefix)/$(PACKAGE)
+ install-data-local:
+-      $(mkinstalldirs) $(sysconfdir);
+-      @chmod 0755 $(sysconfdir);
++      $(mkinstalldirs) $(DESTDIR)$(sysconfdir);
++      @chmod 0755 $(DESTDIR)$(sysconfdir);
+       @echo "Installing admin files : partysip.conf";
+-      @if test -f $(sysconfdir)partysip.conf; then \
++      @if test -f $(DESTDIR)$(sysconfdir)partysip.conf; then \
+         echo "********************************************************"; \
+         echo "**** File partysip.conf has already been installed. ****"; \
+         echo "****   MERGE CHANGES MANUALLY in partysip.conf.     ****"; \
+         echo "********************************************************"; \
+         echo "Installing new admin file: partysip.conf.$(PSP_VERSION)";  \
+         echo "********************************************************"; \
+-        $(INSTALL_DATA) $(top_srcdir)/conf/partysip.conf $(sysconfdir)partysip.conf.$(PSP_VERSION); \
++        $(INSTALL_DATA) $(top_srcdir)/conf/partysip.conf $(DESTDIR)$(sysconfdir)partysip.conf.$(PSP_VERSION); \
+       else \
+         echo "********************************************************"; \
+         echo "****         First installation detected.           ****"; \
+         echo "****      Please, edit the file partysip.conf.      ****"; \
+         echo "********************************************************"; \
+-        $(INSTALL_DATA) $(top_srcdir)/conf/partysip.conf $(sysconfdir); \
++        $(INSTALL_DATA) $(top_srcdir)/conf/partysip.conf $(DESTDIR)$(sysconfdir); \
+       fi
diff --git a/partysip-config_location.patch b/partysip-config_location.patch
new file mode 100644 (file)
index 0000000..ce8fab4
--- /dev/null
@@ -0,0 +1,31 @@
+--- ./src/main.c.org   Thu Jan  2 11:10:38 2003
++++ ./src/main.c       Thu Jan  2 11:09:38 2003
+@@ -381,7 +381,7 @@
+   ppl_getopt_t *opt;
+   ppl_status_t rv;
+ #ifdef WIN32
+-  const char *cf_config_file = PSP_SERVER_INSTALL_DIR "partysip.conf";
++  const char *cf_config_file = CONFIG_DIR "/partysip.conf";
+ #ifdef HAVE_NT_SERVICE_MANAGER
+   int interactive_mode = 2;
+ #else
+@@ -389,7 +389,7 @@
+ #endif
+ #else
+   const char *cf_config_file =
+-    PSP_SERVER_INSTALL_DIR "/etc/partysip/partysip.conf";
++    CONFIG_DIR "/partysip.conf";
+   int interactive_mode = 0;
+ #endif
+   int cf_debug_level = 0;
+--- ./src/Makefile.am.org      Thu Jan  2 11:10:57 2003
++++ ./src/Makefile.am  Thu Jan  2 11:09:08 2003
+@@ -20,7 +20,7 @@
+ INCLUDES =  -I$(top_srcdir)/partysip -I$(top_srcdir)/ppl/unix/ \
+ -I$(top_srcdir) -I$(prefix)/include
+-AM_CFLAGS = -Wall $(PARTYSIP_FLAGS) -DPSP_SERVER_PREFIX="\"$(prefix)\"" $(PTHREAD_CFLAGS)
++AM_CFLAGS = -Wall $(PARTYSIP_FLAGS) -DPSP_SERVER_PREFIX="\"$(prefix)\"" -DCONFIG_DIR="\"@sysconfdir@\"" $(PTHREAD_CFLAGS)
+ install-exec-local:
+       echo "Installing script file for plugin: partysip-config";
This page took 0.68346 seconds and 4 git commands to generate.