]> git.pld-linux.org Git - packages/parallel-netcdf.git/blob - parallel-netcdf.spec
- updated to 1.12.1
[packages/parallel-netcdf.git] / parallel-netcdf.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        Parallel netCDF (PnetCDF) library
7 Summary(pl.UTF-8):      Biblioteka zrównoleglona netCDF (PnetCDF)
8 Name:           parallel-netcdf
9 Version:        1.12.1
10 Release:        1
11 License:        BSD-like
12 Group:          Libraries
13 #Source0Download: http://cucis.ece.northwestern.edu/projects/PnetCDF/download.html
14 Source0:        http://cucis.ece.northwestern.edu/projects/PnetCDF/Release/pnetcdf-%{version}.tar.gz
15 # Source0-md5:  878192db34e436cbdd869fff3c7bf0c9
16 Patch0:         %{name}-sh.patch
17 URL:            https://trac.mcs.anl.gov/projects/parallel-netcdf
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  automake >= 1:1.13
20 BuildRequires:  gcc-fortran
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2.4.2
23 # mpicc and co.
24 BuildRequires:  mpich-devel
25 BuildRequires:  m4
26 BuildRequires:  rpmbuild(macros) >= 1.752
27 %if %{with apidocs}
28 BuildRequires:  doxygen
29 BuildRequires:  ghostscript
30 BuildRequires:  texlive-latex
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Parallel netCDF (PnetCDF) is a library providing high-performance
36 parallel I/O while still maintaining file-format compatibility with
37 Unidata's NetCDF, specifically the classic CDF 1, 2, and 5 formats.
38 Although NetCDF supports parallel I/O starting from version 4, it is
39 built on top of HDF5 and thus its parallel feature requires files in
40 HDF5 format. PnetCDF is currently the only option for parallel I/O on
41 files in classic formats.
42
43 %description -l pl.UTF-8
44 Parallel netCDF (PnetCDF) to biblioteka zapewniająca bardzo wydajne,
45 równoległe operacje we/wy, zachowując zgodność z formatem plików
46 Unidata NetCDF, w szczególności klasycznych formatach CDF 1, 2, 5.
47 Mimo że NetCDF obsługuje równoległe operacje we/wy począwszy od wersji
48 4, ale w oparciu o HDF5, więc opcja zrównoleglenia wymaga plików w
49 formacie HDF5. PnetCDF to obecnie jedyna możliwość zrównoleglenia
50 we/wy dla plików w klasycznych formatach.
51
52 %package devel
53 Summary:        Header files for PnetCDF library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PnetCDF
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       mpich-devel
58
59 %description devel
60 Header files for PnetCDF library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki PnetCDF.
64
65 %package static
66 Summary:        Static PnetCDF library
67 Summary(pl.UTF-8):      Statyczna biblioteka PnetCDF
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static PnetCDF library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka PnetCDF.
76
77 %package apidocs
78 Summary:        API documentation for PnetCDF library
79 Summary(pl.UTF-8):      Dokumentacja API biblioteki PnetCDF
80 Group:          Documentation
81 %{?noarchpackage}
82
83 %description apidocs
84 API documentation for PnetCDF library.
85
86 %description apidocs -l pl.UTF-8
87 Dokumentacja API biblioteki PnetCDF.
88
89 %prep
90 %setup -q -n pnetcdf-%{version}
91 %patch0 -p1
92
93 %build
94 %{__libtoolize}
95 %{__aclocal} -I m4
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         %{?with_apidocs:--enable-doxygen} \
101         --disable-silent-rules \
102         --enable-shared \
103         %{!?with_static_libs:--disable-static}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 # .la kept because of MPI dependencies
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS COPYRIGHT CREDITS README RELEASE_NOTES doc/README.{LINUX,consistency,large_files}
123 %attr(755,root,root) %{_bindir}/cdfdiff
124 %attr(755,root,root) %{_bindir}/ncmpidiff
125 %attr(755,root,root) %{_bindir}/ncmpidump
126 %attr(755,root,root) %{_bindir}/ncmpigen
127 %attr(755,root,root) %{_bindir}/ncoffsets
128 %attr(755,root,root) %{_bindir}/ncvalidator
129 %attr(755,root,root) %{_bindir}/pnetcdf_version
130 %attr(755,root,root) %{_libdir}/libpnetcdf.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libpnetcdf.so.4
132 %{_mandir}/man1/cdfdiff.1*
133 %{_mandir}/man1/ncmpidiff.1*
134 %{_mandir}/man1/ncmpidump.1*
135 %{_mandir}/man1/ncmpigen.1*
136 %{_mandir}/man1/ncoffsets.1*
137 %{_mandir}/man1/ncvalidator.1*
138 %{_mandir}/man1/pnetcdf_version.1*
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/pnetcdf-config
143 %attr(755,root,root) %{_libdir}/libpnetcdf.so
144 %{_libdir}/libpnetcdf.la
145 %{_includedir}/pnetcdf.h
146 %{_includedir}/pnetcdf
147 %{_includedir}/pnetcdf.inc
148 %{_includedir}/pnetcdf.mod
149 %{_pkgconfigdir}/pnetcdf.pc
150 %{_mandir}/man3/pnetcdf.3*
151 %{_mandir}/man3/pnetcdf_f77.3*
152 %{_mandir}/man3/pnetcdf_f90.3*
153
154 %if %{with static_libs}
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libpnetcdf.a
158 %endif
159
160 %if %{with apidocs}
161 %files apidocs
162 %defattr(644,root,root,755)
163 %doc doc/pnetcdf-api/pnetcdf-api.pdf
164 %endif
This page took 0.065311 seconds and 3 git commands to generate.