]> git.pld-linux.org Git - packages/pacparser.git/blob - pacparser.spec
- up to 1.2.7
[packages/pacparser.git] / pacparser.spec
1 # TODO:
2 # - description pl
3 # - python module (make pymod, unset SONAME for python module)
4 #
5 Summary:        A library to make your web software pac (proxy auto-config) files intelligent
6 Summary(pl.UTF-8):      Biblioteka do obsługi plików pac (automatycznej konfiguracji proxy)
7 Name:           pacparser
8 Version:        1.2.7
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries
12 Source0:        http://pacparser.googlecode.com/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  d97cd4136403ee73c1ec6aa96b6708ae
14 Patch0:         %{name}-make.patch
15 Patch1:         %{name}-libdir.patch
16 URL:            http://code.google.com/p/pacparser/
17 BuildRequires:  js-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 pacparser is a library to parse proxy auto-config (PAC) files. Proxy
22 auto-config files are a vastly used proxy configuration method these
23 days. Web browsers can use a PAC file to determine which proxy server
24 to use or whether to go direct for a given URL. PAC files are written
25 in JavaScript and can be programmed to return different proxy methods
26 (e.g. "PROXY proxy1:port; DIRECT") depending upon URL, source IP
27 address, protocol, time of the day etc. PAC files introduce a lot of
28 possibilities. Look at the wikipedia link above to find out more about
29 them.
30
31 Needless to say, PAC files are now a widely accepted method for proxy
32 configuration management and companies all over are using them in
33 corporate environment. Almost all popular web browsers support PAC
34 files. The idea behind pacparser is to make it easy to add this PAC
35 file parsing capability to any program (C and python supported right
36 now). It comes as a shared C library and a python module which can be
37 used to make any C or python program PAC scripts intelligent. Some
38 very useful targets could be popular web software like wget, curl and
39 python-urllib.
40
41 %package devel
42 Summary:        Header files for pacparser library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki pacparser
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for pacparser library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki pacparser.
52
53 %prep
54 %setup -q
55 %patch0 -p1
56 %patch1 -p1
57
58 %build
59 cd src
60 %{__make} \
61         CC="%{__cc}" \
62         CFLAGS="%{rpmcflags} -I/usr/include/js -DXP_UNIX" \
63         LDFLAGS="%{rpmldflags} -ljs" \
64         LIB=%{_lib}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 cd src
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT \
72         LIB=%{_lib}
73
74 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc README
85 %attr(755,root,root) %{_bindir}/*
86 %attr(755,root,root) %{_libdir}/libpacparser.so.1
87 %{_mandir}/man1/pactester.1*
88
89 %files devel
90 %defattr(644,root,root,755)
91 %{_mandir}/man3/pacparser*.3*
92 %{_libdir}/libpacparser.so
93 %{_includedir}/pacparser.h
This page took 0.081386 seconds and 3 git commands to generate.