]> git.pld-linux.org Git - packages/pacemaker.git/commitdiff
- updated to 1.1.19 auto/th/pacemaker-1.1.19-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 2 Sep 2018 14:41:48 +0000 (16:41 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 2 Sep 2018 14:41:48 +0000 (16:41 +0200)
- updated update,libs patches

pacemaker-libs.patch
pacemaker-update.patch
pacemaker.spec

index 4042ff2cc27051b83981a6a44e054a62bb2eb3ed..76554a17abe153dd57517e75cb3c632ee5b99ed4 100644 (file)
@@ -95,8 +95,8 @@
  
  AC_SUBST(GNUTLSHEAD)
  AC_SUBST(GNUTLSLIBS)
---- pacemaker-Pacemaker-1.1.16/pengine/Makefile.am.orig        2017-04-16 07:34:31.132737427 +0200
-+++ pacemaker-Pacemaker-1.1.16/pengine/Makefile.am     2017-04-16 07:37:33.349402011 +0200
+--- pacemaker-Pacemaker-1.1.19/pengine/Makefile.am.orig        2018-09-02 14:24:36.610144333 +0200
++++ pacemaker-Pacemaker-1.1.19/pengine/Makefile.am     2018-09-02 14:45:59.036796358 +0200
 @@ -66,14 +66,14 @@
  libpengine_la_LDFLAGS += $(LDFLAGS_HARDENED_LIB)
  
 +                      $(top_builddir)/lib/cib/libcib.la $(LIBXML2)
  # -L$(top_builddir)/lib/pils -lpils -export-dynamic -module -avoid-version
  libpengine_la_SOURCES = pengine.c allocate.c notif.c utils.c constraints.c
- libpengine_la_SOURCES += native.c group.c clone.c master.c graph.c utilization.c
+ libpengine_la_SOURCES += native.c group.c clone.c master.c graph.c utilization.c container.c
  
  pengine_CFLAGS        = $(CFLAGS_HARDENED_EXE)
  pengine_LDFLAGS       = $(LDFLAGS_HARDENED_EXE)
  # libcib for get_object_root()
  #             $(top_builddir)/lib/hbclient/libhbclient.la
  pengine_SOURCES       = main.c
---- pacemaker-Pacemaker-1.1.16/lib/common/Makefile.am.orig     2017-04-16 07:34:31.132737427 +0200
-+++ pacemaker-Pacemaker-1.1.16/lib/common/Makefile.am  2017-04-16 07:38:38.076067942 +0200
-@@ -36,7 +36,7 @@
+--- pacemaker-Pacemaker-1.1.19/lib/common/Makefile.am.orig     2018-09-02 14:46:36.066795934 +0200
++++ pacemaker-Pacemaker-1.1.19/lib/common/Makefile.am  2018-09-02 14:48:38.040127875 +0200
+@@ -35,7 +35,7 @@
  libcrmcommon_la_CFLAGS        = $(CFLAGS_HARDENED_LIB)
  libcrmcommon_la_LDFLAGS       += $(LDFLAGS_HARDENED_LIB)
  
--libcrmcommon_la_LIBADD        = @LIBADD_DL@ $(GNUTLSLIBS) -lm
+-libcrmcommon_la_LIBADD        = @LIBADD_DL@ $(GNUTLSLIBS)
 +libcrmcommon_la_LIBADD        = @LIBADD_DL@ $(LIBPLUMB) $(GNUTLSLIBS) $(LIBXML2) $(LIBXSLT) $(libqb_LIBS) $(LIBBZ2) $(LIBUUID) -lm
  
- libcrmcommon_la_SOURCES       = compat.c digest.c ipc.c io.c procfs.c utils.c xml.c \
-                         iso8601.c remote.c mainloop.c logging.c watchdog.c \
+ libcrmcommon_la_SOURCES       = compat.c digest.c ipc.c io.c procfs.c utils.c xml.c   \
+                         iso8601.c remote.c mainloop.c logging.c watchdog.c    \
 --- pacemaker-Pacemaker-1.1.16/lib/cib/Makefile.am.orig        2017-04-16 07:34:31.132737427 +0200
 +++ pacemaker-Pacemaker-1.1.16/lib/cib/Makefile.am     2017-04-16 07:39:18.802734141 +0200
 @@ -30,7 +30,7 @@
  
  clean-generic:
        rm -f *.log *.debug *.xml *~
---- pacemaker-Pacemaker-1.1.16/lib/pengine/Makefile.am.orig    2017-04-16 07:34:31.136070760 +0200
-+++ pacemaker-Pacemaker-1.1.16/lib/pengine/Makefile.am 2017-04-16 07:40:06.976066925 +0200
+--- pacemaker-Pacemaker-1.1.19/lib/pengine/Makefile.am.orig    2018-09-02 14:49:08.336794196 +0200
++++ pacemaker-Pacemaker-1.1.19/lib/pengine/Makefile.am 2018-09-02 15:23:34.093437276 +0200
 @@ -36,7 +36,7 @@
  libpe_status_la_CFLAGS        = $(CFLAGS_HARDENED_LIB)
  libpe_status_la_LDFLAGS       += $(LDFLAGS_HARDENED_LIB)
  
 -libpe_status_la_LIBADD        = @CURSESLIBS@ $(top_builddir)/lib/common/libcrmcommon.la
 +libpe_status_la_LIBADD        = @CURSESLIBS@ $(top_builddir)/lib/common/libcrmcommon.la $(LIBXML2)
- libpe_status_la_SOURCES       = status.c unpack.c utils.c complex.c native.c \
-                       group.c clone.c rules.c common.c remote.c
+ libpe_status_la_SOURCES       = status.c unpack.c utils.c complex.c native.c container.c \
+                       group.c clone.c rules.c common.c failcounts.c remote.c
  
---- pacemaker-Pacemaker-1.1.16/lib/fencing/Makefile.am.orig    2017-04-16 07:34:31.236070760 +0200
-+++ pacemaker-Pacemaker-1.1.16/lib/fencing/Makefile.am 2017-04-16 07:42:06.086065565 +0200
-@@ -25,5 +25,5 @@
+--- pacemaker-Pacemaker-1.1.19/lib/fencing/Makefile.am.orig    2018-09-02 14:49:08.340127529 +0200
++++ pacemaker-Pacemaker-1.1.19/lib/fencing/Makefile.am 2018-09-02 15:24:03.616770271 +0200
+@@ -14,7 +14,7 @@
  libstonithd_la_CFLAGS = $(CFLAGS_HARDENED_LIB)
  libstonithd_la_LDFLAGS        += $(LDFLAGS_HARDENED_LIB)
  
 -libstonithd_la_LIBADD = $(top_builddir)/lib/common/libcrmcommon.la
 +libstonithd_la_LIBADD = $(top_builddir)/lib/common/libcrmcommon.la $(LIBPILS)
- libstonithd_la_SOURCES        = st_client.c
+ libstonithd_la_SOURCES        = st_client.c st_rhcs.c
+ if BUILD_LHA_SUPPORT
 --- pacemaker-Pacemaker-1.1.16/cib/Makefile.am.orig    2017-04-16 07:34:31.236070760 +0200
 +++ pacemaker-Pacemaker-1.1.16/cib/Makefile.am 2017-04-16 07:42:50.786065054 +0200
 @@ -36,7 +36,7 @@
index 142401e2b4a01e6c926707200a4207fc4f5b938b..e0c4a8b60ce12c1a58565eefdbf39b17dd2752e4 100644 (file)
@@ -1,5 +1,13 @@
 --- pacemaker-Pacemaker-1.1.10/tools/notifyServicelogEvent.c.orig      2013-07-26 02:02:31.000000000 +0200
 +++ pacemaker-Pacemaker-1.1.10/tools/notifyServicelogEvent.c   2013-09-07 22:08:44.162036132 +0200
+@@ -27,6 +27,7 @@
+ #include <syslog.h>
+ #include <unistd.h>
+ #include <config.h>
++#include <crm/attrd.h>
+ #include <crm/common/xml.h>
+ #include <crm/common/util.h>
+ #include <crm_internal.h>
 @@ -31,13 +31,13 @@
  #include <crm/common/util.h>
  #include <crm_internal.h>
          const char *health_component = "#health-ipmi";
          const char *health_status = NULL;
  
-@@ -167,9 +167,9 @@
-         if (health_status) {
-             gboolean rc;
--            rc = attrd_update_no_mainloop(NULL,
-+            rc = (attrd_update_delegate(NULL,
-                                           'v',
--                                          NULL, health_component, health_status, NULL, NULL, NULL);
-+                                          NULL, health_component, health_status, NULL, NULL, NULL, NULL) > 0);
-             crm_debug("attrd_update_no_mainloop ('%s', '%s') = %d",
-                       health_component, health_status, rc);
 --- pacemaker-Pacemaker-1.1.10/tools/ipmiservicelogd.c.orig    2013-07-26 02:02:31.000000000 +0200
 +++ pacemaker-Pacemaker-1.1.10/tools/ipmiservicelogd.c 2013-09-07 22:09:35.002033998 +0200
 @@ -565,7 +565,7 @@
index 3e9cdc2fa4cc6416a2de3d1bd08782a45a7cbabf..a0c20a81d678430cecc5cab3f21a5add293347ff 100644 (file)
 Summary:       The scalable High-Availability cluster resource manager
 Summary(pl.UTF-8):     Skalowalny zarządca zasobów klastrów o wysokiej dostępności
 Name:          pacemaker
-Version:       1.1.16
+Version:       1.1.19
 Release:       1
 License:       GPL v2+, LGPL v2.1+
 Group:         Applications/System
 #Source0Download: https://github.com/ClusterLabs/pacemaker/releases
 Source0:       https://github.com/ClusterLabs/pacemaker/archive/Pacemaker-%{version}.tar.gz
-# Source0-md5: a3b9d075bc9114ff698966e57e50bb12
+# Source0-md5: 335dab2fd6b3a284a6bd2bbeef60c960
 Source1:       %{name}.tmpfiles
 Source2:       %{name}.init
 Source3:       %{name}.service
@@ -103,6 +103,7 @@ Pacemaker był wcześniej częścią pakietu Heartbeat.
 Summary:       Pacemaker libraries
 Summary(pl.UTF-8):     Biblioteki Pacemakera
 Group:         Libraries
+Requires:      libqb >= 0.13
 
 %description libs
 Shared libraries for Pacemaker.
@@ -298,17 +299,17 @@ fi
 %endif
 %attr(755,root,root) %{_sbindir}/notifyServicelogEvent
 %endif
-%dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/attrd
-%attr(755,root,root) %{_libdir}/%{name}/cib
-%attr(755,root,root) %{_libdir}/%{name}/cibmon
-%attr(755,root,root) %{_libdir}/%{name}/crmd
-%attr(755,root,root) %{_libdir}/%{name}/lrmd
-%attr(755,root,root) %{_libdir}/%{name}/lrmd_internal_ctl
-%attr(755,root,root) %{_libdir}/%{name}/lrmd_test
-%attr(755,root,root) %{_libdir}/%{name}/pengine
-%attr(755,root,root) %{_libdir}/%{name}/stonith-test
-%attr(755,root,root) %{_libdir}/%{name}/stonithd
+%dir %{_libexecdir}/%{name}
+%attr(755,root,root) %{_libexecdir}/%{name}/attrd
+%attr(755,root,root) %{_libexecdir}/%{name}/cib
+%attr(755,root,root) %{_libexecdir}/%{name}/cibmon
+%attr(755,root,root) %{_libexecdir}/%{name}/crmd
+%attr(755,root,root) %{_libexecdir}/%{name}/lrmd
+%attr(755,root,root) %{_libexecdir}/%{name}/lrmd_internal_ctl
+%attr(755,root,root) %{_libexecdir}/%{name}/lrmd_test
+%attr(755,root,root) %{_libexecdir}/%{name}/pengine
+%attr(755,root,root) %{_libexecdir}/%{name}/stonith-test
+%attr(755,root,root) %{_libexecdir}/%{name}/stonithd
 %{_datadir}/pacemaker
 %{_datadir}/mibs/PCMK-MIB.txt
 %{py_sitedir}/cts
@@ -356,6 +357,7 @@ fi
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/SystemHealth
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/attribute
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/controld
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/ifspeed
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/o2cb
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/ping
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/pingd
This page took 0.203159 seconds and 4 git commands to generate.