]> git.pld-linux.org Git - packages/pacemaker.git/commitdiff
- 1.0.9.1
authorMarek Marczykowski <marmarek@pld-linux.org>
Thu, 28 Apr 2011 21:55:37 +0000 (21:55 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- corosync (OpenAIS) support
- some linking fixes

Changed files:
    pacemaker-libs.patch -> 1.1
    pacemaker-ncurses.patch -> 1.2
    pacemaker.spec -> 1.6

pacemaker-libs.patch [new file with mode: 0644]
pacemaker-ncurses.patch
pacemaker.spec

diff --git a/pacemaker-libs.patch b/pacemaker-libs.patch
new file mode 100644 (file)
index 0000000..8b93f3e
--- /dev/null
@@ -0,0 +1,61 @@
+diff -ru Pacemaker-1-0-Pacemaker-1.0.9.1.orig/pengine/Makefile.am Pacemaker-1-0-Pacemaker-1.0.9.1/pengine/Makefile.am
+--- Pacemaker-1-0-Pacemaker-1.0.9.1.orig/pengine/Makefile.am   2010-06-23 20:08:40.000000000 +0200
++++ Pacemaker-1-0-Pacemaker-1.0.9.1/pengine/Makefile.am        2011-04-28 08:53:55.536677098 +0200
+@@ -58,6 +58,7 @@
+ # -L$(top_builddir)/lib/pils -lpils -export-dynamic -module -avoid-version 
+ libpengine_la_SOURCES = pengine.c allocate.c utils.c constraints.c \
+                       native.c group.c clone.c master.c graph.c
++libpengine_la_LIBADD  = $(top_builddir)/lib/pengine/libpe_status.la
+ pengine_SOURCES       = main.c
+ pengine_LDADD = $(COMMONLIBS) $(top_builddir)/lib/cib/libcib.la
+diff -ru Pacemaker-1-0-Pacemaker-1.0.9.1.orig/tools/Makefile.am Pacemaker-1-0-Pacemaker-1.0.9.1/tools/Makefile.am
+--- Pacemaker-1-0-Pacemaker-1.0.9.1.orig/tools/Makefile.am     2010-06-23 20:08:40.000000000 +0200
++++ Pacemaker-1-0-Pacemaker-1.0.9.1/tools/Makefile.am  2011-04-28 09:38:06.620010890 +0200
+@@ -85,7 +85,7 @@
+ crm_diff_LDADD                = $(COMMONLIBS)
+ crm_mon_SOURCES               = crm_mon.c
+-crm_mon_LDADD         = $(COMMONLIBS) $(SNMPLIBS) $(ESMTPLIBS) -llrm \
++crm_mon_LDADD         = $(COMMONLIBS) $(SNMPLIBS) $(ESMTPLIBS) -llrm -ltinfo \
+                       $(top_builddir)/lib/pengine/libpe_status.la
+ # Arguments could be made that this should live in crm/pengine
+--- Pacemaker-1-0-Pacemaker-1.0.9.1.orig/lib/pengine/Makefile.am       2010-06-23 20:08:40.000000000 +0200
++++ Pacemaker-1-0-Pacemaker-1.0.9.1/lib/pengine/Makefile.am    2011-04-28 10:04:50.773343305 +0200
+@@ -31,10 +31,13 @@
+ libpe_rules_la_LDFLAGS        = -version-info 2:0:0
+ libpe_rules_la_SOURCES        = $(rule_files)
++libpe_rules_la_LIBADD = $(top_builddir)/lib/common/libcrmcommon.la
+ libpe_status_la_LDFLAGS       = -version-info 2:0:0
+ libpe_status_la_SOURCES       =  $(rule_files) $(status_files)
+-libpe_status_la_LIBADD        = -llrm
++libpe_status_la_LIBADD        = -llrm $(CURSESLIBS) \
++                        $(top_builddir)/lib/common/libcrmcommon.la \
++                        $(top_builddir)/lib/cib/libcib.la
+ clean-generic:
+       rm -f *.log *.debug *~
+--- Pacemaker-1-0-Pacemaker-1.0.9.1.orig/lib/transition/Makefile.am    2010-06-23 20:08:40.000000000 +0200
++++ Pacemaker-1-0-Pacemaker-1.0.9.1/lib/transition/Makefile.am 2011-04-28 10:06:49.623343760 +0200
+@@ -29,6 +29,7 @@
+ libtransitioner_la_LDFLAGS    = -version-info 1:0:0
+ libtransitioner_la_CFLAGS     = -I$(top_builddir)
++libtransitioner_la_LIBADD     = $(top_builddir)/lib/common/libcrmcommon.la
+ clean-generic:
+       rm -f *~
+--- Pacemaker-1-0-Pacemaker-1.0.9.1.orig/lib/Makefile.am       2010-06-23 20:08:40.000000000 +0200
++++ Pacemaker-1-0-Pacemaker-1.0.9.1/lib/Makefile.am    2011-04-28 10:09:28.876677338 +0200
+@@ -18,7 +18,7 @@
+ MAINTAINERCLEANFILES    = Makefile.in
+ ## Subdirectories...
+-SUBDIRS       = common pengine transition cib fencing plugins
++SUBDIRS       = common cib pengine transition fencing plugins
+ DIST_SUBDIRS =  $(SUBDIRS) ais
+ if BUILD_AIS_SUPPORT
index 16f7e2ec585a5d3daed0e9164f22a8ece15a4782..b5698da6a77c6291715ba2fff1307146e86c7649 100644 (file)
@@ -1,5 +1,5 @@
---- Pacemaker-1-0-Pacemaker-1.0.3/configure.in.orig    2009-05-11 14:26:54.000000000 +0200
-+++ Pacemaker-1-0-Pacemaker-1.0.3/configure.in 2009-05-11 14:26:54.000000000 +0200
+--- Pacemaker-1-0-Pacemaker-1.0.3/configure.ac.orig    2009-05-11 14:26:54.000000000 +0200
++++ Pacemaker-1-0-Pacemaker-1.0.3/configure.ac 2009-05-11 14:26:54.000000000 +0200
 @@ -746,8 +746,12 @@
              [
  #if defined(HAVE_CURSES_H)
index 017429824ed6454b80e0190ac05d6c1497630e31..784a0039def6465f4c3121bc892ee1a540b36499 100644 (file)
@@ -1,21 +1,21 @@
-#
-# TODO:
-#      - OpenAIS support
-#
+%bcond_without corosync    # by default use heartbeat
+%bcond_with    heartbeat   # by default use heartbeat
 Summary:       The scalable High-Availability cluster resource manager
 Name:          pacemaker
-Version:       1.0.3
+Version:       1.0.9.1
 Release:       1
 License:       GPL v2+; LGPL v2.1+
 Group:         Applications/System
 Source0:       http://hg.clusterlabs.org/pacemaker/stable-1.0/archive/Pacemaker-%{version}.tar.bz2
-# Source0-md5: b377be64de0920773168bda3abf54319
+# Source0-md5: c844d98a5e6163192dd9f073ba9856ff
 Patch0:                %{name}-ncurses.patch
 Patch1:                %{name}-liborder.patch
+Patch2:                %{name}-libs.patch
 URL:           http://clusterlabs.org/wiki/Main_Page
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
+%{?with_corosync:BuildRequires:        corosync-devel}
 BuildRequires: e2fsprogs-devel
 BuildRequires: glib2-devel
 BuildRequires: gnutls-devel
@@ -29,9 +29,11 @@ BuildRequires:       net-snmp-devel
 BuildRequires: pam-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
 BuildRequires: swig
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      heartbeat
+%{?with_corosync:Requires:     corosync}
+%{?with_heartbeat:Requires:    heartbeat}
 Provides:      group(haclient)
 Provides:      user(hacluster)
 Conflicts:     heartbeat < 2.99.0
@@ -77,7 +79,8 @@ Static Pacemaker libraries.
 %prep
 %setup -qn Pacemaker-1-0-Pacemaker-%{version}
 %patch0 -p1
-%patch1 -p1
+#%patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
@@ -87,8 +90,10 @@ Static Pacemaker libraries.
 %{__automake}
 
 %configure \
-       --with-heartbeat \
-       --without-ais \
+       %{?with_heartbeat:--with-heartbeat} \
+       %{!?with_heartbeat:--without-heartbeat} \
+       %{?with_corosync:--with-ais} \
+       %{?without_corosync:--without-ais} \
        --with-snmp \
        --with-esmtp \
        --disable-fatal-warnings
@@ -101,7 +106,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -r $RPM_BUILD_ROOT%{_docdir}/packages
+rm -r $RPM_BUILD_ROOT%{_docdir}/pacemaker
 rm $RPM_BUILD_ROOT%{_libdir}/heartbeat/plugins/RAExec/*.{la,a}
 
 %clean
@@ -113,7 +118,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc doc/README* doc/*.html doc/*.txt doc/AUTHORS doc/Design
+%doc doc/README* doc/*.html doc/*.txt AUTHORS COPYING* doc/Pacemaker_Explained
 %{_datadir}/pacemaker
 %dir %{_libdir}/heartbeat/plugins/RAExec
 %attr(755,root,root) %{_libdir}/heartbeat/plugins/RAExec/*.so
@@ -132,7 +137,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/heartbeat/crm_primitive.py
 %{_libdir}/heartbeat/hb2openais-helper.py
 %{_libdir}/heartbeat/*.py[co]
-
 %attr(755,root,root) %{_sbindir}/cibadmin
 %attr(755,root,root) %{_sbindir}/crm_attribute
 %attr(755,root,root) %{_sbindir}/crm_diff
@@ -151,12 +155,24 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/cibpipe
 %attr(755,root,root) %{_sbindir}/crm_node
 %attr(755,root,root) %{_sbindir}/crm_uuid
+%{py_sitedir}/crm
+%{_datadir}/snmp/mibs/PCMK-MIB.txt
 %{_mandir}/man8/*.8*
 %dir %attr(750,hacluster,haclient) %{_var}/lib/heartbeat/crm
 %dir %attr(750,hacluster,haclient) %{_var}/lib/pengine
 %dir %attr(750,hacluster,haclient) %{_var}/run/crm
-%attr(755,root,root) %{_libdir}/ocf/resource.d/pacemaker
-#%{_libexecdir}/lcrso/pacemaker.lcrso
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/ClusterMon
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/Dummy
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/HealthCPU
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/HealthSMART
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/Stateful
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/SysInfo
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/SystemHealth
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/controld
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/o2cb
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/ping
+%attr(755,root,root) %{_prefix}/lib/ocf/resource.d/pacemaker/pingd
+%{_libexecdir}/lcrso/pacemaker.lcrso
 
 %files libs
 %defattr(644,root,root,755)
This page took 0.177423 seconds and 4 git commands to generate.