]> git.pld-linux.org Git - packages/owncloudclient.git/blob - owncloudclient.spec
updated to 2.3.3
[packages/owncloudclient.git] / owncloudclient.spec
1 #
2 # Conditional build:
3 %bcond_without  nautilus        # build Nautilus extension
4 %bcond_without  caja            # build caja extension
5 %bcond_with     dolphin         # build dolphin extension
6 %bcond_without  doc             # build docs
7 %bcond_without  gui             # build only libraries
8
9 %if %{without gui}
10 %undefine       with_nautilus
11 %undefine       with_caja
12 %undefine       with_dolphin
13 %undefine       with_doc
14 %endif
15
16 %define         qtver   5.4
17 Summary:        The ownCloud client
18 Name:           owncloudclient
19 Version:        2.3.3
20 Release:        1
21 License:        GPL v2+
22 Group:          X11/Applications
23 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
24 # Source0-md5:  bba20fc6f38e0b14f6ceb9ab432d1802
25 Patch0:         syslibs.patch
26 URL:            https://www.owncloud.com/
27 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
28 BuildRequires:  Qt5Core-devel >= %{qtver}
29 BuildRequires:  Qt5DBus-devel >= %{qtver}
30 BuildRequires:  Qt5Gui-devel >= %{qtver}
31 BuildRequires:  Qt5Keychain-devel
32 BuildRequires:  Qt5Network-devel >= %{qtver}
33 BuildRequires:  Qt5WebKit-devel >= %{qtver}
34 BuildRequires:  Qt5Xml-devel >= %{qtver}
35 BuildRequires:  cmake >= 2.8.11
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  openssl-devel >= 1.0.0
38 BuildRequires:  pkgconfig
39 BuildRequires:  qt5-linguist >= %{qtver}
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.596
42 BuildRequires:  sqlite3-devel >= 3.8.0
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  xz
45 BuildRequires:  zlib-devel
46 %if %{with gui}
47 BuildRequires:  Qt5LockedFile-devel >= 2.4
48 BuildRequires:  Qt5SingleApplication-devel >= 2.6.1-3
49 BuildRequires:  Qt5Sql-devel >= %{qtver}
50 BuildConflicts: QtLockedFile-devel
51 %endif
52 %if %{with dolphin}
53 BuildRequires:  kf5-attica-devel >= 5.16
54 BuildRequires:  kf5-extra-cmake-modules >= 1.2.0
55 BuildRequires:  kf5-kconfig-devel >= 5.16
56 BuildRequires:  kf5-ki18n-devel >= 5.16
57 BuildRequires:  kf5-kio-devel >= 5.16
58 %endif
59 %if %{with doc}
60 BuildRequires:  doxygen
61 BuildRequires:  sphinx-pdg-2
62 BuildRequires:  texlive-format-pdflatex
63 BuildRequires:  texlive-latex-ams
64 BuildRequires:  texlive-makeindex
65 BuildRequires:  texlive-pdftex
66 BuildRequires:  texlive-plain
67 BuildRequires:  texlive-xetex
68 %endif
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       Qt5Gui-platform-xcb
71 Requires:       Qt5SingleApplication >= 2.6.1-3
72 Requires:       desktop-file-utils
73 Requires:       gtk-update-icon-cache
74 Requires:       hicolor-icon-theme
75 Suggests:       %{name}-nautilus
76 Suggests:       %{name}-nemo
77 Obsoletes:      mirall < 1.8
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 ownCloud client enables you to connect to your private ownCloud
82 Server. With it you can create folders in your home directory, and
83 keep the contents of those folders synced with your ownCloud server.
84 Simply copy a file into the directory and the ownCloud Client does the
85 rest.
86
87 ownCloud gives your employees anytime, anywhere access to the files
88 they need to get the job done, whether through this desktop
89 application, our mobile apps, the web interface, or other WebDAV
90 clients. With it, your employees can easily view and share documents
91 and information critical to the business, in a secure, flexible and
92 controlled architecture. You can easily extend ownCloud with plug-ins
93 from the community, or that you build yourself to meet the
94 requirements of your infrastructure and business.
95
96 %package libs
97 Summary:        Shared ownCloud client libraries
98 Group:          Libraries
99 Obsoletes:      mirall-libs < 1.8
100
101 %description libs
102 Shared ownCloud client libraries.
103
104 %package devel
105 Summary:        Header files for %{name} library
106 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
107 Group:          Development/Libraries
108 Requires:       %{name}-libs = %{version}-%{release}
109
110 %description devel
111 Header files for %{name} library.
112
113 %description devel -l pl.UTF-8
114 Pliki nagłówkowe biblioteki %{name}.
115
116 %package apidocs
117 Summary:        %{name} API documentation
118 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
119 Group:          Documentation
120 %if "%{_rpmversion}" >= "5"
121 BuildArch:      noarch
122 %endif
123
124 %description apidocs
125 API documentation for %{name} library.
126
127 %description apidocs -l pl.UTF-8
128 Dokumentacja API biblioteki %{name}.
129
130 %package nautilus
131 Summary:        Nautilus overlay icons
132 Group:          Applications
133 Requires:       %{name} = %{version}-%{release}
134 Requires:       nautilus-python
135
136 %description nautilus
137 This package provides overlay icons to visualize the sync state in the
138 Nautilus file manager.
139
140 %package caja
141 Summary:        Caja overlay icons
142 Group:          Applications
143 Requires:       %{name} = %{version}-%{release}
144 Requires:       caja-python
145
146 %description caja
147 This package provides overlay icons to visualize the sync state in the
148 Caja file manager.
149
150 %prep
151 %setup -q
152 %patch0 -p1
153
154 mv src/3rdparty/qtlockedfile .
155 mv src/3rdparty/qtsingleapplication .
156
157 %build
158 install -d build
159 cd build
160 %cmake \
161         -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qt5keychain \
162         -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqt5keychain.so \
163         -DQT_LRELEASE_EXECUTABLE=/usr/bin/lrelease-qt5 \
164         -DBUILD_WITH_QT4=NO \
165 %if %{with doc}
166         -DSPHINX_EXECUTABLE=/usr/bin/sphinx-build-2 \
167         -DPDFLATEX_EXECUTABLE=/usr/bin/pdflatex \
168         -DDOXYGEN_EXECUTABLE=/usr/bin/doxygen \
169         -DCMAKE_INSTALL_DOCDIR=%{_docdir}/%{name} \
170 %else
171         -DWITH_DOC=NO \
172         -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=TRUE \
173         -DCMAKE_DISABLE_FIND_PACKAGE_PdfLatex=TRUE \
174         -DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=TRUE \
175 %endif
176 %if %{without dolphin}
177         -DCMAKE_DISABLE_FIND_PACKAGE_ECM=TRUE \
178         -DCMAKE_DISABLE_FIND_PACKAGE_KF5=TRUE \
179 %endif
180         %{!?with_gui:-DBUILD_LIBRARIES_ONLY=ON} \
181         ..
182 %{__make}
183
184 %if %{with doc}
185 %{__make} doc
186 rm doc/html/unthemed/.buildinfo
187 %endif
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191 %{__make} -C build install \
192         DESTDIR=$RPM_BUILD_ROOT
193
194 # owncloud client links without rpath
195 mv $RPM_BUILD_ROOT%{_libdir}/owncloud/libocsync.so* $RPM_BUILD_ROOT%{_libdir}
196
197 %if %{with nautilus}
198 # nemo not in pld
199 %{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate-ownCloud.py*
200 %endif
201
202 %clean
203 rm -rf $RPM_BUILD_ROOT
204
205 %post
206 %update_desktop_database
207 %update_icon_cache hicolor
208
209 %postun
210 %update_desktop_database
211 %update_icon_cache hicolor
212
213 %post   libs -p /sbin/ldconfig
214 %postun libs -p /sbin/ldconfig
215
216 %if %{with gui}
217 %files
218 %defattr(644,root,root,755)
219 %doc README.md COPYING
220 %attr(755,root,root) %{_bindir}/owncloud
221 %attr(755,root,root) %{_bindir}/owncloudcmd
222 %{_desktopdir}/owncloud.desktop
223 %{_iconsdir}/*/*/apps/*.png
224 %{_datadir}/owncloud
225 %dir %{_libdir}/owncloud
226 %if %{with doc}
227 %{_mandir}/man1/owncloud.1*
228 %{_mandir}/man1/owncloudcmd.1*
229 %endif
230 %endif
231
232 %files libs
233 %defattr(644,root,root,755)
234 %dir %{_sysconfdir}/ownCloud
235 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/sync-exclude.lst
236 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
237 %ghost %{_libdir}/libowncloudsync.so.0
238 %attr(755,root,root) %{_libdir}/libocsync.so.*.*.*
239 %ghost %{_libdir}/libocsync.so.0
240
241 %files devel
242 %defattr(644,root,root,755)
243 %{_includedir}/owncloudsync
244 %{_libdir}/libowncloudsync.so
245 %{_libdir}/libocsync.so
246
247 %if %{with nautilus}
248 %files nautilus
249 %defattr(644,root,root,755)
250 %{_datadir}/nautilus-python/extensions/syncstate-ownCloud.py*
251 %endif
252
253 %if %{with caja}
254 %files caja
255 %defattr(644,root,root,755)
256 %{_datadir}/caja-python/extensions/syncstate-ownCloud.py*
257 %endif
258
259 %if %{with doc}
260 %files apidocs
261 %defattr(644,root,root,755)
262 %doc %{_docdir}/%{name}
263 %endif
This page took 0.134681 seconds and 3 git commands to generate.