]> git.pld-linux.org Git - packages/ossp-uuid.git/blob - ossp-uuid.spec
rebuild with perl 5.34.0
[packages/ossp-uuid.git] / ossp-uuid.spec
1 #
2 # Conditional build:
3 %bcond_with     php             # don't build PHP binding
4 %bcond_without  perl            # don't build Perl binding
5 %bcond_with     pgsql           # build postgresql binding
6 %bcond_without  static_libs     # don't build static libraries
7
8 Summary:        Universally Unique Identifier library
9 Summary(pl.UTF-8):      Biblioteka unikalnych identyfikatorów UUID
10 Name:           ossp-uuid
11 Version:        1.6.2
12 Release:        34
13 License:        MIT
14 Group:          Libraries
15 Source0:        ftp://ftp.ossp.org/pkg/lib/uuid/uuid-%{version}.tar.gz
16 # Source0-md5:  5db0d43a9022a6ebbbc25337ae28942f
17 Patch0:         uuid-ossp-prefix.patch
18 Patch1:         php3.patch
19 URL:            http://www.ossp.org/pkg/lib/uuid/
20 BuildRequires:  automake
21 %{?with_php:BuildRequires:      %{php_name}-devel}
22 %{?with_php:BuildRequires:      %{php_name}-program}
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool
25 %{?with_perl:BuildRequires:     perl-devel}
26 %{?with_pgsql:BuildRequires:    postgresql-backend-devel}
27 %{?with_pgsql:BuildRequires:    postgresql-devel}
28 BuildRequires:  rpmbuild(macros) >= 1.519
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 OSSP uuid is a ISO-C:1999 application programming interface (API) and
33 corresponding command line interface (CLI) for the generation of DCE
34 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant Universally Unique
35 Identifier (UUID). It supports DCE 1.1 variant UUIDs of version 1
36 (time and node based), version 3 (name based, MD5), version 4 (random
37 number based) and version 5 (name based, SHA-1). Additional API
38 bindings are provided for the languages ISO-C++:1998, Perl:5 and
39 PHP:4/5. Optional backward compatibility exists for the ISO-C DCE-1.1
40 and Perl Data::UUID APIs.
41
42 %description -l pl.UTF-8
43 OSSP uuid to interfejs programistyczny (API) ISO-C:1999 i
44 odpowiadający mu interfejs linii poleceń (CLI) do generowania
45 całkowicie unikalnych identyfikatorów UUID (Universally Unique
46 Identifier) zgodnych z DCE 1.1, ISO/IEC 11578:1996 i RFC 4122.
47 Obsługuje wariant DCE 1.1 UUID-ów w wersji 1 (oparty na czasie i
48 węzłach), w wersji 3 (oparty na nazwie i MD5), w wersji 4 (oparty na
49 liczbach losowych) oraz w wersji 5 (oparty na nazwach i SHA-1).
50 Załączone są dodatkowe wiązania API do języków ISO-C++:1998, Perl:5
51 oraz PHP:4/5. Istnieje też opcjonalna warstwa kompatybilności dla API
52 ISO-C DCE-1.1 i perlowego Data::UUID.
53
54 %package devel
55 Summary:        Development files for Universally Unique Identifier library
56 Summary(pl.UTF-8):      Pliki programistyczne biblioteki OSSP uuid
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59
60 %description devel
61 Development headers and libraries for OSSP uuid.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki OSSP uuid.
65
66 %package static
67 Summary:        Universally Unique Identifier library - static library
68 Summary(pl.UTF-8):      Biblioteka statyczna OSSP uuid
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Universally Unique Identifier library - static library
74
75 %description static -l pl.UTF-8
76 Biblioteka statyczna OSSP uuid
77
78 %package c++
79 Summary:        C++ support for Universally Unique Identifier library
80 Summary(pl.UTF-8):      Wiązania C++ dla biblioteki OSSP uuid
81 Group:          Libraries
82 Requires:       %{name} = %{version}-%{release}
83
84 %description c++
85 C++ binding for OSSP uuid library.
86
87 %description c++ -l pl.UTF-8
88 Wiązania C++ dla biblioteki OSSP uuid.
89
90 %package c++-devel
91 Summary:        C++ development support for Universally Unique Identifier library
92 Summary(pl.UTF-8):      Pliki programistyczne wiązania C++ biblioteki OSSP uuid
93 Group:          Development/Libraries
94 Requires:       %{name}-c++ = %{version}-%{release}
95 Requires:       %{name}-devel = %{version}-%{release}
96 Requires:       libstdc++-devel
97
98 %description c++-devel
99 C++ development headers and libraries for OSSP uuid.
100
101 %description c++-devel -l pl.UTF-8
102 Pliki programistyczne wiązania C++ biblioteki OSSP uuid.
103
104 %package c++-static
105 Summary:        C++ support for Universally Unique Identifier library - static library
106 Summary(pl.UTF-8):      Wiązania C++ dla biblioteki OSSP uuid - biblioteka statyczna
107 Group:          Development/Libraries
108 Requires:       %{name}-c++-devel = %{version}-%{release}
109
110 %description c++-static
111 C++ support for Universally Unique Identifier library - static library
112
113 %description c++-static -l pl.UTF-8
114 Wiązania C++ dla biblioteki OSSP uuid - biblioteka statyczna
115
116 %package dce
117 Summary:        DCE support for Universally Unique Identifier library
118 Summary(pl.UTF-8):      Obsługa DCE dla biblioteki OSSP uuid
119 Group:          Development/Libraries
120 Requires:       %{name} = %{version}-%{release}
121
122 %description dce
123 DCE OSSP uuid library.
124
125 %description dce -l pl.UTF-8
126 Biblioteka DCE OSSP uuid.
127
128 %package dce-devel
129 Summary:        DCE development support for Universally Unique Identifier library
130 Summary(pl.UTF-8):      Pliki programistyczne obsługi DCE dla biblioteki OSSP uuid
131 Group:          Development/Libraries
132 Requires:       %{name}-dce = %{version}-%{release}
133 Requires:       %{name}-devel = %{version}-%{release}
134
135 %description dce-devel
136 DCE development headers and libraries for OSSP uuid.
137
138 %description dce-devel -l pl.UTF-8
139 Pliki programistyczne obsługi DCE dla biblioteki OSSP uuid.
140
141 %package dce-static
142 Summary:        DCE development support for Universally Unique Identifier library - static library
143 Summary(pl.UTF-8):      Pliki programistyczne obsługi DCE dla biblioteki OSSP uuid - biblioteka statyczna
144 Group:          Development/Libraries
145 Requires:       %{name}-dce-devel = %{version}-%{release}
146
147 %description dce-static
148 DCE development support for Universally Unique Identifier library -
149 static library
150
151 %description dce-static -l pl.UTF-8
152 Pliki programistyczne obsługi DCE dla biblioteki OSSP uuid -
153 biblioteka statyczna
154
155 %package -n perl-uuid
156 Summary:        OSSP uuid Perl Binding
157 Summary(pl.UTF-8):      Perlowe wiązania biblioteki OSSP uuid
158 Group:          Development/Libraries
159 Requires:       %{name} = %{version}-%{release}
160
161 %description -n perl-uuid
162 Perl OSSP uuid modules, which includes a Data::UUID replacement.
163
164 %description -n perl-uuid -l pl.UTF-8
165 Moduły Perla OSSP uuid, zawierające zamiennik Data::UUID.
166
167 %package -n %{php_name}-uuid
168 Summary:        PHP support for Universally Unique Identifier library
169 Summary(pl.UTF-8):      Wiązania PHP dla biblioteki OSSP UUID
170 Group:          Development/Libraries
171 Requires:       %{name} = %{version}-%{release}
172 %{?requires_php_extension}
173
174 %description -n %{php_name}-uuid
175 UUID is a PHP extension for the creation of Universally Unique
176 Identifiers (UUID).
177
178 %description -n %{php_name}-uuid -l pl.UTF-8
179 UUID to rozrzeszenie PHP do tworzenia całkowicie unikalnych
180 identyfikatorów UUID.
181
182 %package -n postgresql-uuid
183 Summary:        OSSP uuid bindings for PostgreSQL
184 Summary(pl.UTF-8):      Wiązania OSSP uuid dla PostgreSQL-a
185 Group:          Development/Libraries
186 Requires:       %{name} = %{version}-%{release}
187
188 %description -n postgresql-uuid
189 PostgreSQL OSSP uuid module.
190
191 %description -n postgresql-uuid -l pl.UTF-8
192 Moduł OSSP uuid dla PostgreSQL-a.
193
194 %prep
195 %setup -q -n uuid-%{version}
196 %patch0 -p1
197 %patch1 -p1
198
199 %build
200 cp -f /usr/share/automake/config.sub .
201 %if %{with php}
202 cd php
203 %{__libtoolize}
204 cd ..
205 %endif
206 # Build the library.
207 %configure \
208         --includedir=%{_includedir}/ossp-uuid \
209         %{!?with_static_libs:--disable-static} \
210         --with-dce \
211         --with-cxx \
212         --with%{!?with_perl:out}-perl \
213         --with%{!?with_php:out}-php PHP=php \
214         --with%{!?with_pgsql:out}-pgsql
215
216 %{__make}
217
218 %install
219 rm -rf $RPM_BUILD_ROOT
220 install -d $RPM_BUILD_ROOT/%{_lib}
221 %{__make} install \
222         WITH_PHP=no \
223         WITH_PERL=no \
224         DESTDIR=$RPM_BUILD_ROOT
225
226 mv -f $RPM_BUILD_ROOT%{_libdir}/libossp-uuid.so.* $RPM_BUILD_ROOT/%{_lib}
227 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libossp-uuid.so.*.*) $RPM_BUILD_ROOT%{_libdir}/libossp-uuid.so
228
229 %if %{with perl}
230 %{__make} pure_install \
231         -C perl \
232         INSTALLDIRS=vendor \
233         DESTDIR=$RPM_BUILD_ROOT
234
235 rm $RPM_BUILD_ROOT%{perl_vendorarch}/OSSP/uuid.pod
236 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/OSSP/uuid/.packlist
237 %endif
238
239 %if %{with php}
240 install -d $RPM_BUILD_ROOT{%{php_data_dir},%{php_sysconfdir}/conf.d}
241 %{__make} install \
242         -C php \
243         -f Makefile.local \
244         EXTDIR=%{php_extensiondir} \
245         DESTDIR=$RPM_BUILD_ROOT
246
247 mv $RPM_BUILD_ROOT{%{php_extensiondir},%{php_data_dir}}/uuid.php
248 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{name}.ini
249 ; Enable %{name} extension module
250 extension=%{name}.so
251 EOF
252 %endif
253
254 %clean
255 rm -rf $RPM_BUILD_ROOT
256
257 %post   -p /sbin/ldconfig
258 %postun -p /sbin/ldconfig
259
260 %post   c++ -p /sbin/ldconfig
261 %postun c++ -p /sbin/ldconfig
262
263 %post   dce -p /sbin/ldconfig
264 %postun dce -p /sbin/ldconfig
265
266 %files
267 %defattr(644,root,root,755)
268 %doc AUTHORS ChangeLog HISTORY NEWS PORTING README SEEALSO THANKS TODO USERS
269 %attr(755,root,root) %{_bindir}/uuid
270 %attr(755,root,root) /%{_lib}/libossp-uuid.so.*.*.*
271 %attr(755,root,root) %ghost /%{_lib}/libossp-uuid.so.16
272 %{_mandir}/man1/uuid.1*
273
274 %files devel
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_bindir}/uuid-config
277 %attr(755,root,root) %{_libdir}/libossp-uuid.so
278 %{_libdir}/libossp-uuid.la
279 %dir %{_includedir}/ossp-uuid
280 %{_includedir}/ossp-uuid/uuid.h
281 %{_pkgconfigdir}/ossp-uuid.pc
282 %{_mandir}/man1/uuid-config.1*
283 %{_mandir}/man3/ossp-uuid.3*
284
285 %if %{with static_libs}
286 %files static
287 %defattr(644,root,root,755)
288 %{_libdir}/libossp-uuid.a
289 %endif
290
291 %files c++
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{_libdir}/libossp-uuid++.so.*.*.*
294 %attr(755,root,root) %ghost %{_libdir}/libossp-uuid++.so.16
295
296 %files c++-devel
297 %defattr(644,root,root,755)
298 %attr(755,root,root) %{_libdir}/libossp-uuid++.so
299 %{_libdir}/libossp-uuid++.la
300 %{_includedir}/ossp-uuid/uuid++.hh
301 %{_mandir}/man3/uuid++.3*
302
303 %if %{with static_libs}
304 %files c++-static
305 %defattr(644,root,root,755)
306 %{_libdir}/libossp-uuid++.a
307 %endif
308
309 %files dce
310 %defattr(644,root,root,755)
311 %attr(755,root,root) %{_libdir}/libossp-uuid_dce.so.*.*.*
312 %attr(755,root,root) %ghost %{_libdir}/libossp-uuid_dce.so.16
313
314 %files dce-devel
315 %defattr(644,root,root,755)
316 %attr(755,root,root) %{_libdir}/libossp-uuid_dce.so
317 %{_libdir}/libossp-uuid_dce.la
318 %{_includedir}/ossp-uuid/uuid_dce.h
319
320 %if %{with static_libs}
321 %files dce-static
322 %defattr(644,root,root,755)
323 %{_libdir}/libossp-uuid_dce.a
324 %endif
325
326 %if %{with perl}
327 %files -n perl-uuid
328 %defattr(644,root,root,755)
329 %dir %{perl_vendorarch}/OSSP
330 %{perl_vendorarch}/OSSP/uuid.pm
331 %dir %{perl_vendorarch}/auto/OSSP
332 %dir %{perl_vendorarch}/auto/OSSP/uuid
333 %attr(755,root,root) %{perl_vendorarch}/auto/OSSP/uuid/uuid.so
334 %{_mandir}/man3/OSSP::uuid.3*
335 %endif
336
337 %if %{with php}
338 %files -n %{php_name}-uuid
339 %defattr(644,root,root,755)
340 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{name}.ini
341 %attr(755,root,root) %{php_extensiondir}/%{name}.so
342 %{php_data_dir}/uuid.php
343 %endif
344
345 %if %{with pgsql}
346 %files -n postgresql-uuid
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_libdir}/postgresql/ossp-uuid.so
349 %{_datadir}/postgresql/uuid.sql
350 %endif
This page took 0.093538 seconds and 3 git commands to generate.