]> git.pld-linux.org Git - packages/ortp.git/commitdiff
- updated to 4.4.0; license is GPL v3+ now auto/th/ortp-4.4.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 26 Sep 2020 12:11:23 +0000 (14:11 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 26 Sep 2020 12:11:23 +0000 (14:11 +0200)
- added am patch (update autotools support)

ortp-am.patch [new file with mode: 0644]
ortp.spec

diff --git a/ortp-am.patch b/ortp-am.patch
new file mode 100644 (file)
index 0000000..dd07dae
--- /dev/null
@@ -0,0 +1,45 @@
+--- ortp-4.4.0/Makefile.am.orig        2020-06-15 19:23:39.000000000 +0200
++++ ortp-4.4.0/Makefile.am     2020-09-26 10:24:22.830791471 +0200
+@@ -38,7 +38,7 @@
+ pkgdocdir=$(docdir)/$(PACKAGE)-$(VERSION)
+ doc_htmldir=$(pkgdocdir)/html
+-pkgdoc_DATA = README.md AUTHORS ChangeLog COPYING
++pkgdoc_DATA = README.md AUTHORS.md CHANGELOG.md LICENSE.txt
+ doc_html_DATA = $(top_builddir)/doc/html/html.tar
+ $(top_builddir)/doc/html/html.tar: $(top_builddir)/doc/html/index.html
+--- ortp-4.4.0/src/Makefile.am.orig    2020-06-15 19:23:39.000000000 +0200
++++ ortp-4.4.0/src/Makefile.am 2020-09-26 10:36:44.623439502 +0200
+@@ -44,6 +44,7 @@
+                       rtpsession_priv.h \
+                       rtpsignaltable.c  \
+                       rtptimer.c      rtptimer.h \
++                      rtpbundle.cc \
+                       scheduler.c scheduler.h \
+                       sessionset.c  \
+                       str_utils.c     \
+--- ortp-4.4.0/configure.ac.orig       2020-06-15 19:23:39.000000000 +0200
++++ ortp-4.4.0/configure.ac    2020-09-26 10:37:42.769791163 +0200
+@@ -47,6 +47,7 @@
+ dnl Checks for programs.
+ AC_PROG_CC
++AC_PROG_CXX
+ LT_INIT([win32-dll shared disable-static])
+ gl_LD_OUTPUT_DEF
+@@ -298,13 +299,6 @@
+ )
+ AM_CONDITIONAL(ENABLE_TESTS, test x$tests_enabled = xtrue)
+-case "$target_os" in
+-      *linux*)
+-              # Eliminate -lstdc++ addition to postdeps for cross compiles.
+-              postdeps_CXX=`echo " $postdeps_CXX " | sed 's, -lstdc++ ,,g'`
+-      ;;
+-esac
+-
+ dnl ##################################################
+ dnl # Check for doxygen
+ dnl ##################################################
index c705cd5a90766730dcc04bda2d3419efa71ca5c3..0db550bdd3ad3a5821415d69e2b1fd2fc7aeaa73 100644 (file)
--- a/ortp.spec
+++ b/ortp.spec
@@ -5,17 +5,20 @@
 Summary:       RTP/RTCP protocol library
 Summary(pl.UTF-8):     Biblioteka obsługująca protokół RTP/RTCP
 Name:          ortp
-Version:       1.0.2
+Version:       4.4.0
 Release:       1
-License:       LGPL v2.1+
+License:       GPL v3+
 Group:         Libraries
-Source0:       https://linphone.org/releases/sources/ortp/%{name}-%{version}.tar.gz
-# Source0-md5: 82629e99befa578341e0bdc225924135
-URL:           http://www.linphone.org/eng/documentation/dev/ortp.html
+#Source0Download: https://gitlab.linphone.org/BC/public/ortp/tags
+Source0:       https://gitlab.linphone.org/BC/public/ortp/-/archive/%{version}/%{name}-%{version}.tar.bz2
+# Source0-md5: 33df5f50a6ce40cc114c1393a30959b7
+Patch0:                %{name}-am.patch
+URL:           http://www.linphone.org/technical-corner/ortp
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: bctoolbox-devel
 BuildRequires: doxygen
+BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:2.0
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
@@ -34,6 +37,7 @@ Summary:      Header files to develop applications using ortp
 Summary(pl.UTF-8):     Pliki nagłówkowe do tworzenia aplikacji używających ortp
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      libstdc++-devel
 Requires:      openssl-devel
 
 %description devel
@@ -58,7 +62,7 @@ Statyczna biblioteka ortp.
 Summary:       API documentation for ortp library
 Summary(pl.UTF-8):     Dokumentacja API biblioteki ortp
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
+%if "%{_rpmversion}" >= "4.6"
 BuildArch:     noarch
 %endif
 
@@ -69,7 +73,8 @@ API documentation for ortp library.
 Dokumentacja API biblioteki ortp.
 
 %prep
-%setup -q -n %{name}-%{version}-0
+%setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -96,6 +101,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libortp.la
+
 # packaged as %doc
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/ortp-1.0.1
 
@@ -107,14 +115,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README.md
+%doc AUTHORS.md CHANGELOG.md README.md
 %attr(755,root,root) %{_libdir}/libortp.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libortp.so.13
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libortp.so
-%{_libdir}/libortp.la
 %{_includedir}/ortp
 %{_pkgconfigdir}/ortp.pc
 
This page took 0.122732 seconds and 4 git commands to generate.