]> git.pld-linux.org Git - packages/ortp.git/commitdiff
- updated to 0.18.0 auto/th/ortp-0_18_0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 3 Jan 2012 17:58:30 +0000 (17:58 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete Werror patch
- build with srtp and zrtp support by default

Changed files:
    ortp-Werror.patch -> 1.3
    ortp.spec -> 1.25

ortp-Werror.patch [deleted file]
ortp.spec

diff --git a/ortp-Werror.patch b/ortp-Werror.patch
deleted file mode 100644 (file)
index 4e17c01..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
---- ortp-0.15.0/src/stun.c~    2009-05-03 14:51:36.000000000 +0200
-+++ ortp-0.15.0/src/stun.c     2009-05-03 14:56:07.000000000 +0200
-@@ -1109,6 +1109,7 @@
-       fd_set fdSet;
-       int maxFd=0;
-       struct timeval tv;
-+      size_t got;
-       int e;
-         int fd=open("/dev/random",O_RDONLY);
-@@ -1132,8 +1133,15 @@
-            closesocket(fd);
-          return random();
-       }
--      read(fd,&tick,sizeof(tick));
-+      got = read(fd,&tick,sizeof(tick));
-       closesocket(fd);
-+
-+      if (got != sizeof(tick))
-+      {
-+          ortp_message("stun: Failed to get data from random device\n");
-+          return random();
-+      }
-+
-       }
- #else
- #     error Need some way to seed the random number generator 
-
-
index 6ef90ed0b98dd3f49b4a3725fb5b5aa755a2a318..70cfebb5bbf3edefefa8ba830961a1a4e52ce3f7 100644 (file)
--- a/ortp.spec
+++ b/ortp.spec
@@ -1,39 +1,48 @@
+#
+# Conditional build:
+%bcond_without zrtp    # ZRTP (RFC 6189: Media Path Key Agreement for Unicast Secure RTP) support; GPL v3
+#
 Summary:       RTP/RTCP protocol library
 Summary(pl.UTF-8):     Biblioteka obsługująca protokół RTP/RTCP
 Name:          ortp
-Version:       0.16.5
+Version:       0.18.0
 Release:       1
+%if %{with zrtp}
+License:       GPL v3+
+%else
 License:       LGPL v2.1+
+%endif
 Group:         Libraries
 Source0:       http://download.savannah.nongnu.org/releases/linphone/ortp/sources/%{name}-%{version}.tar.gz
-# Source0-md5: 94546901d14b85f97342f4ecf39489b1
+# Source0-md5: 098e984f9325d9e2648bfd9863eed501
 Patch0:                %{name}-i486.patch
-Patch1:                %{name}-Werror.patch
-Patch2:                %{name}-libssl-not-required.patch
-URL:           http://www.linphone.org/index.php/eng/code_review/ortp
+Patch1:                %{name}-libssl-not-required.patch
+URL:           http://www.linphone.org/eng/documentation/dev/ortp.html
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: doxygen
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2.0
+%{?with_zrtp:BuildRequires:    libzrtpcpp-devel >= 2.0.0}
 BuildRequires: openssl-devel
+BuildRequires: srtp-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags       -fno-strict-aliasing
 
 %description
-ortp is a library for handling RTP/RTCP packets. (See RFC 1889 and
-1890 for more information about the protocol)
+ortp is a library for handling RTP protocol (RFC 3550).
 
 %description -l pl.UTF-8
-ortp to biblioteka obsługująca pakiety RTP/RTCP. Więcej informacji o
-protokole znajduje się w RFC 1889 i 1890.
+ortp to biblioteka obsługująca protokół RTP (RFC 3550).
 
 %package devel
 Summary:       Header files to develop applications using ortp
 Summary(pl.UTF-8):     Pliki nagłówkowe do tworzenia aplikacji używających ortp
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+%{?with_zrtp:Requires: libzrtpcpp-devel >= 2.0.0}
 Requires:      openssl-devel
+Requires:      srtp-devel
 
 %description devel
 Header files for the ortp library.
@@ -57,21 +66,25 @@ Statyczna biblioteka ortp.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 %configure \
+       --disable-silent-rules \
+       --disable-strict \
+       --enable-ipv6 \
 %if "%{_lib}" == "lib64"
        --enable-mode64bit=yes \
 %else
        --enable-mode64bit=no \
 %endif
-       --enable-ipv6 \
-       --disable-strict
+       --enable-static \
+       %{?with_zrtp:--enable-zrtp}
+
 %{__make}
 
 %install
@@ -80,6 +93,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/ortp
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -88,12 +103,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README NEWS AUTHORS ChangeLog doc/html
+%doc AUTHORS ChangeLog NEWS README TODO
 %attr(755,root,root) %{_libdir}/libortp.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libortp.so.8
 
 %files devel
 %defattr(644,root,root,755)
+%doc doc/html/*
 %attr(755,root,root) %{_libdir}/libortp.so
 %{_libdir}/libortp.la
 %{_includedir}/ortp
This page took 0.104243 seconds and 4 git commands to generate.