]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
update for discarded shared/static bcond, cosmetics
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version
5 #
6 # NOTE: to avoid creating unreadable/unmaintainable spec:
7 # - don't put static version here, create STATIC branch for that for example
8 # - don't create useless bconds that for example limit SourceX: to current arch only
9 #
10
11 %define         ver     9.50
12 %define         shver   %(echo %{ver} | tr -d .)
13 %define         buildid 2042
14
15 Summary:        World fastest web browser
16 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
17 Name:           opera
18 Version:        %{ver}
19 Release:        3
20 Epoch:          2
21 License:        Distributable
22 Group:          X11/Applications/Networking
23 Source10:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/final/en/i386/shared/%{name}-%{version}.gcc4-shared-qt3.i386.tar.bz2
24 # Source10-md5: 34392767b4e1e233c682600d563d659f
25 Source11:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/final/en/x86_64/%{name}-%{version}.gcc4-shared-qt3.x86_64.tar.bz2
26 # Source11-md5: 091ed5b0f8a7541c7555744defca7a6c
27 Source12:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/final/en/ppc/shared/%{name}-%{version}.gcc4-shared-qt3.ppc.tar.bz2
28 # Source12-md5: c1b01ac1051c52a433514c3545bacac0
29 Source0:        %{name}.desktop
30 Patch0:         %{name}-wrapper.patch
31 URL:            http://www.opera.com/
32 BuildRequires:  rpmbuild(macros) >= 1.356
33 BuildRequires:  sed >= 4.0
34 Requires:       browser-plugins >= 2.0
35 Requires:       freetype >= 2
36 Provides:       wwwbrowser
37 Obsoletes:      opera-i18n
38 ExclusiveArch:  %{ix86} %{x8664} ppc
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _plugindir      %{_libdir}/opera/plugins
42 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
43
44 %description
45 Opera is world fastest web browser. It supports most of nowaday
46 extensions of HTML. And it is quite stable. This version is
47 linked with shared version of Qt.
48
49 %description -l pl.UTF-8
50 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
51 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
52 wersja jest skonsolidowana dynamicznie z Qt.
53
54 %package plugin32
55 Summary:        Opera 32-bit plugins support
56 Summary(pl.UTF-8):      Obsługa 32-bitowych wtyczek Opery
57 Group:          X11/Applications/Networking
58 Requires:       %{name} = %{epoch}:%{version}-%{release}
59
60 %description plugin32
61 Opera 32-bit plugins support.
62
63 %description plugin32 -l pl.UTF-8
64 Obsługa 32-bitowych wtyczek Opery.
65
66 %prep
67 %ifarch %{ix86}
68 %setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.gcc4-shared-qt3.i386
69 %endif
70 %ifarch %{x8664}
71 %setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.gcc4-shared-qt3.x86_64
72 %endif
73 %ifarch ppc
74 %setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.gcc4-shared-qt3.ppc
75 %endif
76 %patch0 -p1
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
81
82 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
83 # opera does not use for .xpt files
84 *.xpt
85
86 # use mplayerplug-in-opera instead
87 mplayerplug-in*
88
89 # opera uses libjava.so to run java
90 libjavaplugin_oji.so
91 EOF
92
93 sh install.sh \
94         DESTDIR=$RPM_BUILD_ROOT \
95         --prefix=%{_prefix} \
96         --exec_prefix=%{_libdir}/%{name}/bin \
97         --plugindir=%{_libdir}/%{name}/plugins \
98         --docdir=%{_operadocdir}
99
100 # install in kde etc.
101 install %{SOURCE0} $RPM_BUILD_ROOT%{_desktopdir}
102
103 install etc/* $RPM_BUILD_ROOT%{_sysconfdir}
104 install usr/share/pixmaps/*.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 %update_browser_plugins
111
112 %postun
113 if [ "$1" = 0 ]; then
114         %update_browser_plugins
115 fi
116
117 %files
118 %defattr(644,root,root,755)
119 %doc LICENSE
120 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*rc*
121
122 # browser plugins v2
123 %{_browserpluginsconfdir}/browsers.d/%{name}.*
124 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
125
126 %attr(755,root,root) %{_bindir}/*
127 %dir %{_libdir}/opera
128 %dir %{_libdir}/opera/bin
129 %attr(755,root,root) %{_libdir}/opera/bin/*
130 %ifarch %{x8664}
131 %exclude %{_libdir}/opera/bin/*-ia32-*
132 %endif
133 %dir %{_plugindir}
134 %dir %{_datadir}/opera
135 %{_datadir}/opera/*.*
136 %{_datadir}/opera/ini
137 %{_datadir}/opera/java
138 %{_datadir}/opera/skin
139 %{_datadir}/opera/styles
140 %dir %{_datadir}/opera/locale
141 %{_datadir}/opera/locale/en
142 %{_datadir}/opera/locale/english.lng
143 %lang(be) %{_datadir}/opera/locale/be
144 %lang(bg) %{_datadir}/opera/locale/bg
145 %lang(cs) %{_datadir}/opera/locale/cs
146 %lang(da) %{_datadir}/opera/locale/da
147 %lang(de) %{_datadir}/opera/locale/de
148 %lang(el) %{_datadir}/opera/locale/el
149 %lang(en_GB) %{_datadir}/opera/locale/en-GB
150 %lang(es_ES) %{_datadir}/opera/locale/es-ES
151 %lang(es_LA) %{_datadir}/opera/locale/es-LA
152 %lang(fi) %{_datadir}/opera/locale/fi
153 %lang(fr) %{_datadir}/opera/locale/fr
154 %lang(fr_CA) %{_datadir}/opera/locale/fr-CA
155 %lang(fy) %{_datadir}/opera/locale/fy
156 %lang(hi) %{_datadir}/opera/locale/hi
157 %lang(hr) %{_datadir}/opera/locale/hr
158 %lang(hu) %{_datadir}/opera/locale/hu
159 %lang(it) %{_datadir}/opera/locale/it
160 %lang(ja) %{_datadir}/opera/locale/ja
161 %lang(ka) %{_datadir}/opera/locale/ka
162 %lang(ko) %{_datadir}/opera/locale/ko
163 %lang(lt) %{_datadir}/opera/locale/lt
164 %lang(mk) %{_datadir}/opera/locale/mk
165 %lang(nb) %{_datadir}/opera/locale/nb
166 %lang(nl) %{_datadir}/opera/locale/nl
167 %lang(nn) %{_datadir}/opera/locale/nn
168 %lang(pl) %{_datadir}/opera/locale/pl
169 %lang(pt) %{_datadir}/opera/locale/pt
170 %lang(pt_BR) %{_datadir}/opera/locale/pt-BR
171 %lang(ru) %{_datadir}/opera/locale/ru
172 %lang(sv) %{_datadir}/opera/locale/sv
173 %lang(tr) %{_datadir}/opera/locale/tr
174 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
175 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
176 %{_desktopdir}/*.desktop
177 %{_mandir}/man1/opera.1*
178 %{_pixmapsdir}/opera.xpm
179
180 %ifarch %{x8664}
181 %files plugin32
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/opera/bin/*-ia32-*
184 %endif
This page took 0.077345 seconds and 4 git commands to generate.