]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- add missed R: desktop-file-utils for %%post(un).
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version
5 #
6 # NOTE: to avoid creating unreadable/unmaintainable spec:
7 # - don't put static version here, create STATIC branch for that for example
8 # - don't create useless bconds that for example limit SourceX: to current arch only
9 #
10
11 %define         ver     10.60
12 %define         shver   %(echo %{ver} | tr -d .)
13 %define         buildid 6386
14
15 Summary:        World fastest web browser
16 Summary(hu.UTF-8):      A világ leggyorsabb webböngészője
17 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
18 Name:           opera
19 Version:        %{ver}
20 Release:        3
21 Epoch:          2
22 License:        Distributable
23 Group:          X11/Applications/Networking
24 Source10:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.i386.linux.tar.bz2
25 # Source10-md5: e86d604b2f9397a618e8ecf357748f55
26 Source11:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.x86_64.linux.tar.bz2
27 # Source11-md5: 6415f21430bade3193d0d6c174e3bfb1
28 Source12:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{name}-%{version}-%{buildid}.ppc.linux.tar.bz2
29 # Source12-md5: 4cd09b64a0d1c3826b3e7038326c14dc
30 Source0:        %{name}.desktop
31 Patch0:         %{name}-wrapper.patch
32 Patch1:         %{name}-desktop.patch
33 Patch2:         %{name}-pluginpath.patch
34 URL:            http://www.opera.com/
35 BuildRequires:  rpm >= 4.4.9-56
36 BuildRequires:  rpmbuild(macros) >= 1.356
37 BuildRequires:  sed >= 4.0
38 Requires:       browser-plugins >= 2.0
39 Requires:       desktop-file-utils
40 Requires:       freetype >= 2
41 Provides:       wwwbrowser
42 Obsoletes:      opera-i18n
43 ExclusiveArch:  %{ix86} %{x8664} ppc
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _enable_debug_packages  0
47
48 %define         _plugindir      %{_libdir}/opera/plugins
49 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
50 # alternative arch for plugin32
51 %define         alt_arch        i386
52
53 %description
54 Opera is world fastest web browser. It supports most of nowaday
55 extensions of HTML. And it is quite stable. This version is linked
56 with shared version of Qt.
57
58 %description -l hu.UTF-8
59 Opera a világ leggyorsabb webböngészője. A manapság elterjedt
60 HTML-kiterjesztések túlnyomó többségét támogatja. És elég stabili is.
61 Ez a verzió a Qt megosztott verziójához linkelődik.
62
63 %description -l pl.UTF-8
64 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
65 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
66 wersja jest skonsolidowana dynamicznie z Qt.
67
68 %package plugin32
69 Summary:        Opera 32-bit plugins support
70 Summary(hu.UTF-8):      Opera 32-bites plugin támogatás
71 Summary(pl.UTF-8):      Obsługa 32-bitowych wtyczek Opery
72 Group:          X11/Applications/Networking
73 Requires:       %{name} = %{epoch}:%{version}-%{release}
74 Requires:       browser-plugins >= 2.0
75
76 %description plugin32
77 Opera 32-bit plugins support.
78
79 %description plugin32 -l hu.UTF-8
80 Opera 32-bites plugin támogatás.
81
82 %description plugin32 -l pl.UTF-8
83 Obsługa 32-bitowych wtyczek Opery.
84
85 %prep
86 %ifarch %{ix86}
87 %setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.i386.linux
88 %endif
89
90 %ifarch %{x8664}
91 %setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.x86_64.linux
92 %endif
93
94 %ifarch ppc
95 %setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.ppc.linux
96 %endif
97
98 sed -i -e '
99         s,@@{PREFIX},%{_prefix},g
100         s,@@{SUFFIX},,
101         s,@@{_SUFFIX},,
102 ' share/{applications/*.desktop,mime/packages/*.xml}
103
104 sed -i -e 's,kfmclient exec,xdg-open,' share/opera/defaults/filehandler.ini
105
106 %patch0 -p1
107 %patch1 -p1
108
109 # remove lib32/lib64 paths so patch2 can apply (i386 build contained lib64 as well, oh well)
110 %{__sed} -i -e '/lib32\|lib64/d;$d' share/opera/defaults/pluginpath.ini
111 %patch2 -p1
112
113 mv lib/opera/plugins/README README.plugins
114 mv share/opera/defaults/license.txt .
115 mv share/doc/opera/* .
116
117 # nobody wants scalable huge icons
118 rm -rf share/icons/hicolor/scalable
119
120 # opera packaging tools we don't need runtime
121 mv share/opera/package .
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir},%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
126
127 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
128 # opera does not use for .xpt files
129 *.xpt
130
131 # use mplayerplug-in-opera instead
132 mplayerplug-in*
133 EOF
134
135 install -p opera* $RPM_BUILD_ROOT%{_bindir}
136 cp -a lib/opera $RPM_BUILD_ROOT%{_libdir}
137 cp -a share/* $RPM_BUILD_ROOT%{_datadir}
138 #cp -a etc/*.ini $RPM_BUILD_ROOT%{_sysconfdir}
139
140 sed -i -e 's#/usr/lib/opera#%{_libdir}/opera#g' $RPM_BUILD_ROOT%{_bindir}/opera
141
142 cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/operaprefs_default.ini
143 [ISP]
144 Id="DISTRO"
145 EOF
146
147 %if "%{pld_release}" == "ti"
148 sed -i -e 's#DISTRO#PLD/Titanium#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
149 %else
150 %if "%{pld_release}" == "ac"
151 sed -i -e 's#DISTRO#PLD/2.0 (Ac)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
152 %else
153 sed -i -e 's#DISTRO#PLD/3.0 (Th)#g' $RPM_BUILD_ROOT/etc/operaprefs_default.ini
154 %endif
155 %endif
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post
161 %update_mime_database
162 %update_icon_cache hicolor
163 %update_desktop_database_post
164 %update_browser_plugins
165
166 %postun
167 %update_mime_database
168 %update_icon_cache hicolor
169 %update_desktop_database_postun
170 if [ "$1" = 0 ]; then
171         %update_browser_plugins
172 fi
173
174 %post plugin32
175 %update_browser_plugins
176
177 %postun plugin32
178 if [ "$1" = 0 ]; then
179         %update_browser_plugins
180 fi
181
182 %files
183 %defattr(644,root,root,755)
184 %doc LICENSE
185 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*ini
186
187 # browser plugins v2
188 %{_browserpluginsconfdir}/browsers.d/%{name}.*
189 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
190 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/operaprefs*.ini
191 %attr(755,root,root) %{_bindir}/opera
192 %attr(755,root,root) %{_bindir}/opera-widget-manager
193 %dir %{_libdir}/opera
194 %ifarch %{x8664}
195 %exclude %{_libdir}/opera/*-ia32-*
196 %endif
197 %attr(755,root,root) %{_libdir}/opera/*.so
198 %attr(755,root,root) %{_libdir}/opera/opera*
199 %dir %{_plugindir}
200 %dir %{_libdir}/opera/gstreamer
201 %dir %{_libdir}/opera/gstreamer/plugins
202 %attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperamatroska.so
203 %attr(755,root,root) %{_libdir}/opera/gstreamer/plugins/libgstoperavp8.so
204 %dir %{_datadir}/opera
205 %{_datadir}/opera/*.*
206 %{_datadir}/opera/defaults
207 %{_datadir}/opera/extra
208 %{_datadir}/opera/skin
209 %{_datadir}/opera/styles
210 %{_datadir}/opera/ui
211 %{_datadir}/opera/unite
212 %dir %{_datadir}/opera/locale
213 %{_datadir}/opera/locale/en
214 %lang(be) %{_datadir}/opera/locale/be
215 %lang(bg) %{_datadir}/opera/locale/bg
216 %lang(cs) %{_datadir}/opera/locale/cs
217 %lang(da) %{_datadir}/opera/locale/da
218 %lang(de) %{_datadir}/opera/locale/de
219 %lang(el) %{_datadir}/opera/locale/el
220 %lang(en_GB) %{_datadir}/opera/locale/en-GB
221 %lang(es_ES) %{_datadir}/opera/locale/es-ES
222 %lang(es_LA) %{_datadir}/opera/locale/es-LA
223 %lang(et) %{_datadir}/opera/locale/et
224 %lang(fi) %{_datadir}/opera/locale/fi
225 %lang(fr) %{_datadir}/opera/locale/fr
226 %lang(fr_CA) %{_datadir}/opera/locale/fr-CA
227 %lang(fy) %{_datadir}/opera/locale/fy
228 %lang(hi) %{_datadir}/opera/locale/hi
229 %lang(hr) %{_datadir}/opera/locale/hr
230 %lang(hu) %{_datadir}/opera/locale/hu
231 %lang(id) %{_datadir}/opera/locale/id
232 %lang(it) %{_datadir}/opera/locale/it
233 %lang(ja) %{_datadir}/opera/locale/ja
234 %lang(ka) %{_datadir}/opera/locale/ka
235 %lang(ko) %{_datadir}/opera/locale/ko
236 %lang(lt) %{_datadir}/opera/locale/lt
237 %lang(mk) %{_datadir}/opera/locale/mk
238 %lang(nb) %{_datadir}/opera/locale/nb
239 %lang(nl) %{_datadir}/opera/locale/nl
240 %lang(nn) %{_datadir}/opera/locale/nn
241 %lang(pl) %{_datadir}/opera/locale/pl
242 %lang(pt) %{_datadir}/opera/locale/pt
243 %lang(pt_BR) %{_datadir}/opera/locale/pt-BR
244 %lang(ro) %{_datadir}/opera/locale/ro
245 %lang(ru) %{_datadir}/opera/locale/ru
246 %lang(sk) %{_datadir}/opera/locale/sk
247 %lang(sr) %{_datadir}/opera/locale/sr
248 %lang(sv) %{_datadir}/opera/locale/sv
249 %lang(ta) %{_datadir}/opera/locale/ta
250 %lang(te) %{_datadir}/opera/locale/te
251 %lang(tr) %{_datadir}/opera/locale/tr
252 %lang(uk) %{_datadir}/opera/locale/uk
253 %lang(vi) %{_datadir}/opera/locale/vi
254 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
255 %lang(zh_HK) %{_datadir}/opera/locale/zh-hk
256 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
257 %{_datadir}/mime/packages/opera-widget.xml
258 %{_datadir}/mime/packages/opera-unite-application.xml
259 %{_desktopdir}/*.desktop
260 %{_mandir}/man1/opera.1*
261 %{_mandir}/man1/opera-widget-manager.1*
262 %{_iconsdir}/hicolor/*/*/*.png
263
264 %ifarch %{x8664}
265 %files plugin32
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_libdir}/opera/*-ia32-*
268 %endif
This page took 0.083449 seconds and 4 git commands to generate.