]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- up to 9.24; SECURITY
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version
5
6 # TODO:
7 # - move translations into a separate, noarch package
8 #
9 %bcond_without  shared          # static or shared version
10 %bcond_without  distributable   # distributable or not
11 %bcond_without  incall          # include all tarballs into src.rpm (but splitted into shared/static)
12
13 %define ver             9.24
14 %define sver            9.24
15 %define fix             %{nil}
16 %define dirrel          20071015
17 %define reltype         final
18 %define magicstr        671
19
20 %define shver           %(echo %{ver} | tr -d .)%{fix}
21 %define x86_shared_rel          %{dirrel}.5
22 %define x86_static_rel          %{dirrel}.1
23 %define sparc_shared_rel        %{dirrel}.2
24 %define sparc_static_rel        %{dirrel}.1
25 %define ppc_shared_rel          %{dirrel}.3
26 %define ppc_static_rel          %{dirrel}.1
27
28 %if %{with shared}
29 %define type            shared
30 # We should be able to build src.rpm also on not supported archs
31 %define rel             %{x86_shared_rel}
32 %ifarch sparc sparcv9
33 #%%define       rel             %{sparc_shared_rel}
34 %define rel             %{sparc_static_rel}
35 %else
36 %ifarch ppc
37 %define rel             %{ppc_shared_rel}
38 %endif
39 %endif
40 %else
41 %define type            static
42 %define rel             %{x86_static_rel}
43 %ifarch sparc sparcv9
44 %define rel             %{sparc_static_rel}
45 %else
46 %ifarch ppc
47 %define rel             %{ppc_static_rel}
48 %endif
49 %endif
50 %endif
51
52 # define to 0 and then redefine to avoid
53 # not defined macros
54 %define need_ix86_shared        0
55 %define need_sparc_shared       0
56 %define need_ppc_shared         0
57 %define need_ix86_static        0
58 %define need_sparc_static       0
59 %define need_ppc_static         0
60
61 %if %{with incall}
62 #       with incall?    [if]
63 %if %{with shared}
64 #                       with shared?    [if]
65 %define need_ix86_shared        1
66 #%%define       need_sparc_shared       1
67 %define need_sparc_static       1
68 %define need_ppc_shared 1
69 %else
70 #                       with shared:    [else]
71 %define need_ix86_static        1
72 %define need_sparc_static       1
73 %define need_ppc_static 1
74 %endif
75 #                       with shared;    [endif]
76 %else
77 #       with incall:    [else]
78 %ifarch %{ix86}
79 #               is ix86?        [if]
80 %else
81 #               is ix86:        [else]
82 %ifarch sparc sparc64
83 #               is sparc?       [if]
84 %if     %{with shared}
85 #                               with shared?    [if]
86 #%%define       need_sparc_shared       1
87 %define need_sparc_static       1
88 %else
89 #                               with shared:    [else]
90 %define need_sparc_static       1
91 %endif
92 #                               with shared;    [endif]
93 %else
94 #               is sparc:       [else]
95 %ifarch ppc
96 #               is ppc?         [if]
97 %if     %{with shared}
98 #                               with shared?    [if]
99 %define need_ppc_shared 1
100 %else
101 #                               with shared:    [else]
102 %define need_ppc_static 1
103 %endif
104 #                               with shared;    [endif]
105 %endif
106 #               is ppc;         [endif]
107 %endif
108 #               is sparc;       [endif]
109 %endif
110 #               is ix86;        [endif]
111 %endif
112 #       with incall;    [endif]
113
114 %define         _rel    1
115 Summary:        World fastest web browser
116 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
117 Name:           opera
118 Version:        %{ver}%{fix}
119 Release:        %{_rel}
120 Epoch:          2
121 License:        Distributable
122 Group:          X11/Applications/Networking
123
124 %if %{need_ix86_static}
125 Source0:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/static/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
126 # Source0-md5:  96b8010ddb0ff250817c7fb314de2d26
127 %{!?with_distributable:NoSource:        0}
128 %endif
129
130 %if %{need_sparc_static}
131 Source1:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
132 # Source1-md5:  c8443b4b83b21a56fdd8dc3526eaf46f
133 %{!?with_distributable:NoSource:        1}
134 %endif
135
136 %if %{need_ppc_static}
137 Source2:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/static/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
138 # Source2-md5:  be68f701224493bbd9a6d62df8eb9b19
139 %{!?with_distributable:NoSource:        2}
140 %endif
141
142 %if %{need_ix86_shared}
143 Source20:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
144 # Source20-md5: e7d934c0fe9ce0ef7cec67981b71332d
145 %{!?with_distributable:NoSource:        20}
146 %endif
147
148 %if %{need_sparc_shared}
149 Source21:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/shared/gcc-2.95/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
150 # Source21-md5: 883df8058672cf52678a07d714dcfce
151 %{!?with_distributable:NoSource:        21}
152 %endif
153
154
155 %if %{need_ppc_shared}
156 Source22:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/gcc-2.95/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
157 # Source22-md5: 07f97223ffcb2d2ab87c921ead880018
158 %{!?with_distributable:NoSource:        22}
159 %endif
160
161 Source4:        %{name}.desktop
162 Patch0:         %{name}-wrapper.patch
163 URL:            http://www.opera.com/
164 BuildRequires:  rpmbuild(macros) >= 1.356
165 BuildRequires:  sed >= 4.0
166 Requires:       browser-plugins >= 2.0
167 Requires:       freetype >= 2
168 Provides:       wwwbrowser
169 ExclusiveArch:  %{ix86} ppc sparc sparcv9
170 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
171
172 %define         _plugindir      %{_libdir}/opera/plugins
173 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
174
175 %description
176 Opera is world fastest web browser. It supports most of nowaday
177 extensions of HTML. And it is quite stable. This version is %{?with_shared:shared}%{!?with_shared:statically}
178 linked with Qt.
179
180 %description -l pl.UTF-8
181 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
182 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
183 wersja jest skonsolidowana %{?with_shared:dynamicznie}%{!?with_shared:statycznie} z Qt.
184
185 %prep
186 %ifarch %{ix86}
187 %setup -q -T -b %{?with_shared:2}0 -n %{name}-%{sver}-%{rel}-%{type}-qt.i386-en%{?magicstr:-%{magicstr}}
188 %endif
189 %ifarch sparc sparcv9
190 %setup -q -T -b %{?with_shared:2}1 -n %{name}-%{sver}-%{rel}-%{type}-qt.sparc-en-en%{?magicstr:-%{magicstr}}
191 %endif
192 %ifarch ppc
193 %setup -q -T -b %{?with_shared:2}2 -n %{name}-%{sver}-%{rel}-%{type}-qt.ppc-en%{?magicstr:-%{magicstr}}
194 %endif
195 %patch0 -p1
196
197 %install
198 rm -rf $RPM_BUILD_ROOT
199 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
200
201 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
202 # opera does not use for .xpt files
203 *.xpt
204
205 # use mplayerplug-in-opera instead
206 mplayerplug-in*
207
208 # opera uses libjava.so to run java
209 libjavaplugin_oji.so
210 EOF
211
212 sh install.sh \
213         DESTDIR=$RPM_BUILD_ROOT \
214         --prefix=%{_prefix} \
215         --exec_prefix=%{_libdir}/%{name}/bin \
216         --plugindir=%{_libdir}/%{name}/plugins \
217         --docdir=%{_operadocdir}
218
219 # install in kde etc.
220 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
221
222 mv -f $RPM_BUILD_ROOT%{_datadir}/%{name}/config/* $RPM_BUILD_ROOT%{_sysconfdir}
223 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
224
225 %clean
226 rm -rf $RPM_BUILD_ROOT
227
228 %post
229 %update_browser_plugins
230
231 %postun
232 if [ "$1" = 0 ]; then
233         %update_browser_plugins
234 fi
235
236 %files
237 %defattr(644,root,root,755)
238 %doc LICENSE
239 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*rc*
240
241 # browser plugins v2
242 %{_browserpluginsconfdir}/browsers.d/%{name}.*
243 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
244
245 %attr(755,root,root) %{_bindir}/*
246 %dir %{_libdir}/opera
247 %dir %{_libdir}/opera/bin
248 %attr(755,root,root) %{_libdir}/opera/bin/*
249 %dir %{_plugindir}
250 %attr(755,root,root) %{_plugindir}/*
251 %dir %{_datadir}/opera
252 %{_datadir}/opera/*.*
253 %{_datadir}/opera/ini
254 %{_datadir}/opera/java
255 %{_datadir}/opera/images
256 %{_datadir}/opera/skin
257 %{_datadir}/opera/styles
258 %dir %{_datadir}/opera/locale
259 %{_datadir}/opera/locale/en
260 %{_datadir}/opera/locale/english.lng
261 %{_desktopdir}/*.desktop
262 %{_mandir}/man1/opera.1*
263 %{_pixmapsdir}/opera.xpm
This page took 0.102182 seconds and 4 git commands to generate.