]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- simplify
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version
5
6 # TODO:
7 # - move translations into a separate, noarch package
8 #
9 %bcond_without  shared          # static or shared version
10 %bcond_without  distributable   # distributable or not
11 %bcond_without  incall          # include all tarballs into src.rpm (but splitted into shared/static)
12
13 %define ver             9.24
14 %define sver            9.24
15 %define fix             %{nil}
16 %define dirrel          20071015
17 %define reltype         final
18 %define magicstr        671
19
20 %define shver           %(echo %{ver} | tr -d .)%{fix}
21 %define x86_shared_rel          %{dirrel}.5
22 %define x86_static_rel          %{dirrel}.1
23 %define sparc_shared_rel        %{dirrel}.2
24 %define sparc_static_rel        %{dirrel}.1
25 %define ppc_shared_rel          %{dirrel}.3
26 %define ppc_static_rel          %{dirrel}.1
27
28 %if %{with shared}
29         %define type            shared
30         # We should be able to build src.rpm also on not supported archs
31         %define rel             %{x86_shared_rel}
32         %ifarch sparc sparcv9
33                 %define rel             %{sparc_shared_rel}
34         %else
35                 %ifarch ppc
36                 %define rel             %{ppc_shared_rel}
37                 %endif
38         %endif
39 %else
40         %define type            static
41         %define rel             %{x86_static_rel}
42         %ifarch sparc sparcv9
43                 %define rel             %{sparc_static_rel}
44         %else
45                 %ifarch ppc
46                         %define rel             %{ppc_static_rel}
47                 %endif
48         %endif
49 %endif
50
51 # define to 0 and then redefine to avoid
52 # not defined macros
53 %define need_ix86_shared        0
54 %define need_sparc_shared       0
55 %define need_ppc_shared         0
56 %define need_ix86_static        0
57 %define need_sparc_static       0
58 %define need_ppc_static         0
59
60 %if %{with incall}
61         %if %{with shared}
62                 %define need_ix86_shared        1
63                 %define need_sparc_shared       1
64                 %define need_ppc_shared 1
65         %else
66                 %define need_ix86_static        1
67                 %define need_sparc_static       1
68                 %define need_ppc_static 1
69         %endif
70 %else
71         %ifarch sparc sparc64
72                 %if     %{with shared}
73                         %define need_sparc_shared       1
74                 %else
75                         %define need_sparc_static       1
76                 %endif
77         %endif
78         %ifarch ppc
79                 %if     %{with shared}
80                         %define need_ppc_shared 1
81                 %else
82                         %define need_ppc_static 1
83                 %endif
84         %endif
85 %endif
86
87 %define         _rel    2
88 Summary:        World fastest web browser
89 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
90 Name:           opera
91 Version:        %{ver}%{fix}
92 Release:        %{_rel}
93 Epoch:          2
94 License:        Distributable
95 Group:          X11/Applications/Networking
96
97 %if %{need_ix86_static}
98 Source0:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/static/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
99 # Source0-md5:  96b8010ddb0ff250817c7fb314de2d26
100 %{!?with_distributable:NoSource:        0}
101 %endif
102
103 %if %{need_sparc_static}
104 Source1:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
105 # Source1-md5:  c8443b4b83b21a56fdd8dc3526eaf46f
106 %{!?with_distributable:NoSource:        1}
107 %endif
108
109 %if %{need_ppc_static}
110 Source2:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/static/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
111 # Source2-md5:  be68f701224493bbd9a6d62df8eb9b19
112 %{!?with_distributable:NoSource:        2}
113 %endif
114
115 %if %{need_ix86_shared}
116 Source20:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
117 # Source20-md5: e7d934c0fe9ce0ef7cec67981b71332d
118 %{!?with_distributable:NoSource:        20}
119 %endif
120
121 %if %{need_sparc_shared}
122 Source21:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/shared/gcc-2.95/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
123 # Source21-md5: 84df0097ac9c52e95bc74e73407386ee
124 %{!?with_distributable:NoSource:        21}
125 %endif
126
127
128 %if %{need_ppc_shared}
129 Source22:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/gcc-2.95/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
130 # Source22-md5: 07f97223ffcb2d2ab87c921ead880018
131 %{!?with_distributable:NoSource:        22}
132 %endif
133
134 Source4:        %{name}.desktop
135 Patch0:         %{name}-wrapper.patch
136 URL:            http://www.opera.com/
137 BuildRequires:  rpmbuild(macros) >= 1.356
138 BuildRequires:  sed >= 4.0
139 Requires:       browser-plugins >= 2.0
140 Requires:       freetype >= 2
141 Provides:       wwwbrowser
142 ExclusiveArch:  %{ix86} ppc sparc sparcv9
143 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
144
145 %define         _plugindir      %{_libdir}/opera/plugins
146 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
147
148 %description
149 Opera is world fastest web browser. It supports most of nowaday
150 extensions of HTML. And it is quite stable. This version is %{?with_shared:shared}%{!?with_shared:statically}
151 linked with Qt.
152
153 %description -l pl.UTF-8
154 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
155 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
156 wersja jest skonsolidowana %{?with_shared:dynamicznie}%{!?with_shared:statycznie} z Qt.
157
158 %prep
159 %ifarch %{ix86}
160 %setup -q -T -b %{?with_shared:2}0 -n %{name}-%{sver}-%{rel}-%{type}-qt.i386-en%{?magicstr:-%{magicstr}}
161 %endif
162 %ifarch sparc sparcv9
163 %setup -q -T -b %{?with_shared:2}1 -n %{name}-%{sver}-%{rel}-%{type}-qt.sparc-en-%{?magicstr:-%{magicstr}}
164 %endif
165 %ifarch ppc
166 %setup -q -T -b %{?with_shared:2}2 -n %{name}-%{sver}-%{rel}-%{type}-qt.ppc-en%{?magicstr:-%{magicstr}}
167 %endif
168 %patch0 -p1
169
170 %install
171 rm -rf $RPM_BUILD_ROOT
172 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
173
174 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
175 # opera does not use for .xpt files
176 *.xpt
177
178 # use mplayerplug-in-opera instead
179 mplayerplug-in*
180
181 # opera uses libjava.so to run java
182 libjavaplugin_oji.so
183 EOF
184
185 sh install.sh \
186         DESTDIR=$RPM_BUILD_ROOT \
187         --prefix=%{_prefix} \
188         --exec_prefix=%{_libdir}/%{name}/bin \
189         --plugindir=%{_libdir}/%{name}/plugins \
190         --docdir=%{_operadocdir}
191
192 # install in kde etc.
193 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
194
195 mv -f $RPM_BUILD_ROOT%{_datadir}/%{name}/config/* $RPM_BUILD_ROOT%{_sysconfdir}
196 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %post
202 %update_browser_plugins
203
204 %postun
205 if [ "$1" = 0 ]; then
206         %update_browser_plugins
207 fi
208
209 %files
210 %defattr(644,root,root,755)
211 %doc LICENSE
212 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*rc*
213
214 # browser plugins v2
215 %{_browserpluginsconfdir}/browsers.d/%{name}.*
216 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
217
218 %attr(755,root,root) %{_bindir}/*
219 %dir %{_libdir}/opera
220 %dir %{_libdir}/opera/bin
221 %attr(755,root,root) %{_libdir}/opera/bin/*
222 %dir %{_plugindir}
223 %attr(755,root,root) %{_plugindir}/*
224 %dir %{_datadir}/opera
225 %{_datadir}/opera/*.*
226 %{_datadir}/opera/ini
227 %{_datadir}/opera/java
228 %{_datadir}/opera/images
229 %{_datadir}/opera/skin
230 %{_datadir}/opera/styles
231 %dir %{_datadir}/opera/locale
232 %{_datadir}/opera/locale/en
233 %{_datadir}/opera/locale/english.lng
234 %{_desktopdir}/*.desktop
235 %{_mandir}/man1/opera.1*
236 %{_pixmapsdir}/opera.xpm
This page took 0.054678 seconds and 4 git commands to generate.