]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- rel 2; 32bit plugins support subpackage for x86_64
[packages/opera.git] / opera.spec
1 # BRANCHES:
2 # - HEAD - stable version
3 # - DEVEL - development version
4 # - WEEKLY - weekly development version
5 #
6 # NOTE, to avoid creating unreadable/unmaintainable spec:
7 # - don't put static version here, create STATIC branch for that for example
8 # - don't create useless bconds that for example limit SourceX: to current arch only
9 #
10 #
11 %define ver     9.50
12 %define shver   %(echo %{ver} | tr -d .)
13 %define buildid 2042
14 #
15 Summary:        World fastest web browser
16 Summary(pl.UTF-8):      Najszybsza przeglądarka WWW na świecie
17 Name:           opera
18 Version:        %{ver}
19 Release:        2
20 Epoch:          2
21 License:        Distributable
22 Group:          X11/Applications/Networking
23 Source10:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/final/en/i386/shared/%{name}-%{version}.gcc4-shared-qt3.i386.tar.bz2
24 # Source10-md5: 34392767b4e1e233c682600d563d659f
25 Source11:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/final/en/x86_64/%{name}-%{version}.gcc4-shared-qt3.x86_64.tar.bz2
26 # Source11-md5: 091ed5b0f8a7541c7555744defca7a6c
27 Source12:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/final/en/ppc/shared/%{name}-%{version}.gcc4-shared-qt3.ppc.tar.bz2
28 # Source12-md5: c1b01ac1051c52a433514c3545bacac0
29
30 Source4:        %{name}.desktop
31 Patch0:         %{name}-wrapper.patch
32 URL:            http://www.opera.com/
33 BuildRequires:  rpmbuild(macros) >= 1.356
34 BuildRequires:  sed >= 4.0
35 Requires:       browser-plugins >= 2.0
36 Requires:       freetype >= 2
37 Provides:       wwwbrowser
38 Obsoletes:      opera-i18n
39 ExclusiveArch:  %{ix86} %{x8664} ppc
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _plugindir      %{_libdir}/opera/plugins
43 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
44
45 %description
46 Opera is world fastest web browser. It supports most of nowaday
47 extensions of HTML. And it is quite stable. This version is
48 %{?with_shared:shared}%{!?with_shared:statically} linked with Qt.
49
50 %description -l pl.UTF-8
51 Opera jest najszybszą przeglądarką WWW na świecie. Obsługuje większość
52 dzisiejszych rozszerzeń HTML-a. Dodatkowo jest w miarę stabilna. Ta
53 wersja jest skonsolidowana
54 %{?with_shared:dynamicznie}%{!?with_shared:statycznie} z Qt.
55
56 %package plugin32
57 Summary:        Opera 32-bit plugins support
58 Summary(pl.UTF-8):      Obsługa 32-bitowych wtyczek Opery
59 Group:          X11/Applications/Networking
60 Requires:       %{name} = %{epoch}:%{version}-%{release}
61
62 %description plugin32
63 Opera 32-bit plugins support.
64
65 %description plugin32 -l pl.UTF-8
66 Obsługa 32-bitowych wtyczek Opery.
67
68 %prep
69 %ifarch %{ix86}
70 %setup -q -T -b 10 -n %{name}-%{version}-%{buildid}.gcc4-shared-qt3.i386
71 %endif
72 %ifarch %{x8664}
73 %setup -q -T -b 11 -n %{name}-%{version}-%{buildid}.gcc4-shared-qt3.x86_64
74 %endif
75 %ifarch ppc
76 %setup -q -T -b 12 -n %{name}-%{version}-%{buildid}.gcc4-shared-qt3.ppc
77 %endif
78 %patch0 -p1
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
83
84 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
85 # opera does not use for .xpt files
86 *.xpt
87
88 # use mplayerplug-in-opera instead
89 mplayerplug-in*
90
91 # opera uses libjava.so to run java
92 libjavaplugin_oji.so
93 EOF
94
95 sh install.sh \
96         DESTDIR=$RPM_BUILD_ROOT \
97         --prefix=%{_prefix} \
98         --exec_prefix=%{_libdir}/%{name}/bin \
99         --plugindir=%{_libdir}/%{name}/plugins \
100         --docdir=%{_operadocdir}
101
102 # install in kde etc.
103 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
104
105 install etc/* $RPM_BUILD_ROOT%{_sysconfdir}
106 install usr/share/pixmaps/*.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %update_browser_plugins
113
114 %postun
115 if [ "$1" = 0 ]; then
116         %update_browser_plugins
117 fi
118
119 %files
120 %defattr(644,root,root,755)
121 %doc LICENSE
122 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*rc*
123
124 # browser plugins v2
125 %{_browserpluginsconfdir}/browsers.d/%{name}.*
126 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
127
128 %attr(755,root,root) %{_bindir}/*
129 %dir %{_libdir}/opera
130 %dir %{_libdir}/opera/bin
131 %attr(755,root,root) %{_libdir}/opera/bin/*
132 %ifarch %{x8664}
133 %exclude %{_libdir}/opera/bin/*-ia32-*
134 %endif
135 %dir %{_plugindir}
136 %dir %{_datadir}/opera
137 %{_datadir}/opera/*.*
138 %{_datadir}/opera/ini
139 %{_datadir}/opera/java
140 %{_datadir}/opera/skin
141 %{_datadir}/opera/styles
142 %dir %{_datadir}/opera/locale
143 %{_datadir}/opera/locale/en
144 %{_datadir}/opera/locale/english.lng
145 %lang(be) %{_datadir}/opera/locale/be
146 %lang(bg) %{_datadir}/opera/locale/bg
147 %lang(cs) %{_datadir}/opera/locale/cs
148 %lang(da) %{_datadir}/opera/locale/da
149 %lang(de) %{_datadir}/opera/locale/de
150 %lang(el) %{_datadir}/opera/locale/el
151 %lang(en_GB) %{_datadir}/opera/locale/en-GB
152 %lang(es_ES) %{_datadir}/opera/locale/es-ES
153 %lang(es_LA) %{_datadir}/opera/locale/es-LA
154 %lang(fi) %{_datadir}/opera/locale/fi
155 %lang(fr) %{_datadir}/opera/locale/fr
156 %lang(fr_CA) %{_datadir}/opera/locale/fr-CA
157 %lang(fy) %{_datadir}/opera/locale/fy
158 %lang(hi) %{_datadir}/opera/locale/hi
159 %lang(hr) %{_datadir}/opera/locale/hr
160 %lang(hu) %{_datadir}/opera/locale/hu
161 %lang(it) %{_datadir}/opera/locale/it
162 %lang(ja) %{_datadir}/opera/locale/ja
163 %lang(ka) %{_datadir}/opera/locale/ka
164 %lang(ko) %{_datadir}/opera/locale/ko
165 %lang(lt) %{_datadir}/opera/locale/lt
166 %lang(mk) %{_datadir}/opera/locale/mk
167 %lang(nb) %{_datadir}/opera/locale/nb
168 %lang(nl) %{_datadir}/opera/locale/nl
169 %lang(nn) %{_datadir}/opera/locale/nn
170 %lang(pl) %{_datadir}/opera/locale/pl
171 %lang(pt) %{_datadir}/opera/locale/pt
172 %lang(pt_BR) %{_datadir}/opera/locale/pt-BR
173 %lang(ru) %{_datadir}/opera/locale/ru
174 %lang(sv) %{_datadir}/opera/locale/sv
175 %lang(tr) %{_datadir}/opera/locale/tr
176 %lang(zh_CN) %{_datadir}/opera/locale/zh-cn
177 %lang(zh_TW) %{_datadir}/opera/locale/zh-tw
178 %{_desktopdir}/*.desktop
179 %{_mandir}/man1/opera.1*
180 %{_pixmapsdir}/opera.xpm
181
182 %ifarch %{x8664}
183 %files plugin32
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/opera/bin/*-ia32-*
186 %endif
This page took 0.163126 seconds and 4 git commands to generate.