]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
e2b25af95237c8c71ebaeeec225aa69249c4932f
[packages/opera.git] / opera.spec
1 #
2 # There're some problems with "shared" version
3 #
4 %define ver     7.21
5 %define rel     20031009.1
6 %define dirrel  20031009
7 %define type    static
8 Summary:        World fastest web browser
9 Summary(pl):    Najszybsza przegl±darka WWW na ¶wiecie
10 Name:           opera
11 Version:        %{ver}.%{rel}
12 Release:        1
13 License:        Restricted, see file LICENSE
14 Group:          X11/Applications/Networking
15 #Source0:       http://snapshot.opera.com/unix/intel-linux/447-%{dirrel}-%{ver}-B5/opera-%{ver}-%{rel}-%{type}-qt.i386.tar.bz2
16 Source0:        http://snapshot.opera.com/unix/7.21-Preview-3/intel-linux/opera-%{ver}-%{rel}-%{type}-qt.i386.tar.bz2
17 #Source0:       ftp://ftp.opera.com/pub/opera/linux/711/final/en/i386/static/%{name}-%{ver}-%{rel}-%{type}-qt.i386.tar.bz2
18 #Source0:       ftp://ftp.opera.com/pub/opera/linux/720/beta7/en/i386/static/%{name}-%{ver}-%{rel}-%{type}-qt.i386.tar.bz2
19 %ifarch ppc
20 #Source1:       http://snapshot.opera.com/unix/ppc-linux/447-%{rel}-%{ver}-B5/opera-%{ver}-%{rel}-%{type}-qt.ppc.tar.bz2
21 Source1:        http://snapshot.opera.com/unix/7.21-Preview-3/ppc-linux/opera-%{ver}-%{rel}-%{type}-qt.ppc.tar.bz2
22 #Source1:       ftp://ftp.opera.com/pub/opera/linux/711/final/en/ppc/static/%{name}-%{ver}-%{rel}-%{type}-qt.ppc.tar.bz2
23 #Source0:       ftp://ftp.opera.com/pub/opera/linux/720/beta7/en/ppc/static/%{name}-%{ver}-%{rel}-%{type}-qt.ppc.tar.bz2
24 %endif
25 %ifarch sparc
26 #Source1:       http://snapshot.opera.com/unix/sparc-linux/447-%{rel}-%{ver}-B5/opera-%{ver}-%{rel}-%{type}-qt.sparc.tar.bz2
27 Source1:        http://snapshot.opera.com/unix/7.21-Preview-3/sparc-linux/opera-%{ver}-%{rel}-%{type}-qt.sparc.tar.bz2
28 #Source0:       ftp://ftp.opera.com/pub/opera/linux/720/beta7/en/sparc/static/%{name}-%{ver}-%{rel}-%{type}-qt.sparc.tar.bz2
29 %endif
30 # polish language file
31 Source2:        %{name}-2887.lng
32 Source3:        %{name}.desktop
33 NoSource:       0
34 URL:            http://www.opera.com/
35 ExclusiveArch:  %{ix86} ppc
36 Requires:       freetype >= 2
37 Requires:       openmotif >= 2
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _plugindir      %{_libdir}/opera/plugins
41 %define         _operadocdir    %{_docdir}/%{name}-%{ver}.%{rel}
42 %define         configfile      %{_datadir}/opera/config/opera6rc
43
44 %description
45 Opera is world fastest web browser. It supports most of nowaday
46 extensions of HTML. And it is quite stable. Only disadvantage are
47 advertisements on the top of its window. Version static linked with qt.
48
49 %description -l pl
50 Opera jest najszybsz± przegl±dark± WWW na ¶wiecie. Obs³uguje wiêkszo¶æ
51 dzisiejszych rozszerzeñ HTMLa. Dodatkowo jest w miarê stabilna. Jedyn±
52 niedogodno¶ci± s± reklamy ukazuj±ce siê w górze okna. Wersja statycznie
53 linkowana z qt.
54
55 %prep
56 %ifarch %{ix86}
57 %setup -q  -n %{name}-%{ver}-%{rel}-%{type}-qt.i386
58 %endif
59 %ifarch ppc
60 %setup -q -T -b 1 -n %{name}-%{ver}-%{rel}-%{type}-qt.ppc
61 %endif
62 %ifarch sparc
63 %setup -q -T -b 1 -n %{name}-%{ver}-%{rel}-%{type}-qt.sparc
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 cat install.sh | sed 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' > install2.sh
70 mv install2.sh install.sh
71
72 echo y |\
73 sh install.sh \
74   --prefix=$RPM_BUILD_ROOT%{_prefix} \
75   --wrapperdir=$RPM_BUILD_ROOT%{_bindir} \
76   --docdir=$RPM_BUILD_ROOT%{_operadocdir} \
77   --sharedir=$RPM_BUILD_ROOT%{_datadir}/opera \
78   --exec_prefix=$RPM_BUILD_ROOT%{_datadir}/opera/bin \
79   --plugindir=$RPM_BUILD_ROOT%{_plugindir}
80
81 # Polish locale
82 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/opera/locale/
83
84 # man install
85 install -d $RPM_BUILD_ROOT%{_mandir}/man1
86 install man/opera.1 $RPM_BUILD_ROOT%{_mandir}/man1
87
88 # wrapper correction
89 sed s#$RPM_BUILD_ROOT## > $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
90 mv $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
91
92 # install in kde etc.
93 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
94 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
95
96 install -d $RPM_BUILD_ROOT%{_applnkdir}/Network/WWW
97 install %{SOURCE3} $RPM_BUILD_ROOT%{_applnkdir}/Network/WWW
98
99 # symlink który niweluje burkanie siê opery :>
100 #ln -sf %{_datadir}/opera/ $RPM_BUILD_ROOT/usr/share/
101 #ln -sf %{_libdir}/opera $RPM_BUILD_ROOT/usr/lib/
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 %defattr(644,root,root,755)
108 %doc LICENSE bugreport help
109 %attr(755,root,root) %{_bindir}/*
110 %dir %{_datadir}/opera
111 %dir %{_datadir}/opera/bin
112 %attr(755,root,root) %{_datadir}/opera/bin/*
113 %{_datadir}/opera/config
114 %{_datadir}/opera/help
115 %{_datadir}/opera/images
116 %{_datadir}/opera/java
117 %{_datadir}/opera/locale
118 %{_datadir}/opera/skin
119 %{_datadir}/opera/styles
120 %{_datadir}/opera/ini
121 %{_datadir}/opera/search.ini
122 %{_datadir}/opera/*.html
123 %ifarch %{ix86}
124 %attr(755,root,root) %{_datadir}/opera/chartables.bin
125 %endif
126 %ifarch ppc
127 %attr(755,root,root) %{_datadir}/opera/chartables-be.bin
128 %endif
129 %attr(755,root,root) %{_datadir}/opera/opera6.adr
130 %dir %{_libdir}/opera
131 %dir %{_plugindir}
132 %attr(755,root,root) %{_plugindir}/*
133
134 %{_pixmapsdir}/opera.xpm
135 %{_applnkdir}/Network/WWW/*.desktop
136
137 %{_mandir}/man1/opera.1*
This page took 0.069295 seconds and 2 git commands to generate.