]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- SECURITY note
[packages/opera.git] / opera.spec
1 # TODO:
2 # - SECURITY: http://securitytracker.com/alerts/2004/Jul/1010780.html
3 #
4 %bcond_without  shared          # static or shared version
5 %bcond_without  distributable   # distributable or not
6 %bcond_without  incall          # include all tarballs into src.rpm (but splitted into shared/static)
7 %bcond_with     snap            # snap version
8
9 %define ver             7.54
10 %define shver           %(echo %{ver} | tr -d .)
11 %define dirrel          20040803
12 # type of release, usually final or beta or Preview-4 for snaps
13 %define reltype         final
14 %define x86_shared_rel          %{dirrel}.5
15 %define x86_static_rel          %{dirrel}.1
16 %define sparc_shared_rel        %{dirrel}.2
17 %define sparc_static_rel        %{dirrel}.1
18 %define ppc_shared_rel          %{dirrel}.2
19 %define ppc_static_rel          %{dirrel}.1
20 %if %{with shared}
21 %define type            shared
22 %ifarch %{ix86}
23 %define rel             %{x86_shared_rel}
24 %endif
25 %ifarch sparc64 sparc
26 %define rel             %{sparc_shared_rel}
27 %endif
28 %ifarch ppc
29 %define rel             %{ppc_shared_rel}
30 %endif
31 %else
32 %define type            static
33 %ifarch %{ix86}
34 %define rel             %{x86_static_rel}
35 %endif
36 %ifarch sparc sparc64
37 %define rel             %{sparc_static_rel}
38 %endif
39 %ifarch ppc
40 %define rel             %{ppc_static_rel}
41 %endif
42 %endif
43
44 Summary:        World fastest web browser
45 Summary(pl):    Najszybsza przegl±darka WWW na ¶wiecie
46 Name:           opera
47 Version:        %{ver}.%{rel}
48 Release:        1
49 License:        Distributable for PLD until 31 Dec 2006 - http://distribute.opera.com/ (otherwise restricted, see file LICENSE)
50 Group:          X11/Applications/Networking
51 %if %{without shared}
52 %{!?with_incall:%ifarch %{ix86}}
53 %if ! %{with snap}
54 Source0:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/static/%{name}-%{ver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
55 # Source0-md5:  0a7e933ef593d4b7a897041c9f87bba2
56 %else
57 Source100:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/intel-linux/en/%{name}-%{ver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
58 %endif
59 %{!?with_distributable:NoSource:        0}
60 %if ! %{with incall}
61 %endif
62 %ifarch sparc sparc64
63 %endif
64 %if ! %{with snap}
65 Source1:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{ver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
66 # Source1-md5:  04976a6ace7a4345ce5e4cf763159939
67 %else
68 Source101:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/sparc-linux/en/%{name}-%{ver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
69 %endif
70 %{!?with_distributable:NoSource:        1}
71 %if ! %{with incall}
72 %endif
73 %ifarch ppc
74 %endif
75 %if ! %{with snap}
76 Source2:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/static/%{name}-%{ver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
77 # Source2-md5:  c11a4c78d18bdaa4bd338b4c0dc27f38
78 %else
79 Source102:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/ppc-linux/en/%{name}-%{ver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
80 %endif
81 %{!?with_distributable:NoSource:        2}
82 %{!?with_incall:%endif}
83 %else
84 %{!?with_incall:%ifarch %{ix86}}
85 %if ! %{with snap}
86 Source20:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/%{name}-%{ver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
87 # Source20-md5: 0e407a050f3aa4559011a3cea707cd20
88 %else
89 Source1020:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/intel-linux/en/%{name}-%{ver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
90 %endif
91 %{!?with_distributable:NoSource:        20}
92 %if ! %{with incall}
93 %endif
94 %ifarch sparc sparc64
95 %endif
96 %if ! %{with snap}
97 Source21:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/shared/gcc-2.95/%{name}-%{ver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
98 # Source21-md5: d8635013dac0c98c680997fcc9dd66c4
99 %else
100 Source1021:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/sparc-linux/en/%{name}-%{ver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
101 %endif
102 %{!?with_distributable:NoSource:        21}
103 %if ! %{with incall}
104 %endif
105 %ifarch ppc
106 %endif
107 %if ! %{with snap}
108 Source22:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/gcc-2.95/%{name}-%{ver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
109 # Source22-md5: 516992e68c5a710d795a1ecc791c7f4d
110 %else
111 Source1022:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/ppc-linux/en/%{name}-%{ver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
112 %endif
113 %{!?with_distributable:NoSource:        22}
114 %endif
115 %{!?with_incall:%endif}
116 Source3:        ftp://ftp.opera.com/pub/opera/unix/lng/752/pl/ou752_727pl.lng
117 # Source3-md5:  48bfd8a0d541698c70e151c81ab61408
118 Source4:        %{name}.desktop
119 URL:            http://www.opera.com/
120 ExclusiveArch:  %{ix86} ppc sparc sparc64
121 Requires:       freetype >= 2
122 Requires:       openmotif >= 2
123 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125 %define         _plugindir      %{_libdir}/opera/plugins
126 %define         _operadocdir    %{_docdir}/%{name}-%{ver}.%{rel}
127 %define         configfile      %{_datadir}/opera/config/opera6rc
128
129 %description
130 Opera is world fastest web browser. It supports most of nowaday
131 extensions of HTML. And it is quite stable. Only disadvantage are
132 advertisements on the top of its window. Version static linked with
133 qt.
134
135 %description -l pl
136 Opera jest najszybsz± przegl±dark± WWW na ¶wiecie. Obs³uguje wiêkszo¶æ
137 dzisiejszych rozszerzeñ HTMLa. Dodatkowo jest w miarê stabilna. Jedyn±
138 niedogodno¶ci± s± reklamy ukazuj±ce siê w górze okna. Wersja
139 statycznie skonsolidowana z qt.
140
141 %prep
142 %ifarch %{ix86}
143 %setup -q %{?with_shared:-T -b %{?with_snap:10}20} -n %{name}-%{ver}-%{rel}-%{type}-qt.i386-en
144 %endif
145 %ifarch sparc sparc64
146 %setup -q -T -b %{?with_snap:10}%{?with_shared:2}1 -n %{name}-%{ver}-%{rel}-%{type}-qt.sparc-en
147 %endif
148 %ifarch ppc
149 %setup -q -T -b %{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{ver}-%{rel}-%{type}-qt.ppc-en
150 %endif
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154
155 install -d $RPM_BUILD_ROOT{/etc,%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
156
157 cat install.sh | sed 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' > install2.sh
158 mv install2.sh install.sh
159
160 echo y |\
161 sh install.sh \
162   --prefix=$RPM_BUILD_ROOT%{_prefix} \
163   --wrapperdir=$RPM_BUILD_ROOT%{_bindir} \
164   --docdir=$RPM_BUILD_ROOT%{_operadocdir} \
165   --sharedir=$RPM_BUILD_ROOT%{_datadir}/opera \
166   --exec_prefix=$RPM_BUILD_ROOT%{_datadir}/opera/bin \
167   --plugindir=$RPM_BUILD_ROOT%{_plugindir}
168
169 # Polish locale
170 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/opera/locale/polish.lng
171
172 # man install
173 install man/opera.1 $RPM_BUILD_ROOT%{_mandir}/man1
174
175 # wrapper correction
176 sed s#$RPM_BUILD_ROOT## > $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
177 mv $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
178
179 # install in kde etc.
180 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
181
182 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
183
184 # symlink który niweluje burkanie siê opery :>
185 #ln -sf %{_datadir}/opera/ $RPM_BUILD_ROOT/usr/share/
186 #ln -sf %{_libdir}/opera $RPM_BUILD_ROOT/usr/lib/
187
188 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_datadir}/opera/java/*.policy
189
190 # always use wrapper linked with libXm.so.3
191 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper
192 ln -sf operamotifwrapper-3 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-2
193 ln -sf operamotifwrapper-3 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/operamotifwrapper-1
194
195 # %{_libdir} is not the best place for it but opera doesn't search for it in better
196 # places :/
197 install lib/spellcheck.so $RPM_BUILD_ROOT%{_libdir}
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %files
203 %defattr(644,root,root,755)
204 %doc LICENSE bugreport help
205 %attr(755,root,root) %{_bindir}/*
206 %dir %{_datadir}/opera
207 %dir %{_datadir}/opera/bin
208 %attr(755,root,root) %{_datadir}/opera/bin/*
209 %{_datadir}/opera/config
210 %{_datadir}/opera/help
211 %{_datadir}/opera/images
212 %{_datadir}/opera/java
213 %{_datadir}/opera/locale
214 %{_datadir}/opera/skin
215 %{_datadir}/opera/styles
216 %{_datadir}/opera/ini
217 %{_datadir}/opera/search.ini
218 %{_datadir}/opera/*.html
219 %{_datadir}/opera/*.ssr
220 %{_datadir}/opera/*.txt
221 %ifarch %{ix86}
222 %attr(755,root,root) %{_datadir}/opera/chartables.bin
223 %endif
224 %ifarch ppc
225 %attr(755,root,root) %{_datadir}/opera/chartables-be.bin
226 %endif
227 %attr(755,root,root) %{_datadir}/opera/opera6.adr
228 %attr(755,root,root) %{_libdir}/*.so
229 %dir %{_libdir}/opera
230 %dir %{_plugindir}
231 %attr(755,root,root) %{_plugindir}/*
232
233 %{_pixmapsdir}/opera.xpm
234 %{_desktopdir}/*.desktop
235
236 %{_mandir}/man1/opera.1*
This page took 0.055853 seconds and 3 git commands to generate.