]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- typo
[packages/opera.git] / opera.spec
1 # TODO:
2 # - move translations into a separate, noarch package
3 #
4 %bcond_without  shared          # static or shared version
5 %bcond_without  distributable   # distributable or not
6 %bcond_without  incall          # include all tarballs into src.rpm (but splitted into shared/static)
7 %bcond_with     snap            # snap version
8 %bcond_with     weekly          # weekly snapshot version
9
10 %ifarch sparc64 sparc
11 %undefine with_shared
12 %endif
13
14 %if %{with weekly}
15 %define ver             9.10
16 %define sver            %{ver}
17 %define fix             %{nil}
18 %define dirrel          20061214
19 %define magicstr        521
20 %define with_snap       1
21 %else
22 %if %{with snap}
23 %define ver             9.0
24 %define sver            %{ver}
25 %define fix             %{nil}
26 %define dirrel          20060206
27 %define reltype         Preview-2
28 %define magicstr        %{nil}
29 %else
30 %define ver             9.10
31 %define sver            9.10
32 %define fix             %{nil}
33 %define dirrel          20061214
34 %define reltype         final
35 %define magicstr        521
36 %endif
37 %endif
38
39 %define shver           %(echo %{ver} | tr -d .)%{fix}
40 %define x86_shared_rel          %{dirrel}.5
41 %define x86_static_rel          %{dirrel}.1
42 %define sparc_shared_rel        %{dirrel}.2
43 %define sparc_static_rel        %{dirrel}.1
44 %define ppc_shared_rel          %{dirrel}.3
45 %define ppc_static_rel          %{dirrel}.1
46 %if %{with shared}
47 %define type            shared
48 # We should be able to build src.rpm also on not supported archs
49 %define rel             %{x86_shared_rel}
50 %ifarch sparc64 sparc
51 #%%define       rel             %{sparc_shared_rel}
52 %define rel             %{sparc_static_rel}
53 %endif
54 %ifarch ppc
55 %define rel             %{ppc_shared_rel}
56 %endif
57 %else
58 %define type            static
59 %define rel             %{x86_static_rel}
60 %ifarch sparc sparc64
61 %define rel             %{sparc_static_rel}
62 %endif
63 %ifarch ppc
64 %define rel             %{ppc_static_rel}
65 %endif
66 %endif
67
68 # define to 0 and then redefine to avoid
69 # not defined macros
70 %define need_ix86_shared_snap   0
71 %define need_sparc_shared_snap  0
72 %define need_ppc_shared_snap    0
73 %define need_ix86_static_snap   0
74 %define need_sparc_static_snap  0
75 %define need_ppc_static_snap    0
76
77 %define need_ix86_shared        0
78 %define need_sparc_shared       0
79 %define need_ppc_shared         0
80 %define need_ix86_static        0
81 %define need_sparc_static       0
82 %define need_ppc_static         0
83
84 %if %{with incall}
85 #       with incall?    [if]
86 %if     %{with snap}
87 #               with snap?      [if]
88 %if     %{with shared}
89 #                       with shared?    [if]
90 %define need_ix86_shared_snap   1
91 %define need_sparc_shared_snap  0
92 %define need_ppc_shared_snap    1
93 %else
94 #                       with shared:    [else]
95 %define need_ix86_static_snap   1
96 %define need_sparc_static_snap  1
97 %define need_ppc_static_snap    1
98 %endif
99 #                       with shared;    [endif]
100 %else
101 #               with snap:      [else]
102 %if %{with shared}
103 #                       with shared?    [if]
104 %define need_ix86_shared        1
105 #%%define       need_sparc_shared       1
106 %define need_sparc_static       1
107 %define need_ppc_shared 1
108 %else
109 #                       with shared:    [else]
110 %define need_ix86_static        1
111 %define need_sparc_static       1
112 %define need_ppc_static 1
113 %endif
114 #                       with shared;    [endif]
115 %endif
116 #               with snap;      [endif]
117 %else
118 #       with incall:    [else]
119 %ifarch %{ix86}
120 #               is ix86?        [if]
121 %if     %{with snap}
122 #                       with snap?      [if]
123 %if     %{with shared}
124 #                               with shared?    [if]
125 %define need_ix86_shared_snap   1
126 %else
127 #                               with shared:    [else]
128 %define need_ix86_static_snap   1
129 %endif
130 #                               with shared;    [endif]
131 %else
132 #                       with snap:      [else]
133 %if     %{with shared}
134 #                               with shared?    [if]
135 %define need_ix86_shared        1
136 %else
137 #                               with shared:    [else]
138 %define need_ix86_static        1
139 %endif
140 #                               with shared;    [endif]
141 %endif
142 #                       with snap;      [endif]
143 %endif
144 #               is ix86;        [endif]
145 %ifarch sparc sparc64
146 #               is sparc?       [if]
147 %if     %{with snap}
148 #                       with snap?      [if]
149 %if     %{with shared}
150 #                               with shared?    [if]
151 %define need_sparc_shared_snap  1
152 %else
153 #                               with shared:    [else]
154 %define need_sparc_static_snap  1
155 %endif
156 #                               with shared;    [endif]
157 %else
158 #                       with snap:      [else]
159 %if     %{with shared}
160 #                               with shared?    [if]
161 #%%define       need_sparc_shared       1
162 %define need_sparc_static       1
163 %else
164 #                               with shared:    [else]
165 %define need_sparc_static       1
166 %endif
167 #                               with shared;    [endif]
168 %endif
169 #                       with snap;      [endif]
170 %endif
171 #               is sparc;       [endif]
172 %ifarch ppc
173 #               is ppc?         [if]
174 %if     %{with snap}
175 #                       with snap?      [if]
176 %if     %{with shared}
177 #                               with shared?    [if]
178 %define need_ppc_shared_snap    1
179 %else
180 #                               with shared:    [else]
181 %define need_ppc_static_snap    1
182 %endif
183 #                               with shared;    [endif]
184 %else
185 #                       with snap:      [else]
186 %if     %{with shared}
187 #                               with shared?    [if]
188 %define need_ppc_shared 1
189 %else
190 #                               with shared:    [else]
191 %define need_ppc_static 1
192 %endif
193 #                               with shared;    [endif
194 %endif
195 #                       with snap;      [endif
196 %endif
197 #               is ppc;         [endif]
198 %endif
199 #       with incall;    [endif]
200
201 %if %{with weekly}
202 %define need_ppc_shared_snap    0
203 %define need_ppc_static_snap    0
204 %define need_sparc_shared_snap  0
205 %define need_sparc_static_snap  0
206 %endif
207
208 %define         _rel    2
209 Summary:        World fastest web browser
210 Summary(pl):    Najszybsza przegl±darka WWW na ¶wiecie
211 Name:           opera
212 Version:        %{ver}%{fix}
213 Release:        %{?with_snap:1.%{rel}.}%{_rel}
214 Epoch:          2
215 License:        Distributable for PLD until 31 Dec 2006 - http://distribute.opera.com/ (otherwise restricted, see file LICENSE)
216 Group:          X11/Applications/Networking
217
218 %if %{need_ix86_static}
219 Source0:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/static/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en.tar.bz2
220 # Source0-md5:  dccdc5252ffc6658f3c46f32c64c8219
221 %{!?with_distributable:NoSource:        0}
222 %endif
223
224 %if %{need_ix86_static_snap}
225 %if %{with weekly}
226 Source30100:    http://snapshot.opera.com/unix/Weekly-%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en-%{magicstr}.tar.bz2
227 %else
228 Source100:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_static_rel}-static-qt.i386-en-%{magicstr}.tar.bz2
229 %endif
230 %{!?with_distributable:NoSource:        100}
231 %endif
232
233 %if %{need_sparc_static}
234 Source1:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/static/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
235 # Source1-md5:  e7bcbbaa48a63827d0efc60cf6fef68d
236 %{!?with_distributable:NoSource:        1}
237 %endif
238
239 %if %{need_sparc_static_snap}
240 Source101:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/sparc-linux/%{name}-%{sver}-%{sparc_static_rel}-static-qt.sparc-en.tar.bz2
241 # Source101-md5:        913ccb28106f9f5acd3d94c8dc71ae1
242 %{!?with_distributable:NoSource:        101}
243 %endif
244
245 %if %{need_ppc_static}
246 Source2:        ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/static/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
247 # Source2-md5:  d67428a09a036e786efc22e03150a344
248 %{!?with_distributable:NoSource:        2}
249 %endif
250
251 %if %{need_ppc_static_snap}
252 %if %{with weekly}
253 Source30102:    http://snapshot.opera.com/unix/Weekly-%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en-%{magicstr}.tar.bz2
254 %else
255 Source102:      http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_static_rel}-static-qt.ppc-en.tar.bz2
256 %endif
257 %{!?with_distributable:NoSource:        102}
258 %endif
259
260 %if %{need_ix86_shared}
261 Source20:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/i386/shared/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
262 # Source20-md5: a60b0abe55ca580952b30f4540632425
263 %{!?with_distributable:NoSource:        20}
264 %endif
265
266 %if %{need_ix86_shared_snap}
267 %if %{with weekly}
268 Source301020:   http://snapshot.opera.com/unix/Weekly-%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en-%{magicstr}.tar.bz2
269 # Source301020-md5:     a60b0abe55ca580952b30f4540632425
270 %else
271 Source1020:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/intel-linux/%{name}-%{sver}-%{x86_shared_rel}-shared-qt.i386-en.tar.bz2
272 # Source1020-md5:       6f296be6b9fc3001588d4509016062bd
273 %{!?with_distributable:NoSource:        1020}
274 %endif
275 %endif
276
277 %if %{need_sparc_shared}
278 Source21:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/sparc/shared/gcc-2.95/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
279 # Source21-md5: 883df8058672cf52678a07d714dcfce
280 %{!?with_distributable:NoSource:        21}
281 %endif
282
283 %if %{need_sparc_shared_snap}
284 Source1021:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/sparc-linux/%{name}-%{sver}-%{sparc_shared_rel}-shared-qt.sparc-en.tar.bz2
285 # Source1021-md5:       e190021f5530de3f711006cd9f6bb339
286 %{!?with_distributable:NoSource:        1021}
287 %endif
288
289 %if %{need_ppc_shared}
290 Source22:       ftp://ftp.opera.com/pub/opera/linux/%{shver}/%{reltype}/en/ppc/shared/gcc-2.95/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
291 # Source22-md5: 6ef04f12a39fdbe671dfbd6a37080a81
292 %{!?with_distributable:NoSource:        22}
293 %endif
294
295 %if %{need_ppc_shared_snap}
296 %if %{with weekly}
297 Source301022:   http://snapshot.opera.com/unix/Weekly-%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en-%{magicstr}.tar.bz2
298 # Source301022-md5:     65293d788e18d0c23cccac71b9fe567c
299 %else
300 Source1022:     http://snapshot.opera.com/unix/%{ver}-%{reltype}/%{magicstr}/ppc-linux/%{name}-%{sver}-%{ppc_shared_rel}-shared-qt.ppc-en.tar.bz2
301 # Source1022-md5:       74985fa6da49b2e54c9d03dab1119325
302 %{!?with_distributable:NoSource:        1022}
303 %endif
304 %endif
305
306 Source4:        %{name}.desktop
307 Patch0:         %{name}-wrapper.patch
308 URL:            http://www.opera.com/
309 BuildRequires:  sed >= 4.0
310 Requires:       freetype >= 2
311 Provides:       wwwbrowser
312 ExclusiveArch:  %{ix86} ppc sparc sparc64
313 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
314
315 %define         _plugindir      %{_libdir}/opera/plugins
316 %define         _operadocdir    %{_docdir}/%{name}-%{ver}
317
318 %description
319 Opera is world fastest web browser. It supports most of nowaday
320 extensions of HTML. And it is quite stable. This version is %{?with_shared:shared}%{!?with_shared:statically}
321 linked with Qt.
322
323 %description -l pl
324 Opera jest najszybsz± przegl±dark± WWW na ¶wiecie. Obs³uguje wiêkszo¶æ
325 dzisiejszych rozszerzeñ HTML-a. Dodatkowo jest w miarê stabilna. Ta
326 wersja jest skonsolidowana %{?with_shared:dynamicznie}%{!?with_shared:statycznie} z Qt.
327
328 %prep
329 %ifarch %{ix86}
330 %setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}0 -n %{name}-%{sver}-%{rel}-%{type}-qt.i386-en%{?magicstr:-%{magicstr}}
331 %endif
332 %ifarch sparc sparc64
333 %setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}1 -n %{name}-%{sver}-%{rel}-%{type}-qt.sparc-en%{?magicstr:-%{magicstr}}
334 %endif
335 %ifarch ppc
336 %setup -q -T -b %{?with_weekly:30}%{?with_snap:10}%{?with_shared:2}2 -n %{name}-%{sver}-%{rel}-%{type}-qt.ppc-en%{?magicstr:-%{magicstr}}
337 %endif
338 %patch0 -p1
339
340 %install
341 rm -rf $RPM_BUILD_ROOT
342 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_sysconfdir}}
343
344 sh install.sh \
345         DESTDIR=$RPM_BUILD_ROOT \
346         --prefix=%{_prefix} \
347         --exec_prefix=%{_libdir}/opera/bin \
348         --docdir=%{_operadocdir}
349
350 # install in kde etc.
351 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
352 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
353
354 mv -f $RPM_BUILD_ROOT%{_datadir}/%{name}/config/* $RPM_BUILD_ROOT%{_sysconfdir}
355
356 %clean
357 rm -rf $RPM_BUILD_ROOT
358
359 %files
360 %defattr(644,root,root,755)
361 %doc LICENSE
362 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/opera*rc*
363 %attr(755,root,root) %{_bindir}/*
364 %dir %{_libdir}/opera
365 %dir %{_libdir}/opera/bin
366 %attr(755,root,root) %{_libdir}/opera/bin/*
367 %dir %{_plugindir}
368 %attr(755,root,root) %{_plugindir}/*
369 %dir %{_datadir}/opera
370 %{_datadir}/opera/*.*
371 %{_datadir}/opera/images
372 %{_datadir}/opera/ini
373 %{_datadir}/opera/java
374 %{_datadir}/opera/skin
375 %{_datadir}/opera/styles
376 %dir %{_datadir}/opera/locale
377 %{_datadir}/opera/locale/en
378 %{_datadir}/opera/locale/english.lng
379 %{_desktopdir}/*.desktop
380 %{_mandir}/man1/opera.1*
381 %{_pixmapsdir}/opera.xpm
This page took 0.053574 seconds and 3 git commands to generate.