]> git.pld-linux.org Git - packages/opera.git/blob - opera.spec
- B4 snapshot
[packages/opera.git] / opera.spec
1 #
2 # There're some problems with "shared" version
3 #
4 %define ver     7.20
5 %define rel     20030821.1
6 %define dirrel  20030821
7 %define type    static
8 Summary:        World fastest web browser
9 Summary(pl):    Najszybsza przegl±darka WWW na ¶wiecie
10 Name:           opera
11 Version:        %{ver}.%{rel}
12 Release:        1
13 License:        Restricted, see file LICENSE
14 Group:          X11/Applications/Networking
15 #Source0:       ftp://ftp.opera.com/pub/opera/linux/711/final/en/i386/static/%{name}-%{ver}-%{rel}-%{type}-qt.i386.tar.bz2
16 Source0:        http://snapshot.opera.com/unix/intel-linux/445-%{dirrel}-%{ver}-B4/opera-%{ver}-%{rel}-%{type}-qt.i386.tar.bz2
17 %ifarch ppc
18 #Source1:       ftp://ftp.opera.com/pub/opera/linux/711/final/en/ppc/static/%{name}-%{ver}-%{rel}-%{type}-qt.ppc.tar.bz2
19 Source1:        http://snapshot.opera.com/unix/ppc-linux/445-%{rel}-%{ver}-B4/opera-%{ver}-%{rel}-%{type}-qt.i386.tar.bz2
20 %endif
21 %ifarch sparc
22 Source1:        http://snapshot.opera.com/unix/sparc-linux/445-%{rel}-%{ver}-B4/opera-%{ver}-%{rel}-%{type}-qt.i386.tar.bz2
23 %endif
24 # polish language file
25 Source2:        %{name}-2887.lng
26 Source3:        %{name}.desktop
27 NoSource:       0
28 URL:            http://www.opera.com/
29 ExclusiveArch:  %{ix86} ppc
30 Requires:       freetype >= 2
31 Requires:       openmotif >= 2
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _plugindir      %{_libdir}/opera/plugins
35 %define         _operadocdir    %{_docdir}/%{name}-%{ver}.%{rel}
36 %define         configfile      %{_datadir}/opera/config/opera6rc
37
38 %description
39 Opera is world fastest web browser. It supports most of nowaday
40 extensions of HTML. And it is quite stable. Only disadvantage are
41 advertisements on the top of its window. Version static linked with qt.
42
43 %description -l pl
44 Opera jest najszybsz± przegl±dark± WWW na ¶wiecie. Obs³uguje wiêkszo¶æ
45 dzisiejszych rozszerzeñ HTMLa. Dodatkowo jest w miarê stabilna. Jedyn±
46 niedogodno¶ci± s± reklamy ukazuj±ce siê w górze okna. Wersja statycznie
47 linkowana z qt.
48
49 %prep
50 %ifarch %{ix86}
51 %setup -q  -n %{name}-%{ver}-%{rel}-%{type}-qt.i386
52 %endif
53 %ifarch ppc
54 %setup -q -T -b 1 -n %{name}-%{ver}-%{rel}-%{type}-qt.ppc
55 %endif
56 %ifarch sparc
57 %setup -q -T -b 1 -n %{name}-%{ver}-%{rel}-%{type}-qt.sparc
58 %endif
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 cat install.sh | sed 's|/etc|$RPM_BUILD_ROOT%{_sysconfdir}|' > install2.sh
64 mv install2.sh install.sh
65
66 echo y |\
67 sh install.sh \
68   --prefix=$RPM_BUILD_ROOT%{_prefix} \
69   --wrapperdir=$RPM_BUILD_ROOT%{_bindir} \
70   --docdir=$RPM_BUILD_ROOT%{_operadocdir} \
71   --sharedir=$RPM_BUILD_ROOT%{_datadir}/opera \
72   --exec_prefix=$RPM_BUILD_ROOT%{_datadir}/opera/bin \
73   --plugindir=$RPM_BUILD_ROOT%{_plugindir}
74
75 # Polish locale
76 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/opera/locale/
77
78 # man install
79 install -d $RPM_BUILD_ROOT%{_mandir}/man1
80 install man/opera.1 $RPM_BUILD_ROOT%{_mandir}/man1
81
82 # wrapper correction
83 sed s#$RPM_BUILD_ROOT## > $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
84 mv $RPM_BUILD_ROOT%{_bindir}/opera2 $RPM_BUILD_ROOT%{_bindir}/opera
85
86 # install in kde etc.
87 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
88 install images/opera.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
89
90 install -d $RPM_BUILD_ROOT%{_applnkdir}/Network/WWW
91 install %{SOURCE3} $RPM_BUILD_ROOT%{_applnkdir}/Network/WWW
92
93 # symlink który niweluje burkanie siê opery :>
94 #ln -sf %{_datadir}/opera/ $RPM_BUILD_ROOT/usr/share/
95 #ln -sf %{_libdir}/opera $RPM_BUILD_ROOT/usr/lib/
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %doc LICENSE bugreport help
103 %attr(755,root,root) %{_bindir}/*
104 %dir %{_datadir}/opera
105 %dir %{_datadir}/opera/bin
106 %attr(755,root,root) %{_datadir}/opera/bin/*
107 %{_datadir}/opera/config
108 %{_datadir}/opera/help
109 %{_datadir}/opera/images
110 %{_datadir}/opera/java
111 %{_datadir}/opera/locale
112 %{_datadir}/opera/skin
113 %{_datadir}/opera/styles
114 %{_datadir}/opera/ini
115 %{_datadir}/opera/search.ini
116 %{_datadir}/opera/*.html
117 %ifarch %{ix86}
118 %attr(755,root,root) %{_datadir}/opera/chartables.bin
119 %endif
120 %ifarch ppc
121 %attr(755,root,root) %{_datadir}/opera/chartables-be.bin
122 %endif
123 %attr(755,root,root) %{_datadir}/opera/opera6.adr
124 %dir %{_libdir}/opera
125 %dir %{_plugindir}
126 %attr(755,root,root) %{_plugindir}/*
127
128 %{_pixmapsdir}/opera.xpm
129 %{_applnkdir}/Network/WWW/*.desktop
130
131 %{_mandir}/man1/opera.1*
This page took 0.062843 seconds and 3 git commands to generate.