]> git.pld-linux.org Git - packages/openssl.git/commitdiff
- use the __perl macro
authorradek <radek@pld-linux.org>
Sun, 2 Mar 2003 21:36:53 +0000 (21:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    openssl.spec -> 1.92

openssl.spec

index ed3e70158e58a119e380662d5b82498735d8e4b3..f10d3dae296eeb129ec0fd3a5364ee79c93acf87 100644 (file)
@@ -181,12 +181,12 @@ RC4, RSA 
 
 %build
 for f in ` grep -r "%{_prefix}/local/bin/perl" . | cut -d":" -f1`; do
-perl -pi -e 's#%{_prefix}/local/bin/perl#%{_bindir}/perl#g' $f
+%{__perl} -pi -e 's#%{_prefix}/local/bin/perl#%{__perl}#g' $f
 done
 
 touch Makefile.*
 
-perl util/perlpath.pl %{_bindir}/perl
+%{__perl} util/perlpath.pl %{__perl}
 
 OPTFLAGS="%{rpmcflags}"
 export OPTFLAGS
@@ -215,7 +215,7 @@ center="OpenSSL 0.9.7"
 rel="OpenSSL 0.9.7"
 
 cd doc/apps || exit 1
-perl -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
+%{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
 
 for pod in *.pod; do
        if [ $pod != "openssl.pod" ]; then
@@ -244,7 +244,7 @@ for dir in ssl crypto; do
                rel="OpenSSL cryptographic library"
        fi
 
-       perl -p -i -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
+       %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
 
        for pod in *.pod; do
                sec=`[ "$pod" = "des_modes.pod" ] && echo 7 || echo 3`;
@@ -258,7 +258,8 @@ for dir in ssl crypto; do
 done
 
 #cd perl
-#perl Makefile.PL
+#%{__perl} Makefile.PL \
+#      INSTALLDIRS=vendor
 #make
 
 %install
This page took 0.090918 seconds and 4 git commands to generate.