]> git.pld-linux.org Git - packages/openssl.git/commitdiff
- add patch from upstream
authorAndrzej Zawadzki <zawadaa@pld-linux.org>
Mon, 28 Apr 2014 11:19:42 +0000 (13:19 +0200)
committerAndrzej Zawadzki <zawadaa@pld-linux.org>
Mon, 28 Apr 2014 11:19:42 +0000 (13:19 +0200)
https://rt.openssl.org/Ticket/Display.html?id=3265
and fix:
http://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=94d1f4b0f3d262edf1cf7023a01d5404945035d5

openssl-fix_use_after_free.patch [new file with mode: 0644]
openssl.spec

diff --git a/openssl-fix_use_after_free.patch b/openssl-fix_use_after_free.patch
new file mode 100644 (file)
index 0000000..f00d291
--- /dev/null
@@ -0,0 +1,15 @@
+diff --git a/ssl/s3_pkt.c b/ssl/s3_pkt.c
+index b9e45c7..30b74c2 100644
+--- a/ssl/s3_pkt.c
++++ b/ssl/s3_pkt.c
+@@ -1335,7 +1335,8 @@ start:
+                               s->rstate=SSL_ST_READ_HEADER;
+                               rr->off=0;
+                               if (s->mode & SSL_MODE_RELEASE_BUFFERS)
+-                                      ssl3_release_read_buffer(s);
++                                      if (s->s3->rbuf.left == 0) /* no read-ahead left? */
++                                              ssl3_release_read_buffer(s);
+                               }
+                       }
+               return(n);
+
index e44f791dadea34789b29e1e87abbf440c3b43498..f5a0ec01146ae1a7dce3652f6c0a0bea170b5ff4 100644 (file)
@@ -41,6 +41,9 @@ Patch10:      default_bits.patch
 Patch11:       pic.patch
 Patch12:       stddef.patch
 
 Patch11:       pic.patch
 Patch12:       stddef.patch
 
+# from upstream
+Patch13:       %{name}-fix_use_after_free.patch
+
 URL:           http://www.openssl.org/
 BuildRequires: bc
 BuildRequires: perl-devel >= 1:5.6.1
 URL:           http://www.openssl.org/
 BuildRequires: bc
 BuildRequires: perl-devel >= 1:5.6.1
@@ -262,6 +265,8 @@ RC4, RSA и SSL. Включает статические библиотеки д
 %patch11 -p1
 %patch12 -p1
 
 %patch11 -p1
 %patch12 -p1
 
+%patch13 -p1
+
 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
 
 %build
 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
 
 %build
This page took 0.292394 seconds and 4 git commands to generate.