]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- spec adapterized.
[packages/openssl.git] / openssl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Library and toolkit for the "Secure Sockets Layer" (SSL v2/v3)
3 Summary(de):    Secure Sockets Layer (SSL)-Kommunikationslibrary & Utilities
4 Summary(fr):    Utilitaires et librairies de communication SSL (Secure Sockets Layer)
5 Name:           openssl
6 Version:        0.9.5a
7 Release:        1
8 Group:          Libraries
9 Group(fr):      Librairies
10 Group(pl):      Biblioteki
11 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
12 Patch0:         openssl-perl.patch
13 Vendor:         The OpenSSL Project
14 License:        Apache-style License
15 BuildRequires:  symlinks
16 BuildRequires:  perl
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Obsoletes:      SSLeay
19 Obsoletes:      SSLeay-devel
20 Obsoletes:      SSLeay-perl
21
22 %define         openssldir      /var/lib/openssl
23 %define         _sysconfdir     /etc/%{name}
24 %define         _pkglibdir      %{_libdir}/%{name}
25 %define         _pkgincludedir  %{_includedir}/%{name}
26
27 %description
28 The OpenSSL Project is a collaborative effort to develop a robust,
29 commercial-grade, full-featured, and Open Source toolkit implementing
30 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
31 v1) protocols with full-strength cryptography world-wide. The project
32 is managed by a worldwide community of volunteers that use the
33 Internet to communicate, plan, and develop the OpenSSL tookit and its
34 related documentation.
35
36 OpenSSL is based on the excellent SSLeay library developed by Eric A.
37 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
38 Apache-style licence, which basically means that you are free to get
39 and use it for commercial and non-commercial purposes subject to some
40 simple license conditions.
41
42 %description -l de
43 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
44 libraries, die verschiedene Verschlüsselungs- und
45 Entschlüsselungsalgorithmen und
46 - -protokolle, wie DES, RC4, RSA und SSL zur Verfügung stellen.
47
48 %description -l fr
49 OpenSSL est un outiil de gestion des certificats et les librairies
50 partagees qui fournit plusieurs protocoles et algorithmes de
51 codage/decodage, incluant DES, RC4, RSA et SSL.
52
53 %package devel
54 Summary:        Development part of OpenSSL library
55 Summary(de):    Secure Sockets Layer Kommunikationslibrary: statische libraries+header                           
56 Summary(fr):    Librairies statiques, headers et utilitaires pour communication SSL (Secure Sockets Layer)
57 Summary(pl):    Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów
58 Group:          Development/Libraries
59 Group(fr):      Development/Librairies
60 Group(pl):      Programowanie/Biblioteki
61 Requires:       %{name} = %{version}
62
63 %description devel
64 Development part of OpenSSL library.
65
66 %description devel -l pl
67 Czê¶æ bibiloteki OpenSSL przeznaczona dla programistów.
68
69 %package static
70 Summary:        Static OpenSSL library
71 Summary(pl):    Statyczna wersja biblioteki OpenSSL
72 Group:          Development/Libraries
73 Group(fr):      Development/Librairies
74 Group(pl):      Programowanie/Biblioteki
75 Requires:       %{name}-devel = %{version}
76
77 %description static
78 Static OpenSSL library.
79
80 %description static -l pl
81 Statyczna wersja biblioteki OpenSSL.
82
83 %prep
84 %setup -q 
85 %patch -p1
86
87 %build
88 for i in Configure Makefile.org ; do
89         perl -pi -e 's#-m486##g' $i
90         perl -pi -e 's#-O3 -fomit-frame-pointer#%{optflags}#g' $i
91 done
92
93 perl util/perlpath.pl %{_bindir}
94
95 ./config --openssldir=%{openssldir}
96
97 make OPT_FLAGS="$RPM_OPT_FLAGS" linux-shared
98 make INSTALLTOP=%{_prefix} OPT_FLAGS="$RPM_OPT_FLAGS"
99 make rehash
100 #cd perl
101 #perl Makefile.PL
102 #make
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
108
109 make install \
110         INSTALLTOP=%{_prefix} \
111         INSTALL_PREFIX=$RPM_BUILD_ROOT
112
113 install libRSAglue.a    $RPM_BUILD_ROOT%{_libdir}
114 install lib*.so.*.*     $RPM_BUILD_ROOT%{_libdir}
115 cp -d   lib*.so         $RPM_BUILD_ROOT%{_libdir}
116
117 #cd perl
118 #make install DESTDIR=$RPM_BUILD_ROOT
119 #cd ..
120
121 mv $RPM_BUILD_ROOT%{openssldir}/openssl.cnf $RPM_BUILD_ROOT%{_sysconfdir}
122 ln -s %{_sysconfdir}/openssl.cnf \
123         $RPM_BUILD_ROOT%{openssldir}/openssl.cnf
124 symlinks -cs $RPM_BUILD_ROOT%{openssldir}
125
126 mv $RPM_BUILD_ROOT%{openssldir}/misc/*  $RPM_BUILD_ROOT%{_pkglibdir}
127 rm -rf $RPM_BUILD_ROOT%{openssldir}/misc
128
129 strip $RPM_BUILD_ROOT%{_bindir}/* || :
130 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
131
132 gzip -9nf CHANGES CHANGES.SSLeay LICENSE NEWS README \
133         doc/*.txt doc/*/*pod
134
135 %post
136 %{_bindir}/c_rehash certs
137 /sbin/ldconfig
138
139 %postun -p /sbin/ldconfig
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files
145 %defattr(644,root,root,755)
146 %doc {CHANGES,CHANGES.SSLeay,LICENSE,NEWS,README}.gz
147 %doc doc/*.txt.gz doc/apps 
148 %doc doc/openssl_button.gif doc/openssl_button.html
149
150 %attr(755,root,root) %{_bindir}/*
151 %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/openssl.cnf
152 %verify(not md5 size mtime) %config(noreplace) %{openssldir}/openssl.cnf
153 %{openssldir}/certs
154 %{openssldir}/private
155 %dir %{_pkglibdir}
156 %attr(755,root,root) %{_pkglibdir}/*
157 %attr(755,root,root) %{_libdir}/lib*.so.*.*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %doc doc/ssl doc/crypto
162 %attr(755,root,root) %{_libdir}/lib*.so
163 %{_pkgincludedir}
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/lib*.a
This page took 0.042386 seconds and 4 git commands to generate.