]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
- up to 3.0.0
[packages/openssl.git] / openssl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make tests"
4 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
5 %bcond_with     sslv3   # SSLv3: note - enables CVE-2014-3566 vulnerability
6
7 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
8 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
9 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
10 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
11 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
12 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
13 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
14 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
15 Name:           openssl
16 Version:        3.0.0
17 Release:        1
18 License:        Apache v2.0
19 Group:          Libraries
20 Source0:        https://www.openssl.org/source/%{name}-%{version}.tar.gz
21 # Source0-md5:  43c5ab628b7ab899d7cd4a4c7fe4067f
22 Source2:        %{name}.1.pl
23 Source3:        %{name}-ssl-certificate.sh
24 Source4:        %{name}-c_rehash.sh
25 Patch0:         %{name}-optflags.patch
26 Patch1:         %{name}-ca-certificates.patch
27 Patch2:         %{name}-find.patch
28 Patch3:         pic.patch
29 Patch4:         engines-dir.patch
30 URL:            http://www.openssl.org/
31 BuildRequires:  libsctp-devel
32 BuildRequires:  perl-devel >= 1:5.10.0
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 BuildRequires:  rpmbuild(macros) >= 1.213
36 BuildRequires:  sed >= 4.0
37 BuildRequires:  zlib-devel
38 Requires:       ca-certificates >= 20141019-3
39 Requires:       rpm-whiteout >= 1.7
40 Obsoletes:      SSLeay
41 Obsoletes:      SSLeay-devel
42 Obsoletes:      SSLeay-perl
43 Obsoletes:      libopenssl0
44 %if "%{pld_release}" == "ac"
45 Conflicts:      neon < 0.26.3-3
46 Conflicts:      ntpd < 4.2.4p8-10
47 Conflicts:      openssh-clients < 2:5.8p1-9
48 Conflicts:      openssh-server < 2:5.8p1-9
49 %else
50 Conflicts:      neon < 0.29.6-8
51 Conflicts:      openssh-clients < 2:6.2p2-3
52 Conflicts:      openssh-server < 2:6.2p2-3
53 %endif
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 The OpenSSL Project is a collaborative effort to develop a robust,
58 commercial-grade, full-featured, and Open Source toolkit implementing
59 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
60 v1) protocols with full-strength cryptography world-wide. The project
61 is managed by a worldwide community of volunteers that use the
62 Internet to communicate, plan, and develop the OpenSSL tookit and its
63 related documentation.
64
65 OpenSSL is based on the excellent SSLeay library developed by Eric A.
66 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
67 Apache-style licence, which basically means that you are free to get
68 and use it for commercial and non-commercial purposes subject to some
69 simple license conditions.
70
71 This package contains shared libraries only, install openssl-tools if
72 you want to use openssl cmdline tool.
73
74 %description -l de.UTF-8
75 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
76 libraries, die verschiedene Verschlüsselungs- und
77 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
78 zur Verfügung stellen.
79
80 %description -l es.UTF-8
81 Biblioteca C que suministra algoritmos y protocolos criptográficos.
82
83 %description -l fr.UTF-8
84 OpenSSL est un outiil de gestion des certificats et les librairies
85 partagees qui fournit plusieurs protocoles et algorithmes de
86 codage/decodage, incluant DES, RC4, RSA et SSL.
87
88 %description -l pl.UTF-8
89 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
90 v2/v3 oraz Transport Layer Security (TLS v1).
91
92 %description -l pt_BR.UTF-8
93 Uma biblioteca C que fornece vários algoritmos e protocolos
94 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
95 compartilhadas e utilitários.
96
97 %description -l ru.UTF-8
98 Программа openssl для работы с сертификатами и разделяемые библиотеки,
99 которые реализуют множетсво криптографических алгоритмов, включая DES,
100 RC4, RSA и SSL.
101
102 %description -l uk.UTF-8
103 Програма openssl для роботи з сертифікатами та бібліотеки спільного
104 користування, що реалізують велику кількість криптографічних
105 алгоритмів, включаючи DES, RC4, RSA та SSL.
106
107 %package engines
108 Summary:        OpenSSL optional crypto engines
109 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
110 Group:          Libraries
111 Requires:       %{name} = %{version}-%{release}
112
113 %description engines
114 With OpenSSL 0.9.6, a new component was added to support alternative
115 cryptography implementations, most commonly for interfacing with
116 external crypto devices (eg. accelerator cards). This component is
117 called ENGINE.
118
119 There are currently built-in ENGINE implementations for the following
120 crypto devices:
121
122 - CryptoSwift
123 - Compaq Atalla
124 - nCipher CHIL
125 - Nuron
126 - Broadcom uBSec
127
128 In addition, dynamic binding to external ENGINE implementations is now
129 provided by a special ENGINE called "dynamic".
130
131 %description engines -l pl.UTF-8
132 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
133 wspierać alternatywne implementacje kryptografii, przeważnie
134 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
135 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
136 ENGINE).
137
138 Obecnie istnieją wbudowane implementacje silników dla następujących
139 urządzeń kryptograficznych:
140 - CryptoSwift
141 - Compaq Atalla
142 - nCipher CHIL
143 - Nuron
144 - Broadcom uBSec
145
146 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
147 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
148
149 %package tools
150 Summary:        OpenSSL command line tool and utilities
151 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
152 Group:          Applications/Communications
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       which
155
156 %description tools
157 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
158
159 %description tools -l pl.UTF-8
160 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
161
162 %package tools-perl
163 Summary:        OpenSSL utilities written in Perl
164 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
165 Group:          Applications/Communications
166 Requires:       %{name} = %{version}-%{release}
167
168 %description tools-perl
169 OpenSSL Toolkit tools written in Perl.
170
171 %description tools-perl -l pl.UTF-8
172 Narzędzia OpenSSL napisane w perlu.
173
174 %package devel
175 Summary:        Development part of OpenSSL Toolkit libraries
176 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
177 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
178 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
179 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
180 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
181 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
182 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
183 Group:          Development/Libraries
184 Requires:       %{name} = %{version}-%{release}
185 Obsoletes:      libopenssl0-devel
186
187 %description devel
188 Development part of OpenSSL library.
189
190 %description devel -l es.UTF-8
191 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
192
193 %description devel -l pl.UTF-8
194 Część biblioteki OpenSSL przeznaczona dla programistów.
195
196 %description devel -l pt_BR.UTF-8
197 Uma biblioteca C que fornece vários algoritmos e protocolos
198 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
199 arquivos de inclusão para desenvolvimento.
200
201 %description devel -l ru.UTF-8
202 Программа openssl для работы с сертификатами и разделяемые библиотеки,
203 которые реализуют множетсво криптографических алгоритмов, включая DES,
204 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
205 с использованием SSL.
206
207 %description devel -l uk.UTF-8
208 Програма openssl для роботи з сертифікатами та бібліотеки спільного
209 користування, що реалізують велику кількість криптографічних
210 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
211 хедери для розробки програм з використанням SSL.
212
213 %package static
214 Summary:        Static OpenSSL libraries
215 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
216 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
217 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
218 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
219 Group:          Development/Libraries
220 Requires:       %{name}-devel = %{version}-%{release}
221
222 %description static
223 Static OpenSSL Toolkit libraries.
224
225 %description static -l pl.UTF-8
226 Statyczne wersje bibliotek z OpenSSL.
227
228 %description static -l pt_BR.UTF-8
229 Bibliotecas estáticas para desenvolvimento com openssl.
230
231 %description static -l ru.UTF-8
232 Программа openssl для работы с сертификатами и разделяемые библиотеки,
233 которые реализуют множетсво криптографических алгоритмов, включая DES,
234 RC4, RSA и SSL. Включает статические библиотеки для разработки
235 приложений с использованием OpenSSL.
236
237 %description static -l uk.UTF-8
238 Програма openssl для роботи з сертифікатами та бібліотеки спільного
239 користування, що реалізують велику кількість криптографічних
240 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
241 бібліотеки для розробки програм з використанням SSL.
242
243 %prep
244 %setup -q
245 %patch0 -p1
246 %patch1 -p1
247 %patch2 -p1
248 %patch3 -p1
249 %patch4 -p1
250
251 # fails with enable-sctp as of 1.1.1
252 %{__rm} test/recipes/80-test_ssl_new.t
253
254 %build
255 touch Makefile.*
256
257 PERL="%{__perl}" \
258 %{__perl} ./Configure \
259         --prefix=%{_prefix} \
260         --openssldir=%{_sysconfdir}/%{name} \
261         --libdir=%{_lib} \
262         -Wa,--noexecstack \
263         shared \
264         threads \
265         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
266         %{!?with_zlib:no-}zlib \
267         enable-cms \
268         enable-idea \
269         enable-md2 \
270         enable-mdc2 \
271         enable-rc5 \
272         enable-rfc3779 \
273         enable-sctp \
274         enable-seed \
275 %ifarch %{x8664}
276         enable-ec_nistp_64_gcc_128 \
277 %endif
278 %ifarch %{ix86}
279 %ifarch i386
280         386 linux-elf
281 # ^- allow running on 80386 (default code uses bswapl available on i486+)
282 %else
283         linux-elf
284 %endif
285 %endif
286 %ifarch alpha
287         linux-alpha-gcc
288 %endif
289 %ifarch %{x8664}
290         linux-x86_64
291 %endif
292 %ifarch x32
293         linux-x32
294 %endif
295 %ifarch ia64
296         linux-ia64
297 %endif
298 %ifarch ppc
299         linux-ppc
300 %endif
301 %ifarch ppc64
302         linux-ppc64
303 %endif
304 %ifarch sparc
305         linux-sparcv8
306 %endif
307 %ifarch sparcv9
308         linux-sparcv9
309 %endif
310 %ifarch sparc64
311         linux64-sparcv9
312 %endif
313 %ifarch %{arm}
314         linux-armv4
315 %endif
316 %ifarch aarch64
317         linux-aarch64
318 %endif
319
320 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
321 test "$v" = %{version}
322
323 %{__make} -j1 all %{?with_tests:tests} \
324         CC="%{__cc}" \
325         OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
326         INSTALLTOP=%{_prefix}
327
328 %install
329 rm -rf $RPM_BUILD_ROOT
330 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
331         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
332         $RPM_BUILD_ROOT%{_pkgconfigdir}
333
334 %{__make} -j1 install \
335         CC="%{__cc}" \
336         DESTDIR=$RPM_BUILD_ROOT
337
338 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
339 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
340 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
341
342 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
343 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
344
345 # html version of man pages - not packaged
346 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/html/man[1357]
347
348 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
349 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
350 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
351
352 %clean
353 rm -rf $RPM_BUILD_ROOT
354
355 %post   -p /sbin/ldconfig
356 %postun -p /sbin/ldconfig
357
358 %triggerpostun -- %{name}-tools < 1.0.0-5
359 # the hashing format has changed in 1.0.0
360 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
361
362 %triggerpostun -- %{name} < 0.9.8i-2
363 # don't do anything on --downgrade
364 if [ $1 -le 1 ]; then
365         exit 0
366 fi
367 if [ -d /var/lib/openssl/certs ] ; then
368         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
369 fi
370 if [ -d /var/lib/openssl/private ] ; then
371         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
372 fi
373 if [ -d /var/lib/openssl ] ; then
374         for f in /var/lib/openssl/* ; do
375                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
376         done
377         rmdir /var/lib/openssl/* 2>/dev/null || :
378         rmdir /var/lib/openssl 2>/dev/null || :
379 fi
380
381 %files
382 %defattr(644,root,root,755)
383 %doc CHANGES.md NEWS.md README.md doc/*.txt
384 %attr(755,root,root) /%{_lib}/libcrypto.so.*
385 %attr(755,root,root) /%{_lib}/libssl.so.*
386 %dir /%{_lib}/ossl-modules
387 %attr(755,root,root) /%{_lib}/ossl-modules/legacy.so
388 %dir %{_sysconfdir}/%{name}
389 %dir %{_sysconfdir}/%{name}/certs
390 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
391 %dir %{_datadir}/ssl
392
393 %files engines
394 %defattr(644,root,root,755)
395 %dir /%{_lib}/engines-3
396 %attr(755,root,root) /%{_lib}/engines-3/*.so
397
398 %files tools
399 %defattr(644,root,root,755)
400 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ct_log_list.cnf
401 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
402 %attr(755,root,root) %{_bindir}/c_rehash.sh
403 %attr(755,root,root) %{_bindir}/openssl
404 %attr(754,root,root) %{_bindir}/ssl-certificate
405 %{_mandir}/man1/asn1parse.1*
406 %{_mandir}/man1/ca.1*
407 %{_mandir}/man1/ciphers.1*
408 %{_mandir}/man1/cms.1*
409 %{_mandir}/man1/crl.1*
410 %{_mandir}/man1/crl2pkcs7.1*
411 %{_mandir}/man1/dgst.1*
412 %{_mandir}/man1/dhparam.1*
413 %{_mandir}/man1/dsa.1*
414 %{_mandir}/man1/dsaparam.1*
415 %{_mandir}/man1/ec.1*
416 %{_mandir}/man1/ecparam.1*
417 %{_mandir}/man1/enc.1*
418 %{_mandir}/man1/engine.1*
419 %{_mandir}/man1/errstr.1*
420 %{_mandir}/man1/gendsa.1*
421 %{_mandir}/man1/genpkey.1*
422 %{_mandir}/man1/genrsa.1*
423 %{_mandir}/man1/kdf.1*
424 %{_mandir}/man1/mac.1*
425 %{_mandir}/man1/nseq.1*
426 %{_mandir}/man1/ocsp.1*
427 %{_mandir}/man1/openssl.1*
428 %{_mandir}/man1/openssl-*.1*
429 %{_mandir}/man1/passwd.1*
430 %{_mandir}/man1/pkcs12.1*
431 %{_mandir}/man1/pkcs7.1*
432 %{_mandir}/man1/pkcs8.1*
433 %{_mandir}/man1/pkey.1*
434 %{_mandir}/man1/pkeyparam.1*
435 %{_mandir}/man1/pkeyutl.1*
436 %{_mandir}/man1/prime.1*
437 %{_mandir}/man1/rand.1*
438 %{_mandir}/man1/rehash.1*
439 %{_mandir}/man1/req.1*
440 %{_mandir}/man1/rsa.1*
441 %{_mandir}/man1/rsautl.1*
442 %{_mandir}/man1/s_client.1*
443 %{_mandir}/man1/sess_id.1*
444 %{_mandir}/man1/smime.1*
445 %{_mandir}/man1/speed.1*
446 %{_mandir}/man1/spkac.1*
447 %{_mandir}/man1/srp.1*
448 %{_mandir}/man1/s_server.1*
449 %{_mandir}/man1/s_time.1*
450 %{_mandir}/man1/storeutl.1*
451 %{_mandir}/man1/ts.1*
452 %{_mandir}/man1/verify.1*
453 %{_mandir}/man1/version.1*
454 %{_mandir}/man1/x509.1*
455 %{_mandir}/man5/*.5*
456 %lang(pl) %{_mandir}/pl/man1/openssl.1*
457
458 %files tools-perl
459 %defattr(644,root,root,755)
460 %attr(755,root,root) %{_bindir}/c_rehash
461 %dir %{_libdir}/%{name}
462 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
463 %attr(755,root,root) %{_libdir}/%{name}/tsget
464 %attr(755,root,root) %{_libdir}/%{name}/tsget.pl
465 %{_mandir}/man1/CA.pl.1*
466 %{_mandir}/man1/c_rehash.1*
467 %{_mandir}/man1/tsget.1*
468
469 %files devel
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_libdir}/libcrypto.so
472 %attr(755,root,root) %{_libdir}/libssl.so
473 %{_includedir}/%{name}
474 %{_pkgconfigdir}/libcrypto.pc
475 %{_pkgconfigdir}/libssl.pc
476 %{_pkgconfigdir}/openssl.pc
477 %{_mandir}/man3/*.3*
478 %{_mandir}/man7/*.7*
479
480 %files static
481 %defattr(644,root,root,755)
482 %{_libdir}/libcrypto.a
483 %{_libdir}/libssl.a
This page took 0.076247 seconds and 4 git commands to generate.