]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
ae7bca06c30154b1773ae679850f60bdbf93789a
[packages/openssl.git] / openssl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make tests"
4 %bcond_without  zlib    # zlib: note - enables CVE-2012-4929 vulnerability
5 %bcond_with     sslv2   # SSLv2: note - many flaws http://en.wikipedia.org/wiki/Transport_Layer_Security#SSL_2.0
6 %bcond_with     sslv3   # SSLv3: note - enables CVE-2014-3566 vulnerability
7
8 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
9 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
10 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
11 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
12 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
13 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
14 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
15 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
16 Name:           openssl
17 # Version 1.1.1 is LTS, supported until 2023-09-11.
18 # https://www.openssl.org/about/releasestrat.html
19 Version:        1.1.1h
20 Release:        1
21 License:        Apache-like
22 Group:          Libraries
23 Source0:        https://www.openssl.org/source/%{name}-%{version}.tar.gz
24 # Source0-md5:  53840c70434793127a3574433494e8d3
25 Source2:        %{name}.1.pl
26 Source3:        %{name}-ssl-certificate.sh
27 Source4:        %{name}-c_rehash.sh
28 Patch1:         %{name}-optflags.patch
29
30 Patch3:         %{name}-man-namespace.patch
31 Patch5:         %{name}-ca-certificates.patch
32 Patch6:         %{name}-no-win32.patch
33 Patch7:         %{name}-find.patch
34 Patch8:         pic.patch
35
36 Patch11:        engines-dir.patch
37 URL:            http://www.openssl.org/
38 BuildRequires:  libsctp-devel
39 BuildRequires:  perl-devel >= 1:5.10.0
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  rpmbuild(macros) >= 1.213
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  zlib-devel
45 Requires:       ca-certificates >= 20141019-3
46 Requires:       rpm-whiteout >= 1.7
47 Obsoletes:      SSLeay
48 Obsoletes:      SSLeay-devel
49 Obsoletes:      SSLeay-perl
50 Obsoletes:      libopenssl0
51 %if "%{pld_release}" == "ac"
52 Conflicts:      neon < 0.26.3-3
53 Conflicts:      ntpd < 4.2.4p8-10
54 Conflicts:      openssh-clients < 2:5.8p1-9
55 Conflicts:      openssh-server < 2:5.8p1-9
56 %else
57 Conflicts:      neon < 0.29.6-8
58 Conflicts:      openssh-clients < 2:6.2p2-3
59 Conflicts:      openssh-server < 2:6.2p2-3
60 %endif
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 The OpenSSL Project is a collaborative effort to develop a robust,
65 commercial-grade, full-featured, and Open Source toolkit implementing
66 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
67 v1) protocols with full-strength cryptography world-wide. The project
68 is managed by a worldwide community of volunteers that use the
69 Internet to communicate, plan, and develop the OpenSSL tookit and its
70 related documentation.
71
72 OpenSSL is based on the excellent SSLeay library developed by Eric A.
73 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
74 Apache-style licence, which basically means that you are free to get
75 and use it for commercial and non-commercial purposes subject to some
76 simple license conditions.
77
78 This package contains shared libraries only, install openssl-tools if
79 you want to use openssl cmdline tool.
80
81 %description -l de.UTF-8
82 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
83 libraries, die verschiedene Verschlüsselungs- und
84 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
85 zur Verfügung stellen.
86
87 %description -l es.UTF-8
88 Biblioteca C que suministra algoritmos y protocolos criptográficos.
89
90 %description -l fr.UTF-8
91 OpenSSL est un outiil de gestion des certificats et les librairies
92 partagees qui fournit plusieurs protocoles et algorithmes de
93 codage/decodage, incluant DES, RC4, RSA et SSL.
94
95 %description -l pl.UTF-8
96 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
97 v2/v3 oraz Transport Layer Security (TLS v1).
98
99 %description -l pt_BR.UTF-8
100 Uma biblioteca C que fornece vários algoritmos e protocolos
101 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
102 compartilhadas e utilitários.
103
104 %description -l ru.UTF-8
105 Программа openssl для работы с сертификатами и разделяемые библиотеки,
106 которые реализуют множетсво криптографических алгоритмов, включая DES,
107 RC4, RSA и SSL.
108
109 %description -l uk.UTF-8
110 Програма openssl для роботи з сертифікатами та бібліотеки спільного
111 користування, що реалізують велику кількість криптографічних
112 алгоритмів, включаючи DES, RC4, RSA та SSL.
113
114 %package engines
115 Summary:        OpenSSL optional crypto engines
116 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
117 Group:          Libraries
118 Requires:       %{name} = %{version}-%{release}
119
120 %description engines
121 With OpenSSL 0.9.6, a new component was added to support alternative
122 cryptography implementations, most commonly for interfacing with
123 external crypto devices (eg. accelerator cards). This component is
124 called ENGINE.
125
126 There are currently built-in ENGINE implementations for the following
127 crypto devices:
128
129 - CryptoSwift
130 - Compaq Atalla
131 - nCipher CHIL
132 - Nuron
133 - Broadcom uBSec
134
135 In addition, dynamic binding to external ENGINE implementations is now
136 provided by a special ENGINE called "dynamic".
137
138 %description engines -l pl.UTF-8
139 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
140 wspierać alternatywne implementacje kryptografii, przeważnie
141 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
142 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
143 ENGINE).
144
145 Obecnie istnieją wbudowane implementacje silników dla następujących
146 urządzeń kryptograficznych:
147 - CryptoSwift
148 - Compaq Atalla
149 - nCipher CHIL
150 - Nuron
151 - Broadcom uBSec
152
153 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
154 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
155
156 %package tools
157 Summary:        OpenSSL command line tool and utilities
158 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
159 Group:          Applications/Communications
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       which
162
163 %description tools
164 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
165
166 %description tools -l pl.UTF-8
167 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
168
169 %package tools-perl
170 Summary:        OpenSSL utilities written in Perl
171 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
172 Group:          Applications/Communications
173 Requires:       %{name} = %{version}-%{release}
174
175 %description tools-perl
176 OpenSSL Toolkit tools written in Perl.
177
178 %description tools-perl -l pl.UTF-8
179 Narzędzia OpenSSL napisane w perlu.
180
181 %package devel
182 Summary:        Development part of OpenSSL Toolkit libraries
183 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
184 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
185 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
186 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
187 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
188 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
189 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
190 Group:          Development/Libraries
191 Requires:       %{name} = %{version}-%{release}
192 Obsoletes:      libopenssl0-devel
193
194 %description devel
195 Development part of OpenSSL library.
196
197 %description devel -l es.UTF-8
198 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
199
200 %description devel -l pl.UTF-8
201 Część biblioteki OpenSSL przeznaczona dla programistów.
202
203 %description devel -l pt_BR.UTF-8
204 Uma biblioteca C que fornece vários algoritmos e protocolos
205 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
206 arquivos de inclusão para desenvolvimento.
207
208 %description devel -l ru.UTF-8
209 Программа openssl для работы с сертификатами и разделяемые библиотеки,
210 которые реализуют множетсво криптографических алгоритмов, включая DES,
211 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
212 с использованием SSL.
213
214 %description devel -l uk.UTF-8
215 Програма openssl для роботи з сертифікатами та бібліотеки спільного
216 користування, що реалізують велику кількість криптографічних
217 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
218 хедери для розробки програм з використанням SSL.
219
220 %package static
221 Summary:        Static OpenSSL libraries
222 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
223 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
224 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
225 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
226 Group:          Development/Libraries
227 Requires:       %{name}-devel = %{version}-%{release}
228
229 %description static
230 Static OpenSSL Toolkit libraries.
231
232 %description static -l pl.UTF-8
233 Statyczne wersje bibliotek z OpenSSL.
234
235 %description static -l pt_BR.UTF-8
236 Bibliotecas estáticas para desenvolvimento com openssl.
237
238 %description static -l ru.UTF-8
239 Программа openssl для работы с сертификатами и разделяемые библиотеки,
240 которые реализуют множетсво криптографических алгоритмов, включая DES,
241 RC4, RSA и SSL. Включает статические библиотеки для разработки
242 приложений с использованием OpenSSL.
243
244 %description static -l uk.UTF-8
245 Програма openssl для роботи з сертифікатами та бібліотеки спільного
246 користування, що реалізують велику кількість криптографічних
247 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
248 бібліотеки для розробки програм з використанням SSL.
249
250 %prep
251 %if %{with snap}
252 %setup -qcT -a1
253 %{__mv} %{name}-OpenSSL_1_1_0-stable/* .
254 %else
255 %setup -q %{?subver:-n %{name}-%{version}-%{subver}}
256 %endif
257 %patch1 -p1
258
259 %patch3 -p1
260 %patch5 -p1
261 %patch6 -p1
262 %patch7 -p1
263 %patch8 -p1
264
265 %patch11 -p1
266
267 %build
268 touch Makefile.*
269
270 PERL="%{__perl}" \
271 %{__perl} ./Configure \
272         --prefix=%{_prefix} \
273         --openssldir=%{_sysconfdir}/%{name} \
274         --libdir=%{_lib} \
275         -Wa,--noexecstack \
276         shared \
277         threads \
278         %{?with_sslv2:enable-ssl2}%{!?with_sslv2:no-ssl2} \
279         %{?with_sslv3:enable-ssl3}%{!?with_sslv3:no-ssl3} \
280         %{!?with_zlib:no-}zlib \
281         enable-cms \
282         enable-idea \
283         enable-md2 \
284         enable-mdc2 \
285         enable-rc5 \
286         enable-rfc3779 \
287         enable-sctp \
288         enable-seed \
289 %ifarch %{x8664}
290         enable-ec_nistp_64_gcc_128 \
291 %endif
292 %ifarch %{ix86}
293 %ifarch i386
294         386 linux-elf
295 # ^- allow running on 80386 (default code uses bswapl available on i486+)
296 %else
297         linux-elf
298 %endif
299 %endif
300 %ifarch alpha
301         linux-alpha-gcc
302 %endif
303 %ifarch %{x8664}
304         linux-x86_64
305 %endif
306 %ifarch x32
307         linux-x32
308 %endif
309 %ifarch ia64
310         linux-ia64
311 %endif
312 %ifarch ppc
313         linux-ppc
314 %endif
315 %ifarch ppc64
316         linux-ppc64
317 %endif
318 %ifarch sparc
319         linux-sparcv8
320 %endif
321 %ifarch sparcv9
322         linux-sparcv9
323 %endif
324 %ifarch sparc64
325         linux64-sparcv9
326 %endif
327 %ifarch %{arm}
328         linux-armv4
329 %endif
330 %ifarch aarch64
331         linux-aarch64
332 %endif
333
334 v=$(awk -F= '/^VERSION/{print $2}' Makefile)
335 test "$v" = %{version}%{?subver:-%{subver}}%{?with_snap:-dev}
336
337 # fails with enable-sctp as of 1.1.1
338 %{__rm} test/recipes/80-test_ssl_new.t
339
340 %{__make} -j1 all %{?with_tests:tests} \
341         CC="%{__cc}" \
342         OPTFLAGS="%{rpmcflags} %{rpmcppflags}" \
343         INSTALLTOP=%{_prefix}
344
345 # Rename POD sources of man pages. "openssl-" prefix is added to each
346 # manpage to avoid potential conflicts with other packages.
347 # openssl-man-namespace.patch mostly marks these pages with "openssl-" prefix.
348
349 for podfile in $(grep -rl '^openssl-' doc/man*); do
350         dir=$(dirname "$podfile")
351         base=$(basename "$podfile")
352         %{__mv} "$podfile" "$dir/openssl-$base"
353 done
354
355 %install
356 rm -rf $RPM_BUILD_ROOT
357 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
358         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
359         $RPM_BUILD_ROOT%{_pkgconfigdir}
360
361 %{__make} -j1 install \
362         CC="%{__cc}" \
363         DESTDIR=$RPM_BUILD_ROOT
364
365 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
366 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
367 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
368
369 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
370 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
371
372 # html version of man pages - not packaged
373 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}/html/man[1357]
374
375 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
376 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
377 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
378
379 %clean
380 rm -rf $RPM_BUILD_ROOT
381
382 %post   -p /sbin/ldconfig
383 %postun -p /sbin/ldconfig
384
385 %triggerpostun -- %{name}-tools < 1.0.0-5
386 # the hashing format has changed in 1.0.0
387 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
388
389 %triggerpostun -- %{name} < 0.9.8i-2
390 # don't do anything on --downgrade
391 if [ $1 -le 1 ]; then
392         exit 0
393 fi
394 if [ -d /var/lib/openssl/certs ] ; then
395         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
396 fi
397 if [ -d /var/lib/openssl/private ] ; then
398         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
399 fi
400 if [ -d /var/lib/openssl ] ; then
401         for f in /var/lib/openssl/* ; do
402                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
403         done
404         rmdir /var/lib/openssl/* 2>/dev/null || :
405         rmdir /var/lib/openssl 2>/dev/null || :
406 fi
407
408 %files
409 %defattr(644,root,root,755)
410 %doc CHANGES LICENSE NEWS README doc/*.txt
411 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*
412 %attr(755,root,root) /%{_lib}/libssl.so.*.*
413 %dir %{_sysconfdir}/%{name}
414 %dir %{_sysconfdir}/%{name}/certs
415 %dir %attr(700,root,root) %{_sysconfdir}/%{name}/private
416 %dir %{_datadir}/ssl
417
418 %files engines
419 %defattr(644,root,root,755)
420 %dir /%{_lib}/engines-1.1
421 %attr(755,root,root) /%{_lib}/engines-1.1/*.so
422
423 %files tools
424 %defattr(644,root,root,755)
425 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ct_log_list.cnf
426 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
427 %attr(755,root,root) %{_bindir}/c_rehash.sh
428 %attr(755,root,root) %{_bindir}/openssl
429 %attr(754,root,root) %{_bindir}/ssl-certificate
430 %{_mandir}/man1/openssl.1*
431 %{_mandir}/man1/openssl-asn1parse.1*
432 %{_mandir}/man1/openssl-ca.1*
433 %{_mandir}/man1/openssl-ciphers.1*
434 %{_mandir}/man1/openssl-cms.1*
435 %{_mandir}/man1/openssl-crl.1*
436 %{_mandir}/man1/openssl-crl2pkcs7.1*
437 %{_mandir}/man1/openssl-dgst.1*
438 %{_mandir}/man1/openssl-dhparam.1*
439 %{_mandir}/man1/openssl-dsa.1*
440 %{_mandir}/man1/openssl-dsaparam.1*
441 %{_mandir}/man1/openssl-ec.1*
442 %{_mandir}/man1/openssl-ecparam.1*
443 %{_mandir}/man1/openssl-enc.1*
444 %{_mandir}/man1/openssl-engine.1*
445 %{_mandir}/man1/openssl-errstr.1*
446 %{_mandir}/man1/openssl-gendsa.1*
447 %{_mandir}/man1/openssl-genpkey.1*
448 %{_mandir}/man1/openssl-genrsa.1*
449 %{_mandir}/man1/openssl-list.1*
450 %{_mandir}/man1/openssl-nseq.1*
451 %{_mandir}/man1/openssl-ocsp.1*
452 %{_mandir}/man1/openssl-passwd.1*
453 %{_mandir}/man1/openssl-pkcs12.1*
454 %{_mandir}/man1/openssl-pkcs7.1*
455 %{_mandir}/man1/openssl-pkcs8.1*
456 %{_mandir}/man1/openssl-pkey.1*
457 %{_mandir}/man1/openssl-pkeyparam.1*
458 %{_mandir}/man1/openssl-pkeyutl.1*
459 %{_mandir}/man1/openssl-prime.1*
460 %{_mandir}/man1/openssl-rand.1*
461 %{_mandir}/man1/openssl-rehash.1*
462 %{_mandir}/man1/openssl-req.1*
463 %{_mandir}/man1/openssl-rsa.1*
464 %{_mandir}/man1/openssl-rsautl.1*
465 %{_mandir}/man1/openssl-s_client.1*
466 %{_mandir}/man1/openssl-s_server.1*
467 %{_mandir}/man1/openssl-s_time.1*
468 %{_mandir}/man1/openssl-sess_id.1*
469 %{_mandir}/man1/openssl-smime.1*
470 %{_mandir}/man1/openssl-speed.1*
471 %{_mandir}/man1/openssl-spkac.1*
472 %{_mandir}/man1/openssl-srp.1*
473 %{_mandir}/man1/openssl-storeutl.1*
474 %{_mandir}/man1/openssl-ts.1*
475 %{_mandir}/man1/openssl-tsget.1*
476 %{_mandir}/man1/openssl-verify.1*
477 %{_mandir}/man1/openssl-version.1*
478 %{_mandir}/man1/openssl-x509.1*
479 %{_mandir}/man5/openssl-config.5*
480 %{_mandir}/man5/openssl-x509v3_config.5*
481 %lang(pl) %{_mandir}/pl/man1/openssl.1*
482
483 %files tools-perl
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_bindir}/c_rehash
486 %dir %{_libdir}/%{name}
487 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
488 %attr(755,root,root) %{_libdir}/%{name}/tsget
489 %attr(755,root,root) %{_libdir}/%{name}/tsget.pl
490 %{_mandir}/man1/CA.pl.1*
491 %{_mandir}/man1/c_rehash.1*
492
493 %files devel
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_libdir}/libcrypto.so
496 %attr(755,root,root) %{_libdir}/libssl.so
497 %{_includedir}/%{name}
498 %{_pkgconfigdir}/libcrypto.pc
499 %{_pkgconfigdir}/libssl.pc
500 %{_pkgconfigdir}/openssl.pc
501 %{_mandir}/man3/ACCESS_DESCRIPTION_*.3*
502 %{_mandir}/man3/ADMISSION*.3*
503 %{_mandir}/man3/ASId*.3*
504 %{_mandir}/man3/ASRange_*.3*
505 %{_mandir}/man3/ASN1_*.3*
506 %{_mandir}/man3/ASYNC_*.3*
507 %{_mandir}/man3/AUTHORITY_*.3*
508 %{_mandir}/man3/BASIC_CONSTRAINTS_*.3*
509 %{_mandir}/man3/BF_*.3*
510 %{_mandir}/man3/BIO_*.3*
511 %{_mandir}/man3/BN_*.3*
512 %{_mandir}/man3/BUF_*.3*
513 %{_mandir}/man3/CERTIFICATEPOLICIES_*.3*
514 %{_mandir}/man3/CMS_*.3*
515 %{_mandir}/man3/CONF_*.3*
516 %{_mandir}/man3/CRL_DIST_POINTS_*.3*
517 %{_mandir}/man3/CRYPTO_*.3*
518 %{_mandir}/man3/CTLOG_*.3*
519 %{_mandir}/man3/CT_POLICY_*.3*
520 %{_mandir}/man3/DECLARE_*.3*
521 %{_mandir}/man3/DEFINE_*.3*
522 %{_mandir}/man3/DES_*.3*
523 %{_mandir}/man3/DH_*.3*
524 %{_mandir}/man3/DHparams_*.3*
525 %{_mandir}/man3/DIRECTORYSTRING_*.3*
526 %{_mandir}/man3/DISPLAYTEXT_*.3*
527 %{_mandir}/man3/DIST_POINT_*.3*
528 %{_mandir}/man3/DSA_*.3*
529 %{_mandir}/man3/DSAparams_*.3*
530 %{_mandir}/man3/DTLS_*.3*
531 %{_mandir}/man3/DTLSv1_*.3*
532 %{_mandir}/man3/ECDH_*.3*
533 %{_mandir}/man3/ECDSA_*.3*
534 %{_mandir}/man3/ECPARAMETERS_*.3*
535 %{_mandir}/man3/ECPKPARAMETERS_*.3*
536 %{_mandir}/man3/ECPKParameters_*.3*
537 %{_mandir}/man3/EC_*.3*
538 %{_mandir}/man3/EDIPARTYNAME_*.3*
539 %{_mandir}/man3/ENGINE_*.3*
540 %{_mandir}/man3/ERR_*.3*
541 %{_mandir}/man3/ESS_*.3*
542 %{_mandir}/man3/EVP_*.3*
543 %{_mandir}/man3/EXTENDED_KEY_USAGE_*.3*
544 %{_mandir}/man3/GENERAL_*.3*
545 %{_mandir}/man3/GEN_SESSION_CB.3*
546 %{_mandir}/man3/HMAC*.3*
547 %{_mandir}/man3/IMPLEMENT_*.3*
548 %{_mandir}/man3/IPAddress*.3*
549 %{_mandir}/man3/ISSUING_DIST_POINT_*.3*
550 %{_mandir}/man3/LHASH*.3*
551 %{_mandir}/man3/MD2*.3*
552 %{_mandir}/man3/MD4*.3*
553 %{_mandir}/man3/MD5*.3*
554 %{_mandir}/man3/MDC2*.3*
555 %{_mandir}/man3/NAME_CONSTRAINTS_*.3*
556 %{_mandir}/man3/NAMING_AUTHORITY*.3*
557 %{_mandir}/man3/NETSCAPE_*.3*
558 %{_mandir}/man3/NOTICEREF_*.3*
559 %{_mandir}/man3/OBJ_*.3*
560 %{_mandir}/man3/OCSP_*.3*
561 %{_mandir}/man3/OPENSSL_*.3*
562 %{_mandir}/man3/OSSL*.3*
563 %{_mandir}/man3/OTHERNAME_*.3*
564 %{_mandir}/man3/OpenSSL_*.3*
565 %{_mandir}/man3/PBE2PARAM_*.3*
566 %{_mandir}/man3/PBEPARAM_*.3*
567 %{_mandir}/man3/PBKDF2PARAM_*.3*
568 %{_mandir}/man3/PEM_*.3*
569 %{_mandir}/man3/PKCS12_*.3*
570 %{_mandir}/man3/PKCS5_*.3*
571 %{_mandir}/man3/PKCS7_*.3*
572 %{_mandir}/man3/PKCS8_*.3*
573 %{_mandir}/man3/PKEY_*.3*
574 %{_mandir}/man3/POLICYINFO_*.3*
575 %{_mandir}/man3/POLICYQUALINFO_*.3*
576 %{_mandir}/man3/POLICY_*.3*
577 %{_mandir}/man3/PROFESSION_INFO*.3*
578 %{_mandir}/man3/PROXY_*.3*
579 %{_mandir}/man3/RAND_*.3*
580 %{_mandir}/man3/RC4*.3*
581 %{_mandir}/man3/RIPEMD160*.3*
582 %{_mandir}/man3/RSAPrivateKey_*.3*
583 %{_mandir}/man3/RSAPublicKey_*.3*
584 %{_mandir}/man3/RSA_*.3*
585 %{_mandir}/man3/SCRYPT_PARAMS*.3*
586 %{_mandir}/man3/SCT_*.3*
587 %{_mandir}/man3/SHA1*.3*
588 %{_mandir}/man3/SHA224*.3*
589 %{_mandir}/man3/SHA256*.3*
590 %{_mandir}/man3/SHA384*.3*
591 %{_mandir}/man3/SHA512*.3*
592 %{_mandir}/man3/SMIME_*.3*
593 %{_mandir}/man3/SSL_*.3*
594 %{_mandir}/man3/SSLv23_*.3*
595 %{_mandir}/man3/SSLv3_*.3*
596 %{_mandir}/man3/SXNET_*.3*
597 %{_mandir}/man3/SXNETID_*.3*
598 %{_mandir}/man3/TLS_*.3*
599 %{_mandir}/man3/TLSv1_*.3*
600 %{_mandir}/man3/TS_*.3*
601 %{_mandir}/man3/UI*.3*
602 %{_mandir}/man3/USERNOTICE_*.3*
603 %{_mandir}/man3/X509_*.3*
604 %{_mandir}/man3/X509V3_*.3*
605 %{_mandir}/man3/X509v3_*.3*
606 %{_mandir}/man3/custom_ext_*.3*
607 %{_mandir}/man3/d2i_*.3*
608 %{_mandir}/man3/i2d_*.3*
609 %{_mandir}/man3/i2o_*.3*
610 %{_mandir}/man3/i2t_*.3*
611 %{_mandir}/man3/lh_TYPE_*.3*
612 %{_mandir}/man3/o2i_*.3*
613 %{_mandir}/man3/pem_password_cb.3*
614 %{_mandir}/man3/sk_TYPE_*.3*
615 %{_mandir}/man3/ssl_ct_validation_cb.3*
616 %{_mandir}/man7/openssl.7*
617 %{_mandir}/man7/openssl-bio.7*
618 %{_mandir}/man7/openssl-crypto.7*
619 %{_mandir}/man7/openssl-ct.7*
620 %{_mandir}/man7/openssl-des_modes.7*
621 %{_mandir}/man7/openssl-Ed25519.7*
622 %{_mandir}/man7/openssl-Ed448.7*
623 %{_mandir}/man7/openssl-evp.7*
624 %{_mandir}/man7/openssl-passphrase-encoding.7*
625 %{_mandir}/man7/openssl-RAND.7*
626 %{_mandir}/man7/openssl-RAND_DRBG.7*
627 %{_mandir}/man7/openssl-scrypt.7*
628 %{_mandir}/man7/openssl-SM2.7*
629 %{_mandir}/man7/openssl-ssl.7*
630 %{_mandir}/man7/openssl-X25519.7*
631 %{_mandir}/man7/openssl-X448.7*
632 %{_mandir}/man7/openssl-x509.7*
633 %{_mandir}/man7/ossl_store.7*
634 %{_mandir}/man7/ossl_store-file.7*
635 %{_mandir}/man7/proxy-certificates.7*
636 %{_mandir}/man7/RSA-PSS.7.gz
637
638 %files static
639 %defattr(644,root,root,755)
640 %{_libdir}/libcrypto.a
641 %{_libdir}/libssl.a
This page took 0.061412 seconds and 2 git commands to generate.