]> git.pld-linux.org Git - packages/openssl.git/blob - openssl.spec
9f038e21f9150bc0a2cb5055fa363c4c766519af
[packages/openssl.git] / openssl.spec
1 # TODO
2 # - consider dropping last optflags.patch hunk and return to SOMAJOR (.so.1) sonames
3 #
4 # Conditional build:
5 %bcond_without  tests   # don't perform "make tests"
6 %bcond_with     purify  # Compile openssl with \-DPURIFY, useful when one wants to
7                         # use valgrind debugger against openssl-linked programs
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        OpenSSL Toolkit libraries for the "Secure Sockets Layer" (SSL v2/v3)
11 Summary(de.UTF-8):      Secure Sockets Layer (SSL)-Kommunikationslibrary
12 Summary(es.UTF-8):      Biblioteca C que suministra algoritmos y protocolos criptográficos
13 Summary(fr.UTF-8):      Utilitaires de communication SSL (Secure Sockets Layer)
14 Summary(pl.UTF-8):      Biblioteki OpenSSL (SSL v2/v3)
15 Summary(pt_BR.UTF-8):   Uma biblioteca C que fornece vários algoritmos e protocolos criptográficos
16 Summary(ru.UTF-8):      Библиотеки и утилиты для соединений через Secure Sockets Layer
17 Summary(uk.UTF-8):      Бібліотеки та утиліти для з'єднань через Secure Sockets Layer
18 Name:           openssl
19 Version:        1.0.1i
20 Release:        2
21 License:        Apache-like
22 Group:          Libraries
23 Source0:        ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
24 # Source0-md5:  c8dc151a671b9b92ff3e4c118b174972
25 Source2:        %{name}.1.pl
26 Source3:        %{name}-ssl-certificate.sh
27 Source4:        %{name}-c_rehash.sh
28 Patch0:         %{name}-alpha-ccc.patch
29 Patch1:         %{name}-optflags.patch
30 Patch2:         %{name}-globalCA.diff
31 Patch3:         %{name}-include.patch
32 Patch4:         %{name}-man-namespace.patch
33 Patch5:         %{name}-asflag.patch
34 Patch6:         %{name}-ca-certificates.patch
35 Patch7:         %{name}-ldflags.patch
36 Patch8:         %{name}-find.patch
37 Patch9:         %{name}-CVE-2014-3566.patch
38 # from debian
39 Patch10:        default_bits.patch
40 Patch11:        pic.patch
41 Patch12:        stddef.patch
42 URL:            http://www.openssl.org/
43 BuildRequires:  bc
44 BuildRequires:  perl-devel >= 1:5.6.1
45 BuildRequires:  rpm-perlprov >= 4.1-13
46 BuildRequires:  rpmbuild(macros) >= 1.213
47 BuildRequires:  sed >= 4.0
48 Requires:       ca-certificates >= 20080809-4
49 Requires:       rpm-whiteout >= 1.7
50 Obsoletes:      SSLeay
51 Obsoletes:      SSLeay-devel
52 Obsoletes:      SSLeay-perl
53 Obsoletes:      libopenssl0
54 Conflicts:      neon < 0.29.6-8
55 Conflicts:      openssh-clients < 2:6.2p2-3
56 Conflicts:      openssh-server < 2:6.2p2-3
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 The OpenSSL Project is a collaborative effort to develop a robust,
61 commercial-grade, full-featured, and Open Source toolkit implementing
62 the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
63 v1) protocols with full-strength cryptography world-wide. The project
64 is managed by a worldwide community of volunteers that use the
65 Internet to communicate, plan, and develop the OpenSSL tookit and its
66 related documentation.
67
68 OpenSSL is based on the excellent SSLeay library developed by Eric A.
69 Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
70 Apache-style licence, which basically means that you are free to get
71 and use it for commercial and non-commercial purposes subject to some
72 simple license conditions.
73
74 This package contains shared libraries only, install openssl-tools if
75 you want to use openssl cmdline tool.
76
77 %description -l de.UTF-8
78 Openssl enthält das OpenSSL Zertifikatsmanagementtool und shared
79 libraries, die verschiedene Verschlüsselungs- und
80 Entschlüsselungsalgorithmen und -protokolle, wie DES, RC4, RSA und SSL
81 zur Verfügung stellen.
82
83 %description -l es.UTF-8
84 Biblioteca C que suministra algoritmos y protocolos criptográficos.
85
86 %description -l fr.UTF-8
87 OpenSSL est un outiil de gestion des certificats et les librairies
88 partagees qui fournit plusieurs protocoles et algorithmes de
89 codage/decodage, incluant DES, RC4, RSA et SSL.
90
91 %description -l pl.UTF-8
92 Implementacja protokołów kryptograficznych Secure Socket Layer (SSL)
93 v2/v3 oraz Transport Layer Security (TLS v1).
94
95 %description -l pt_BR.UTF-8
96 Uma biblioteca C que fornece vários algoritmos e protocolos
97 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas
98 compartilhadas e utilitários.
99
100 %description -l ru.UTF-8
101 Программа openssl для работы с сертификатами и разделяемые библиотеки,
102 которые реализуют множетсво криптографических алгоритмов, включая DES,
103 RC4, RSA и SSL.
104
105 %description -l uk.UTF-8
106 Програма openssl для роботи з сертифікатами та бібліотеки спільного
107 користування, що реалізують велику кількість криптографічних
108 алгоритмів, включаючи DES, RC4, RSA та SSL.
109
110 %package engines
111 Summary:        OpenSSL optional crypto engines
112 Summary(pl.UTF-8):      Opcjonalne silniki kryptograficzne dla OpenSSL-a
113 Group:          Libraries
114 Requires:       %{name} = %{version}-%{release}
115
116 %description engines
117 With OpenSSL 0.9.6, a new component was added to support alternative
118 cryptography implementations, most commonly for interfacing with
119 external crypto devices (eg. accelerator cards). This component is
120 called ENGINE.
121
122 There are currently built-in ENGINE implementations for the following
123 crypto devices:
124
125 - CryptoSwift
126 - Compaq Atalla
127 - nCipher CHIL
128 - Nuron
129 - Broadcom uBSec
130
131 In addition, dynamic binding to external ENGINE implementations is now
132 provided by a special ENGINE called "dynamic".
133
134 %description engines -l pl.UTF-8
135 Począwszy od OpenSSL-a 0.9.6 został dodany nowy komponent, mający
136 wspierać alternatywne implementacje kryptografii, przeważnie
137 współpracujące z zewnętrznymi urządzeniami kryptograficznymi (np.
138 kartami akceleratorów). Komponent ten jest nazywany SILNIKIEM (ang.
139 ENGINE).
140
141 Obecnie istnieją wbudowane implementacje silników dla następujących
142 urządzeń kryptograficznych:
143 - CryptoSwift
144 - Compaq Atalla
145 - nCipher CHIL
146 - Nuron
147 - Broadcom uBSec
148
149 Ponadto zapewnione jest dynamiczne wiązanie dla zewnętrznych
150 implementacji silników poprzez specjalny silnik o nazwie "dynamic".
151
152 %package tools
153 Summary:        OpenSSL command line tool and utilities
154 Summary(pl.UTF-8):      Zestaw narzędzi i skryptów
155 Group:          Applications/Communications
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       which
158
159 %description tools
160 The OpenSSL Toolkit cmdline tool openssl and utility scripts.
161
162 %description tools -l pl.UTF-8
163 Zestaw narzędzi i skryptów wywoływanych z linii poleceń.
164
165 %package tools-perl
166 Summary:        OpenSSL utilities written in Perl
167 Summary(pl.UTF-8):      Narzędzia OpenSSL napisane w perlu
168 Group:          Applications/Communications
169 Requires:       %{name} = %{version}-%{release}
170
171 %description tools-perl
172 OpenSSL Toolkit tools written in Perl.
173
174 %description tools-perl -l pl.UTF-8
175 Narzędzia OpenSSL napisane w perlu.
176
177 %package devel
178 Summary:        Development part of OpenSSL Toolkit libraries
179 Summary(de.UTF-8):      Secure Sockets Layer Kommunikationslibrary: statische libraries+header
180 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para desarrollo OpenSSL
181 Summary(fr.UTF-8):      Librairies statiques, headers et utilitaires pour communication SSL
182 Summary(pl.UTF-8):      Część bibiloteki OpenSSL przeznaczona dla programistów
183 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento OpenSSL
184 Summary(ru.UTF-8):      Библиотеки, хедеры и утилиты для Secure Sockets Layer
185 Summary(uk.UTF-8):      Бібліотеки, хедери та утиліти для Secure Sockets Layer
186 Group:          Development/Libraries
187 Requires:       %{name} = %{version}-%{release}
188 Obsoletes:      libopenssl0-devel
189
190 %description devel
191 Development part of OpenSSL library.
192
193 %description devel -l es.UTF-8
194 Bibliotecas y archivos de inclusión para desarrollo OpenSSL
195
196 %description devel -l pl.UTF-8
197 Część biblioteki OpenSSL przeznaczona dla programistów.
198
199 %description devel -l pt_BR.UTF-8
200 Uma biblioteca C que fornece vários algoritmos e protocolos
201 criptográficos, incluindo DES, RC4, RSA e SSL. Inclui bibliotecas e
202 arquivos de inclusão para desenvolvimento.
203
204 %description devel -l ru.UTF-8
205 Программа openssl для работы с сертификатами и разделяемые библиотеки,
206 которые реализуют множетсво криптографических алгоритмов, включая DES,
207 RC4, RSA и SSL. Включает библиотеки и хедеры для разработки приложений
208 с использованием SSL.
209
210 %description devel -l uk.UTF-8
211 Програма openssl для роботи з сертифікатами та бібліотеки спільного
212 користування, що реалізують велику кількість криптографічних
213 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить бібліотеки та
214 хедери для розробки програм з використанням SSL.
215
216 %package static
217 Summary:        Static OpenSSL libraries
218 Summary(pl.UTF-8):      Statyczne wersje bibliotek z OpenSSL
219 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com openssl
220 Summary(ru.UTF-8):      Статические библиотеки разработчика для OpenSSL
221 Summary(uk.UTF-8):      Статичні бібліотеки програміста для OpenSSL
222 Group:          Development/Libraries
223 Requires:       %{name}-devel = %{version}-%{release}
224
225 %description static
226 Static OpenSSL Toolkit libraries.
227
228 %description static -l pl.UTF-8
229 Statyczne wersje bibliotek z OpenSSL.
230
231 %description static -l pt_BR.UTF-8
232 Bibliotecas estáticas para desenvolvimento com openssl.
233
234 %description static -l ru.UTF-8
235 Программа openssl для работы с сертификатами и разделяемые библиотеки,
236 которые реализуют множетсво криптографических алгоритмов, включая DES,
237 RC4, RSA и SSL. Включает статические библиотеки для разработки
238 приложений с использованием OpenSSL.
239
240 %description static -l uk.UTF-8
241 Програма openssl для роботи з сертифікатами та бібліотеки спільного
242 користування, що реалізують велику кількість криптографічних
243 алгоритмів, включаючи DES, RC4, RSA та SSL. Містить статичні
244 бібліотеки для розробки програм з використанням SSL.
245
246 %prep
247 %setup -q
248 %patch0 -p1
249 %patch1 -p1
250 %patch2 -p1
251 %patch3 -p1
252 %patch4 -p1
253 %patch5 -p1
254 %patch6 -p1
255 %patch7 -p1
256 %patch8 -p1
257 %patch9 -p1
258 %patch10 -p1
259 %patch11 -p1
260 %patch12 -p1
261
262 sed -i -e 's|\$prefix/\$libdir/engines|/%{_lib}/engines|g' Configure
263
264 %build
265 touch Makefile.*
266
267 %{__perl} util/perlpath.pl %{__perl}
268
269 OPTFLAGS="%{rpmcflags} %{rpmcppflags} %{?with_purify:-DPURIFY}" \
270 PERL="%{__perl}" \
271 %{__perl} ./Configure \
272         --openssldir=%{_sysconfdir}/%{name} \
273         --libdir=%{_lib} \
274         shared \
275         threads \
276         zlib \
277         enable-tlsext \
278         enable-seed \
279         enable-rfc3779 \
280         enable-camelia \
281         enable-cms \
282         enable-idea \
283         enable-mdc2 \
284         enable-md2 \
285         enable-rc5 \
286 %ifarch %{ix86}
287 %ifarch i386
288         386 linux-elf
289 # ^- allow running on 80386 (default code uses bswapl available on i486+)
290 %else
291         linux-elf
292 %endif
293 %endif
294 %ifarch alpha
295         linux-alpha+bwx-gcc
296 %endif
297 %ifarch %{x8664}
298         linux-x86_64
299 %endif
300 %ifarch ia64
301         linux-ia64
302 %endif
303 %ifarch ppc
304         linux-ppc
305 %endif
306 %ifarch ppc64
307         linux-ppc64
308 %endif
309 %ifarch sparc
310         linux-sparcv8
311 %endif
312 %ifarch sparcv9
313         linux-sparcv9
314 %endif
315 %ifarch sparc64
316         linux64-sparcv9
317 %endif
318 %ifarch armv4 armv5 armv5t armv5te armv5tel
319         linux-armv4
320 %endif
321
322 %{__make} -j1 all rehash %{?with_tests:tests} \
323         CC="%{__cc}" \
324         ASFLAG='$(CFLAG) -Wa,--noexecstack' \
325         INSTALLTOP=%{_prefix}
326
327 # Rename POD sources of man pages. "openssl_" prefix is added to each
328 # manpage to avoid potential conflicts with other packages.
329
330 for dir in doc/{apps,ssl,crypto}; do
331         cd $dir || exit 1;
332         %{__perl} -pi -e 's/(\W)((?<!openssl_)\w+)(\(\d\))/$1openssl_$2$3/g; s/openssl_openssl/openssl/g;' *.pod;
333
334         for pod in !(openssl*).pod; do
335                 mv -f $pod openssl_$pod;
336         done
337         cd ../..
338 done
339
340 %install
341 rm -rf $RPM_BUILD_ROOT
342 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}} \
343         $RPM_BUILD_ROOT{%{_mandir}/{pl/man1,man{1,3,5,7}},%{_datadir}/ssl} \
344         $RPM_BUILD_ROOT/%{_lib}/engines \
345         $RPM_BUILD_ROOT%{_pkgconfigdir}
346
347 %{__make} -j1 install \
348         INSTALLTOP=%{_prefix} \
349         INSTALL_PREFIX=$RPM_BUILD_ROOT \
350         MANDIR=%{_mandir}
351
352 mv -f $RPM_BUILD_ROOT%{_libdir}/engines/* $RPM_BUILD_ROOT/%{_lib}/engines
353 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
354 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcrypto.*.*) $RPM_BUILD_ROOT%{_libdir}/libcrypto.so
355 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libssl.*.*) $RPM_BUILD_ROOT%{_libdir}/libssl.so
356
357 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc/* $RPM_BUILD_ROOT%{_libdir}/%{name}
358 rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/misc
359
360 # not installed as individual utilities (see openssl dgst instead)
361 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{md2,md4,md5,mdc2,ripemd160,sha,sha1}.1
362
363 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/openssl.1
364 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/ssl-certificate
365 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/c_rehash.sh
366
367 %clean
368 rm -rf $RPM_BUILD_ROOT
369
370 %post   -p /sbin/ldconfig
371 %postun -p /sbin/ldconfig
372
373 %triggerpostun -- %{name}-tools < 1.0.0-5
374 # the hashing format has changed in 1.0.0
375 [ ! -x %{_sbindir}/update-ca-certificates ] || %{_sbindir}/update-ca-certificates --fresh || :
376
377 %triggerpostun -- %{name} < 0.9.8i-2
378 # don't do anything on --downgrade
379 if [ $1 -le 1 ]; then
380         exit 0
381 fi
382 if [ -d /var/lib/openssl/certs ] ; then
383         mv /var/lib/openssl/certs/* %{_sysconfdir}/%{name}/certs 2>/dev/null || :
384 fi
385 if [ -d /var/lib/openssl/private ] ; then
386         mv /var/lib/openssl/private/* %{_sysconfdir}/%{name}/private 2>/dev/null || :
387 fi
388 if [ -d /var/lib/openssl ] ; then
389         for f in /var/lib/openssl/* ; do
390                 [ -f "$f" ] && mv "$f" %{_sysconfdir}/%{name} 2>/dev/null || :
391         done
392         rmdir /var/lib/openssl/* 2>/dev/null || :
393         rmdir /var/lib/openssl 2>/dev/null || :
394 fi
395
396 %files
397 %defattr(644,root,root,755)
398 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README doc/*.txt
399 %doc doc/openssl_button.gif doc/openssl_button.html
400 %attr(755,root,root) /%{_lib}/libcrypto.so.*.*.*
401 %attr(755,root,root) /%{_lib}/libssl.so.*.*.*
402 %dir %{_sysconfdir}/%{name}
403 %dir %{_sysconfdir}/%{name}/certs
404 %dir %{_sysconfdir}/%{name}/private
405 %dir %{_datadir}/ssl
406
407 %files engines
408 %defattr(644,root,root,755)
409 %dir /%{_lib}/engines
410 %attr(755,root,root) /%{_lib}/engines/*.so
411
412 %files tools
413 %defattr(644,root,root,755)
414 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/openssl.cnf
415 %attr(755,root,root) %{_bindir}/c_rehash.sh
416 %attr(755,root,root) %{_bindir}/openssl
417 %attr(754,root,root) %{_bindir}/ssl-certificate
418
419 %dir %{_libdir}/%{name}
420 %attr(755,root,root) %{_libdir}/%{name}/CA.sh
421 %attr(755,root,root) %{_libdir}/%{name}/c_hash
422 %attr(755,root,root) %{_libdir}/%{name}/c_info
423 %attr(755,root,root) %{_libdir}/%{name}/c_issuer
424 %attr(755,root,root) %{_libdir}/%{name}/c_name
425
426 %{_mandir}/man1/openssl.1*
427 %{_mandir}/man1/openssl_asn1parse.1*
428 %{_mandir}/man1/openssl_ca.1*
429 %{_mandir}/man1/openssl_ciphers.1*
430 %{_mandir}/man1/openssl_cms.1*
431 %{_mandir}/man1/openssl_crl.1*
432 %{_mandir}/man1/openssl_crl2pkcs7.1*
433 %{_mandir}/man1/openssl_dgst.1*
434 %{_mandir}/man1/openssl_dhparam.1*
435 %{_mandir}/man1/openssl_dsa.1*
436 %{_mandir}/man1/openssl_dsaparam.1*
437 %{_mandir}/man1/openssl_ec.1*
438 %{_mandir}/man1/openssl_ecparam.1*
439 %{_mandir}/man1/openssl_enc.1*
440 %{_mandir}/man1/openssl_errstr.1*
441 %{_mandir}/man1/openssl_gendsa.1*
442 %{_mandir}/man1/openssl_genpkey.1*
443 %{_mandir}/man1/openssl_genrsa.1*
444 %{_mandir}/man1/openssl_nseq.1*
445 %{_mandir}/man1/openssl_ocsp.1*
446 %{_mandir}/man1/openssl_passwd.1*
447 %{_mandir}/man1/openssl_pkcs12.1*
448 %{_mandir}/man1/openssl_pkcs7.1*
449 %{_mandir}/man1/openssl_pkcs8.1*
450 %{_mandir}/man1/openssl_pkey.1*
451 %{_mandir}/man1/openssl_pkeyparam.1*
452 %{_mandir}/man1/openssl_pkeyutl.1*
453 %{_mandir}/man1/openssl_rand.1*
454 %{_mandir}/man1/openssl_req.1*
455 %{_mandir}/man1/openssl_rsa.1*
456 %{_mandir}/man1/openssl_rsautl.1*
457 %{_mandir}/man1/openssl_s_client.1*
458 %{_mandir}/man1/openssl_s_server.1*
459 %{_mandir}/man1/openssl_s_time.1*
460 %{_mandir}/man1/openssl_sess_id.1*
461 %{_mandir}/man1/openssl_smime.1*
462 %{_mandir}/man1/openssl_speed.1*
463 %{_mandir}/man1/openssl_spkac.1*
464 %{_mandir}/man1/openssl_ts.1*
465 %{_mandir}/man1/openssl_tsget.1*
466 %{_mandir}/man1/openssl_verify.1*
467 %{_mandir}/man1/openssl_version.1*
468 %{_mandir}/man1/openssl_x509.1*
469 %{_mandir}/man5/openssl_config.5*
470 %{_mandir}/man5/openssl_x509v3_config.5*
471 %lang(pl) %{_mandir}/pl/man1/openssl.1*
472
473 %files tools-perl
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{_bindir}/c_rehash
476 %attr(755,root,root) %{_libdir}/%{name}/CA.pl
477 %attr(755,root,root) %{_libdir}/%{name}/tsget
478 %{_mandir}/man1/openssl_CA.pl.1*
479
480 %files devel
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{_libdir}/libcrypto.so
483 %attr(755,root,root) %{_libdir}/libssl.so
484 %{_includedir}/%{name}
485 %{_pkgconfigdir}/libcrypto.pc
486 %{_pkgconfigdir}/libssl.pc
487 %{_pkgconfigdir}/openssl.pc
488 %{_mandir}/man3/openssl*.3*
489 %{_mandir}/man7/openssl_des_modes.7*
490
491 %files static
492 %defattr(644,root,root,755)
493 %{_libdir}/libcrypto.a
494 %{_libdir}/libssl.a
This page took 0.063955 seconds and 2 git commands to generate.